DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUGĀ·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37566>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED ANDĀ·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37566

           Summary: Write message to error log if AuthGroupFile cannot be
                    opened.
           Product: Apache httpd-2.0
           Version: 2.0.55
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_auth
        AssignedTo: [email protected]
        ReportedBy: [EMAIL PROTECTED]


Today I hunted 20 minutes for a typo in the filename of an AuthGroupFile
setting, because I got only an Internal Server Error when accesing the
protected location, but no message in the error log. Having a look in the
code I detected that

1. There is an commented call to aplog_error in groups_for_user of
   mod_auth.

2. groups_for_user in mod_auth_digest prints a message to the error log
   if the group file cannot be opened.

I see no reason, why this is not done for groups_for_user in mod_auth.
The attached patch fixes this.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to