On Thu, Dec 10, 2009 at 1:22 PM, Evan Stade <est...@chromium.org> wrote:

> On Thu, Dec 10, 2009 at 10:58 AM, Peter Kasting <pkast...@google.com>wrote:
>
>> On Thu, Dec 10, 2009 at 10:45 AM, Jonathan Dixon <j...@chromium.org>wrote:
>>
>>> In essence:
>>>
>>> return DoWork(&foo)
>>> #if defined(OS_POSIX)
>>>     && DoWork(&posix_specific)
>>> #endif
>>>     ;  // <-- Lint complains about this guy
>>>
>>
>> I'd prefer this:
>>
>> #if defined(OS_POSIX)
>>   return DoWork(&foo) && DoWork(&posix_specific);
>> #else
>>   return DoWork(&foo);
>> #endif
>>
>> The same number of lines, but much easier to read.
>>
>
> disagree. It's harder to read because it's not immediately obvious that
> some of the code overlaps. Scott's solution seems best to me.
>

+1 Scott's solution seems best for me.  The problem with the above solution
is that it contains code duplication.  For DoWork(&foo), that might seem
small, but as parameters get added, functions get renamed, etc, it's more
work (and error prone) to update two locations instead of one.


>
>>
>> PK
>>
>
>

-- 
Chromium Developers mailing list: chromium-dev@googlegroups.com 
View archives, change email options, or unsubscribe: 
    http://groups.google.com/group/chromium-dev

Reply via email to