Hi,

attached patch adds more variables (bytes_served and access_count) into 
ap_sload_t struct introduced in revision 1389481.

The intention is to have standard method to get number of total bytes_served 
and access_count without code duplication.

Thanks for reviewing,
Jan Kaluza
Index: server/util.c
===================================================================
--- server/util.c	(revision 1389886)
+++ server/util.c	(working copy)
@@ -2802,6 +2802,8 @@
     /* preload errored fields, we overwrite */
     ld->idle = -1;
     ld->busy = -1;
+    ld->bytes_served = 0;
+    ld->access_count = 0;
 
     ap_mpm_query(AP_MPMQ_GENERATION, &mpm_generation);
     ap_mpm_query(AP_MPMQ_HARD_LIMIT_THREADS, &thread_limit);
@@ -2825,6 +2827,14 @@
                      ps->generation == mpm_generation) {
                 busy++;
             }
+
+            if (ap_extended_status && !ps->quiescing && ps->pid) {
+                if (ws->access_count != 0 || 
+                    (res != SERVER_READY && res != SERVER_DEAD)) {
+                    ld->access_count += ws->access_count;
+                    ld->bytes_served += ws->bytes_served;
+                }
+            }
         }
     }
     total = busy + ready;
Index: include/httpd.h
===================================================================
--- include/httpd.h	(revision 1389886)
+++ include/httpd.h	(working copy)
@@ -1308,6 +1308,10 @@
     int idle;
     /* percentage of process/threads busy (0->100) */
     int busy;
+    /* total bytes served */
+    apr_off_t bytes_served;
+    /* total access count */
+    unsigned long access_count;
 };
 
 /**

Reply via email to