Hi,

I'm trying to remove a lot of iterators, and use the for-each syntax, which exists since java 1.5.
During my journey, I found a lot of double tests for a while like this one:

while (typePurposes != null && typePurposes.hasNext()) {
(ContactMechWorker.java line 606)

Can it be simplified to for(GenericValue contactMechTypePurpose : theList) ? Or should I keep it like it is ?

Regards,

--
Erwan de FERRIERES
www.nereide.biz

Reply via email to