* John Denker -- Thursday 05 November 2009:
> By way of pathetic non-excuse, let me remark that a few
> years ago I was rather authoritatively flamed for daring
> to put comments in FGFS code.

That's rather misleading. In fact you were criticized for:

- putting whole gdb stack traces(!) before several functions in a file
- "outdenting" comments within functions, thus making it harder to
  see the code's logical structure
- adding needlessly verbose comments, while one the other hand ...
- using bad variable names in the code, like nnn, ttt, iii in just a
  few lines of code. Here's an example from your patch:

  +  nnn = props.globals.getNode("/sim/presets/" ~ varname, 1);
  +  ttt = nnn.getType();
  +  value = nnn.getValue();

  Could have been "node" and "type". Or just "n" and "t".
  But long *and* meaningless seemed like a bad combination. You
  were invited to resubmit your patch with the points fixed, and
  you chose not to. That's all.

m.



PS: beware: I can back that up with links to the archive!

------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day 
trial. Simplify your report design, integration and deployment - and focus on 
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel

Reply via email to