https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70670

            Bug ID: 70670
           Summary: Duplicate code in rs6000_secondary_reload_direct_move
                    in rs6000.c
           Product: gcc
           Version: 6.0
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: target
          Assignee: unassigned at gcc dot gnu.org
          Reporter: meissner at gcc dot gnu.org
  Target Milestone: ---

In tracking down the bug in 70669, I noticed that
rs6000_secondary_reload_direct_move has duplicated code.

The code looks like:

  if (TARGET_POWERPC64)
    {
      if (size == 16)
        {
             // ...
        }

      else if (mode == SFmode)
        {
             // ...
        }
    }

  if (TARGET_POWERPC64 && size == 16)
    {
       // ...
    }

Where the code in the second if is identical to the code in the first if if the
size is 16 bytes.

Reply via email to