On 01/30/13 21:50, Jeff King wrote:
>
> The strbuf_read above will read to EOF, so it should be equivalent (and
> IMHO slightly more readable) to do:
>
> diff --git a/gpg-interface.c b/gpg-interface.c
> index 0863c61..5f142f6 100644
> --- a/gpg-interface.c
> +++ b/gpg-interface.c
> @@ -130,8 +130,10 @@ int verify_signed_buffer(const char *payload, size_t 
> payload_size,
>       write_in_full(gpg.in, payload, payload_size);
>       close(gpg.in);
>  
> -     if (gpg_output)
> +     if (gpg_output) {
>               strbuf_read(gpg_output, gpg.err, 0);
> +             close(gpg.err);
> +     }
>       ret = finish_command(&gpg);
>  
>       unlink_or_warn(path);
>
> But that is a minor nit; either way, the patch looks good to me.

Looks better. I'll resend with this.

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
hosted by The Linux Foundation

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to