From: Junio C Hamano <gits...@pobox.com>
>
> Christian Couder <chrisc...@tuxfamily.org> writes:
> 
>> +    enum action_if_exist if_exist;
>> +    enum action_if_missing if_missing;
> 
> Probably "if_exists" is more gramatically correct.
> 
>       if (x->if_exists) {
>               ... do this ...
>       }
> 
> would read well, but not "x->if_exist".                

Ok, I will use "if_exists" instead of "if_exist" and also:

enum action_if_exists { EXISTS_ADD_IF_DIFFERENT, 
EXISTS_ADD_IF_DIFFERENT_NEIGHBOR,
                        EXISTS_ADD, EXISTS_OVERWRITE, EXISTS_DO_NOTHING };

instead of:

enum action_if_exist { EXIST_ADD_IF_DIFFERENT, EXIST_ADD_IF_DIFFERENT_NEIGHBOR,
                        EXIST_ADD, EXIST_OVERWRITE, EXIST_DO_NOTHING };

to be consistent.

Thanks,
Christian.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to