From: Nishchal <nishga...@gmail.com>

I am Nishchal Gaba, a GSOC 2014 aspirant, submitting patch in response to 
microproject(8)
Similar Execution Time, but increased readability

Alternate Solution Discarded: Table driven code using commonanilty of the 
statements to be printed due to _()

Signed-off-by: Nishchal Gaba <nishga...@gmail.com>
---
---
 branch.c | 28 +++++++++++++++++-----------
 1 file changed, 17 insertions(+), 11 deletions(-)

diff --git a/branch.c b/branch.c
index 723a36b..04e9e24 100644
--- a/branch.c
+++ b/branch.c
@@ -77,26 +77,32 @@ void install_branch_config(int flag, const char *local, 
const char *origin, cons
        strbuf_release(&key);
 
        if (flag & BRANCH_CONFIG_VERBOSE) {
-               if (remote_is_branch && origin)
-                       printf_ln(rebasing ?
+               if (origin){
+                       if(remote_is_branch)
+                               printf_ln(rebasing ?
                                  _("Branch %s set up to track remote branch %s 
from %s by rebasing.") :
                                  _("Branch %s set up to track remote branch %s 
from %s."),
                                  local, shortname, origin);
-               else if (remote_is_branch && !origin)
-                       printf_ln(rebasing ?
-                                 _("Branch %s set up to track local branch %s 
by rebasing.") :
-                                 _("Branch %s set up to track local branch 
%s."),
-                                 local, shortname);
-               else if (!remote_is_branch && origin)
-                       printf_ln(rebasing ?
+                       else
+                               printf_ln(rebasing ?
                                  _("Branch %s set up to track remote ref %s by 
rebasing.") :
                                  _("Branch %s set up to track remote ref %s."),
                                  local, remote);
-               else if (!remote_is_branch && !origin)
-                       printf_ln(rebasing ?
+               }
+
+               else if (!origin){
+                       if(remote_is_branch)
+                               printf_ln(rebasing ?
+                                 _("Branch %s set up to track local branch %s 
by rebasing.") :
+                                 _("Branch %s set up to track local branch 
%s."),
+                                 local, shortname);
+                       else
+                               printf_ln(rebasing ?
                                  _("Branch %s set up to track local ref %s by 
rebasing.") :
                                  _("Branch %s set up to track local ref %s."),
                                  local, remote);
+               }
+
                else
                        die("BUG: impossible combination of %d and %p",
                            remote_is_branch, origin);
-- 
1.8.1.2

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to