Hello.

Jason Wessel wrote:

>>> As it turns out, the mess is added by i386.patch and can be fixed by
>>> forcibly selecting
>>> KGDB_ARCH_HAS_HARDWARE_BREAKPOINTS for X86 case. However, neither
>>> "for_akpm" nor "testing" kgdb git trees have the functions added by
>>> i386.patch from "staging" tree, while "master" tree has these, but
>>> doesn't define KGDB_ARCH_HAS_HARDWARE_BREAKPOINTS at all. The whole
>>> situation seems a bit of a mess for me, so can you please tell me if
>>> I'm not getting something and explain me what is meant initially by
>>> all these differences, what variant to stick to etc.

>>    While this doesn't seem to be an issue with the 2.6.21 CVS branch, 
>> i386.patch looks there starnge indeed.
>> It doesn't look like it has the *complete* h/w breakpoint support and 
>> it doesn't enable KGDB_ARCH_HAS_HARDWARE_BREAKPOINTS option. Well, 
>> this option looks a bit strange as well as it has a help text 
>> suggesting it should be selectable (and arch/i386/kernel/kgdb.c also 
>> suggests it) but it's *not* selectable. Looks messy. :-]

> I had merged the i386.patch from the master tree and fixed it so it 
> would compile in the 2.6.21 uprev branch.  Upon inspecting the code, it 
> does look like it probably has chunks missing.

    Yes, there's not actual writes to the debug registers...

> Where is the appropriate source of the patch?  It should be easy enough 
> to re-merge, if it can be located.  The version in HEAD on source forge 
> looked the same as the version in the git master tree.

    Well, i386-core.patch in the former Tom's master tree does have some h/w 
breakpoint code -- looks like it hasn't been clearly separated.

> FYI: the fix for the config is this, and I'll go ahead and commit it, 
> until I hear back about a better source for the hw breakpoint patch.

> Jason.

> ------------------------------------------------------------------------

> ---
>  lib/Kconfig.kgdb |    4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> Index: linux-2.6.21-standard/lib/Kconfig.kgdb
> ===================================================================
> --- linux-2.6.21-standard.orig/lib/Kconfig.kgdb
> +++ linux-2.6.21-standard/lib/Kconfig.kgdb
> @@ -22,8 +22,8 @@ config KGDB
>         in Documentation/DocBook/.  If unsure, say N.
>  
>  config KGDB_ARCH_HAS_HARDWARE_BREAKPOINTS
> -     bool
> -     depends on KGDB
> +     bool "KGDB: allow use of hardware breakpoints"
> +     depends on KGDB || X86
>       default n
>       help
>         If you say Y here, KGDB will make use of hardware breakpoints

    Erm, I'd say KGDB_ARCH_HAS_HARDWARE_BREAKPOINTS sounds like a bad name for 
selectable option...

WBR, Sergei

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
Kgdb-bugreport mailing list
Kgdb-bugreport@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/kgdb-bugreport

Reply via email to