On Fri, 2010-12-03 at 13:42 +0000, David Howells wrote: 
> Mimi Zohar <zo...@linux.vnet.ibm.com> wrote:
> 
> > +#define KEY_TRUSTED_PREFIX "trusted:"
> > +#define KEY_TRUSTED_PREFIX_LEN (sizeof (KEY_TRUSTED_PREFIX) - 1)
> > +#define KEY_USER_PREFIX "user:"
> > +#define KEY_USER_PREFIX_LEN (sizeof (KEY_USER_PREFIX) - 1)
> 
> I'd recommend using static const char arrays.

Ok

> > +static int datablob_parse(char *datablob, char **master_desc,
> > ...
> > +           *hex_encoded_data = *hex_encoded_iv + (2 * ivsize) + 2;
> 
> Do you need to validate the length of the string here?

definitely. thanks!

> > +static struct key *request_trusted_key(const char *trusted_desc,
> > +                                  u8 **master_key,
> > +                                  unsigned int *master_keylen)
> 
> You need to annotate the function with an __acquires() to indicate that it
> returns with a lock held for Sparse checking.  I think you should be able to
> do:
> 
>       __acquires(tkey->sem)

hm, only after addding '__acquires' are there Sparse errors.

> on the line before the '{'.
> 
> > +static struct key *request_user_key(const char *master_desc, u8 
> > **master_key,
> > +                               unsigned int *master_keylen)
> 
> Ditto.
> 
> > +static struct sdesc *init_sdesc(struct crypto_shash *alg)
> > +{
> > +   struct sdesc *sdesc;
> > +   int size;
> > +
> > +   size = sizeof(struct shash_desc) + crypto_shash_descsize(alg);
> > +   sdesc = kmalloc(size, GFP_KERNEL);
> 
> I think I'd call it alloc_sdesc() rather than init_sdesc().

Ok

> > +static int calc_hmac(u8 *digest, const u8 *key, const unsigned int keylen,
> > +                const u8 *buf, const unsigned int buflen)
> 
> size_t not 'const unsigned int' please.  There are multiple of these within
> the patch.

Have reverted adding the unnecessary 'const' and converted some
additional 'unsigned int' to 'size_t', but there are still some
remaining; those used as crypto options.

> > +   sg_set_buf(&sg_out[0], epayload->decrypted_data,
> > +              (unsigned int)epayload->decrypted_datalen);
> 
> Superfluous cast.
> 
> David

thanks!

Mimi 

--
To unsubscribe from this list: send the line "unsubscribe linux-crypto" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to