Make use of the swap macro and remove unnecessary variable temp.
This makes the code easier to read and maintain.

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <garsi...@embeddedor.com>
---
 drivers/crypto/chelsio/chcr_algo.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/crypto/chelsio/chcr_algo.c 
b/drivers/crypto/chelsio/chcr_algo.c
index 936bdd8..4b508cb 100644
--- a/drivers/crypto/chelsio/chcr_algo.c
+++ b/drivers/crypto/chelsio/chcr_algo.c
@@ -1469,11 +1469,8 @@ static int chcr_ahash_update(struct ahash_request *req)
                return -ENOMEM;
 
        if (remainder) {
-               u8 *temp;
                /* Swap buffers */
-               temp = req_ctx->reqbfr;
-               req_ctx->reqbfr = req_ctx->skbfr;
-               req_ctx->skbfr = temp;
+               swap(req_ctx->reqbfr, req_ctx->skbfr);
                sg_pcopy_to_buffer(req->src, sg_nents(req->src),
                                   req_ctx->reqbfr, remainder, req->nbytes -
                                   remainder);
-- 
2.7.4

Reply via email to