On 1/29/24 06:57, Lenko Donchev wrote:
We are trying to get rid of all multiplications from allocation
functions to prevent integer overflows[1]. Here the multiplication is
obviously safe, but using kcalloc() is more appropriate and improves
readability. This patch has no effect on runtime behavior.

Link: https://github.com/KSPP/linux/issues/162 [1]
Link: 
https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
 [2]

Signed-off-by: Lenko Donchev <lenko.donc...@gmail.com>

Reviewed-by: Gustavo A. R. Silva <gustavo...@kernel.org>

Thanks!
--
Gustavo

---
  drivers/crypto/intel/qat/qat_common/adf_isr.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/crypto/intel/qat/qat_common/adf_isr.c 
b/drivers/crypto/intel/qat/qat_common/adf_isr.c
index 3557a0d6dea2..a13d9885d60f 100644
--- a/drivers/crypto/intel/qat/qat_common/adf_isr.c
+++ b/drivers/crypto/intel/qat/qat_common/adf_isr.c
@@ -272,7 +272,7 @@ static int adf_isr_alloc_msix_vectors_data(struct 
adf_accel_dev *accel_dev)
        if (!accel_dev->pf.vf_info)
                msix_num_entries += hw_data->num_banks;
- irqs = kzalloc_node(msix_num_entries * sizeof(*irqs),
+       irqs = kcalloc_node(msix_num_entries, sizeof(*irqs),
                            GFP_KERNEL, dev_to_node(&GET_DEV(accel_dev)));
        if (!irqs)
                return -ENOMEM;

Reply via email to