Hi Tomi,

On Thu, Jun 23, 2011 at 2:00 PM, Tomi Valkeinen <tomi.valkei...@ti.com> wrote:
> On Fri, 2011-06-17 at 13:47 +0530, Mythri P K wrote:
>> Define new HDMI timings structure to replace the OMAP DSS timing strucutre 
>> in hdmi.c
>> to have the HDMI include defintion out of DSS.
>>
>> Signed-off-by: Mythri P K <mythr...@ti.com>
>> ---
>>  drivers/video/omap2/dss/hdmi.c |   23 ++++++++++++++++++++---
>>  drivers/video/omap2/dss/hdmi.h |   15 ++++++++++++++-
>>  2 files changed, 34 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/video/omap2/dss/hdmi.c b/drivers/video/omap2/dss/hdmi.c
>> index 4ee879a..c24d573 100644
>> --- a/drivers/video/omap2/dss/hdmi.c
>> +++ b/drivers/video/omap2/dss/hdmi.c
>> @@ -593,6 +593,20 @@ static int read_edid(struct hdmi_ip_data *ip_data, u8 
>> *pedid, u16 max_length)
>>       return 0;
>>  }
>>
>> +static void copy_hdmi_to_dss_timings(struct hdmi_video_timings hdmi_timings,
>> +                     struct omap_video_timings *timings)
>
> There's no reason to pass hdmi_timings as a value, so it should be a
> pointer.
As the hdmi_timings is not changed in the function , i passed it by
value, Not a problem to change.
>
>> +{
>> +     timings->x_res = hdmi_timings.x_res;
>> +     timings->y_res = hdmi_timings.y_res;
>> +     timings->pixel_clock = hdmi_timings.pixel_clock;
>> +     timings->hbp = hdmi_timings.hbp;
>> +     timings->hfp = hdmi_timings.hfp;
>> +     timings->hsw = hdmi_timings.hsw;
>> +     timings->vbp = hdmi_timings.vbp;
>> +     timings->vfp = hdmi_timings.vfp;
>> +     timings->vsw = hdmi_timings.vsw;
>> +}
>> +
>>  static int get_timings_index(void)
>>  {
>>       int code;
>> @@ -617,7 +631,7 @@ static struct hdmi_cm hdmi_get_code(struct 
>> omap_video_timings *timing)
>>  {
>>       int i = 0, code = -1, temp_vsync = 0, temp_hsync = 0;
>>       int timing_vsync = 0, timing_hsync = 0;
>> -     struct omap_video_timings temp;
>> +     struct hdmi_video_timings temp;
>>       struct hdmi_cm cm = {-1};
>>       DSSDBG("hdmi_get_code\n");
>>
>> @@ -775,7 +789,8 @@ static void hdmi_read_edid(struct omap_video_timings *dp)
>
> "dp" feels a rather odd name for video timings variable. What does it
> stand for?

*display pointer, but then it is not a part of this patch.

>
>  Tomi
>
>
>



-- 
Thanks and regards,
Mythri.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to