On Mon, May 14, 2007 at 08:19:59PM +0200, Ozgur Ugras BARAN wrote:
> +bool const ControlToc::allowDemoteCurrentItem(size_t type) const
> +{
> +     return ((kernel().buffer().params().tocdepth - 
> (*getCurrentTocItem(type)).depth() + 1)>0);
> +}

On the formal side:


No need for the outer parantheses.

I moreover personally find   a + 1 > b  easier to read then  ((a - (b) + 1)>0)

There is no need for the 'const' on the return value either.

Ander'

Reply via email to