Hello all,

I'm writing a module that I dubbed "Net::Vimeo::API" for now. It's
rather self-explanatory, but just to make sure: it's supposed to be a
perl module for interfacing with the full Vimeo API (www.vimeo.com). I
am thinking about publishing it on CPAN.

It roughly goes something like this:

use Net::Vimeo::API;

my $api = new Net::Vimeo::API({'key'    => 'your_api_key',
                              'secret' => 'your_shared_secret'});

my $response = $api->execute_method('vimeo.test.echo', {
 'foo' => 'bar',
 'baz' => 'quux',
});

Now, I am writing to the list to ask about the namespace. Is it ok if
I name it Net::Vimeo::API or would it be more appropriate to name it
something else like Vimeo::API or WWW::Vimeo::API?

Your input is much appreciated.

Best,
Chris.

--
Chris Vertonghen
http://friendfeed.com/cvertonghen

Reply via email to