2009/4/15 chunlin <zhangchun...@gmail.com>:
> Apache Version :Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/
> 0.9.8e mod_autoindex_color mod_auth_sspi/1.0.4 SVN/1.4.3 mod_wsgi/2.4
> Python/2.6.1 PHP/5.2.4
> the mod_wsgi I am using is this one:
> http://code.google.com/p/modwsgi/downloads/detail?name=mod_wsgi-win32-ap22py26-2.4.so
> I have add these code to moin.wsgi but still same err
> "
> sys.path.insert(0, r'D:\Python26\Lib\site-packages')
> sys.path.insert(0, r'D:\Python26\Lib\site-packages\MoinMoin')
> sys.path.insert(0, r'D:\Python26\DLLs')
> "
> err message:
> [error] mod_wsgi (pid=3056): Target WSGI script 'E:/Moin/moin/
> moin.wsgi' cannot be loaded as Python module.
> [error] mod_wsgi (pid=3056): Exception occurred processing WSGI script
> 'E:/Moin/moin/moin.wsgi'.
> [error] Traceback (most recent call last):
> [error]   File "E:/Moin/moin/moin.wsgi", line 52, in <module>
> [error]     from MoinMoin.server.server_wsgi import WsgiConfig,
> moinmoinApp
> [error]   File "D:\\Python26\\Lib\\site-packages\\MoinMoin\\server\
> \__init__.py", line 14, in <module>
> [error]     from MoinMoin import log
> [error]   File "D:\\Python26\\Lib\\site-packages\\MoinMoin\\log.py",
> line 92, in <module>
> [error]     import logging.config
> [error]   File "D:\\Python26\\lib\\logging\\config.py", line 30, in
> <module>
> [error]     import sys, logging, logging.handlers, string, socket,
> struct, os, traceback, types
> [error]   File "D:\\Python26\\lib\\logging\\handlers.py", line 30, in
> <module>
> [error]     import logging, socket, types, os, string, cPickle,
> struct, time, re
> [error]   File "D:\\Python26\\lib\\socket.py", line 46, in <module>
> [error]     import _socket
> [error] ImportError: DLL load failed: The specified module could not
> be found.

This problem has been solved before by reinstalling Python, but using
Python 2.6.2.

When you install it, it must be installed from an account with
Administrator privilege and you must select that it be installed for
all users.

Not sure yet whether it relates to fact that mod_wsgi precompiled
module was built against Python 2.6.2, or that it is because of your
existing Python installation not being installed as an account with
Administrator privilege and/or not selecting that it be installed for
all users.

Would be nice if someone can indicate whether they are successfully
using this precompiled mod_wsgi with Python 2.6.1 rather than newer
Python 2.6.2.

If you can say whether you installed your Python from an account with
Administrator privilege and whether you selected install for all
users, would also be useful.

The reason that Python must be installed for all users is that Apache
service runs as special user normally and not as you.


You received this message because you are subscribed to the Google Groups 
"modwsgi" group.
To post to this group, send email to modwsgi@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to