Am 15.08.2018 um 08:12 schrieb Antonio Quartulli:
> The "cleanup" label in ssl_verify.c:verify_user_pass_plugin() is used
> only when PLUGIN_DEF_AUTH is defined, therefore make the label
> definition dependent on the same define.
>
> Fixes the following warning when PLUGIN_DEF_AUTH is not defined:
>
> ssl_verify.c: In function 'verify_user_pass_plugin':
> ssl_verify.c:1223:1: warning: label 'cleanup' defined but not used 
> [-Wunused-label]
>  cleanup:
>  ^~~~~~~
>
> Signed-off-by: Antonio Quartulli <a...@unstable.cc>
> ---
>  src/openvpn/ssl_verify.c | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/src/openvpn/ssl_verify.c b/src/openvpn/ssl_verify.c
> index 61872251..5b46ea72 100644
> --- a/src/openvpn/ssl_verify.c
> +++ b/src/openvpn/ssl_verify.c
> @@ -1220,7 +1220,9 @@ verify_user_pass_plugin(struct tls_session *session, 
> const struct user_pass *up,
>          msg(D_TLS_ERRORS, "TLS Auth Error (verify_user_pass_plugin): peer 
> provided a blank username");
>      }
>  
> +#ifdef PLUGIN_DEF_AUTH
>  cleanup:
> +#endif
>      return retval;
>  }
>  

NAK.

This is useless #ifdef noise in the code and makes it harder to read,
for compile-time cosmetics.

If you don't want the warnings, feed a proper -Wno-unused-label to your
compiler and move on.


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Openvpn-devel mailing list
Openvpn-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/openvpn-devel

Reply via email to