Luke Palmer wrote:

My favorite was from ages ago:

    sub bar(;$foo //= $_) {...}
I think that today that would be written more like this:

	sub bar(;$foo) is given($def_foo) {
		$foo = $def_foo unless exists $foo;
		...
	}

Though we might get away with:

	sub bar(;$foo = $def_foo) is given($def_foo) {
		...
	}


	

Or, if you stick with Perl5 convention, and I imagine this is what
people will expect from the builtins at least:

    sub bar($foo; $baz) is given($baz) {...}
I think this should definitely be a compile-time error.

Damian

Reply via email to