At Sun, 6 Sep 2009 18:59:01 -0600, Doug Williams wrote:
> Would it be better to call
> the operations 'unchecked-<whatever>' instead of 'unsafe-<whatever>'?
> Generally, we are calling the function because we know it is safe to avoid
> some constraint check - not because it is unsafe. Just a nit.

Despite the distinction between unsafety for performance and unsafety
to get at new things, I like having all unsafe operations marked the
same way. Also, "unchecked" doesn't sound dangerous enough to me.

So, you make a good point, but I'm still in favor of "unsafe".

_________________________________________________
  For list-related administrative tasks:
  http://list.cs.brown.edu/mailman/listinfo/plt-dev

Reply via email to