config.h inclusion leftovers

2006-02-24 Thread Ralf Wildenhues
The following patch changes the last files over to the agreed-to style
for inclusion of `config.h'.

Cheers,
Ralf

* lib/mkdtemp.c, lib/setenv.c, lib/unsetenv.c: Normalize
inclusion of `config.h'.

Index: lib/mkdtemp.c
===
RCS file: /cvsroot/gnulib/gnulib/lib/mkdtemp.c,v
retrieving revision 1.4
diff -u -r1.4 mkdtemp.c
--- lib/mkdtemp.c   14 May 2005 06:03:58 -  1.4
+++ lib/mkdtemp.c   22 Feb 2006 19:05:48 -
@@ -18,7 +18,7 @@
 /* Extracted from misc/mkdtemp.c and sysdeps/posix/tempname.c.  */
 
 #ifdef HAVE_CONFIG_H
-# include config.h
+# include config.h
 #endif
 
 /* Specification.  */
Index: lib/setenv.c
===
RCS file: /cvsroot/gnulib/gnulib/lib/setenv.c,v
retrieving revision 1.13
diff -u -r1.13 setenv.c
--- lib/setenv.c14 May 2005 06:03:58 -  1.13
+++ lib/setenv.c22 Feb 2006 19:05:48 -
@@ -15,7 +15,7 @@
with this program; if not, write to the Free Software Foundation,
Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.  */
 
-#if HAVE_CONFIG_H
+#ifdef HAVE_CONFIG_H
 # include config.h
 #endif
 #include alloca.h
Index: lib/unsetenv.c
===
RCS file: /cvsroot/gnulib/gnulib/lib/unsetenv.c,v
retrieving revision 1.5
diff -u -r1.5 unsetenv.c
--- lib/unsetenv.c  14 May 2005 06:03:58 -  1.5
+++ lib/unsetenv.c  22 Feb 2006 19:05:48 -
@@ -15,7 +15,7 @@
with this program; if not, write to the Free Software Foundation,
Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.  */
 
-#if HAVE_CONFIG_H
+#ifdef HAVE_CONFIG_H
 # include config.h
 #endif
 


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


small modules/ cleanup

2006-02-24 Thread Ralf Wildenhues
Two small changes:

- pacify Automake erroring out on:
  | automatically discovered file `xstrtod.h' should not be explicitly mentioned
  | automatically discovered file `xstrtod.c' should not be explicitly mentioned

- use $(EXEEXT) uniformly in TESTS (conforming to a recent agreement),
  and use check_PROGRAMS everywhere.

Cheers,
Ralf

* modules/xstrtod: Do not list xstrtod.h and xstrtod.c in
`lib_SOURCES'; they are listed in AC_LIBSOURCES already.

* modules/lock-tests, modules/tls-tests:
Use `$(EXEEXT)' in Automake variable `TESTS'.
* modules/argp-tests: Likewise.  Also change to use
`check_PROGRAMS'.

Index: modules/xstrtod
===
RCS file: /cvsroot/gnulib/gnulib/modules/xstrtod,v
retrieving revision 1.5
diff -u -r1.5 xstrtod
--- modules/xstrtod 6 May 2005 17:22:45 -   1.5
+++ modules/xstrtod 22 Feb 2006 19:03:02 -
@@ -13,7 +13,6 @@
 gl_XSTRTOD
 
 Makefile.am:
-lib_SOURCES += xstrtod.h xstrtod.c
 
 Include:
 xstrtod.h

Index: modules/argp-tests
===
RCS file: /cvsroot/gnulib/gnulib/modules/argp-tests,v
retrieving revision 1.1
diff -u -r1.1 argp-tests
--- modules/argp-tests  21 Jan 2006 19:09:06 -  1.1
+++ modules/argp-tests  22 Feb 2006 19:03:02 -
@@ -5,8 +5,6 @@
 Depends-on:
 
 Makefile.am:
-TESTS += test-argp test-argp-2.sh
-noinst_PROGRAMS += test-argp 
+TESTS += test-argp$(EXEEXT) test-argp-2.sh
+check_PROGRAMS += test-argp 
 EXTRA_DIST += test-argp-2.sh
-test_argp_SOURCES = test-argp.c
-
Index: modules/lock-tests
===
RCS file: /cvsroot/gnulib/gnulib/modules/lock-tests,v
retrieving revision 1.2
diff -u -r1.2 lock-tests
--- modules/lock-tests  23 Jan 2006 20:38:51 -  1.2
+++ modules/lock-tests  22 Feb 2006 19:03:02 -
@@ -13,7 +13,7 @@
 AC_SUBST([LIBSCHED])
 
 Makefile.am:
-TESTS += test-lock
+TESTS += test-lock$(EXEEXT)
 check_PROGRAMS += test-lock
 test_lock_LDADD = @LIBMULTITHREAD@ @LIBSCHED@ $(LDADD)
 
Index: modules/tls-tests
===
RCS file: /cvsroot/gnulib/gnulib/modules/tls-tests,v
retrieving revision 1.2
diff -u -r1.2 tls-tests
--- modules/tls-tests   23 Jan 2006 20:38:51 -  1.2
+++ modules/tls-tests   22 Feb 2006 19:03:02 -
@@ -13,7 +13,7 @@
 AC_SUBST([LIBSCHED])
 
 Makefile.am:
-TESTS += test-tls
+TESTS += test-tls$(EXEEXT)
 check_PROGRAMS += test-tls
 test_tls_LDADD = @LIBMULTITHREAD@ @LIBSCHED@ $(LDADD)
 


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


test failures: crc, md4, gc-md4

2006-02-24 Thread Ralf Wildenhues
FYI, a few of the gnulib tests currently fail:
On x86_64-unknown-linux-gnu (omitting passed tests):

cu got b9a9a617
FAIL: test-crc

md4 1 mismatch. expected:
a4 48 01 7a af 21 d8 52 5f c1 0a e8 7a a6 72 9d
computed:
29 e6 63 dd dc 61 52 69 91 85 da 92 ed 96 c8 b1
FAIL: test-gc-md4

expected:
a4 48 01 7a af 21 d8 52 5f c1 0a e8 7a a6 72 9d
computed:
29 e6 63 dd dc 61 52 69 91 85 da 92 ed 96 c8 b1
FAIL: test-md4


3 of 26 tests failed


Same with sparc-sun-solaris2.8 in 64bit mode (cc -xarch=v9).


On i686-pc-linux-gnu:

cu got b9a9a617
FAIL: test-crc

1 of 26 tests failed


Same with sparc-sun-solaris2.8 in 32bit mode.

Cheers,
Ralf


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


NetBSD 2.0+, statfs.h and mountlist.c

2006-02-24 Thread Benigno B. Junior
Hello,

I'm sending this email due to a problem I've been facing while trying to find a 
way to use the existent mountlist.c, provided by gnulib, and the statfs problem 
on NetBSD, because there's no statfs anymore, but *statvfs. Changing or 
defining statfs as a statvfs struct works, but mountlist.c has to be changed, 
and it seems to be a bit dirty.

Is there a way to solve this problem with minimal changes, or any planning in 
solving this? findutils and coreutils seems to suffer this problem actually (in 
fact, all of those which use mountlist.c).

Thank you very much, and take care!

 *statvfs http://www.netbsd.org/Foundation/reports/2004Q2.html#statvfs

--
Benigno B. Junior [EMAIL PROTECTED], ICQ#112673
http://pgp.mit.edu:11371/pks/lookup?op=getsearch=0xD3995B21
Research Group on Computer Networks and Software Engineering
Federal University of Itajuba, http://www.unifei.edu.br
Av. BPS, 1303, Itajuba, MG, 37500-903, Brazil


signature.asc
Description: PGP signature
___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


Re: play nice with AC_CACHE_CHECK

2006-02-24 Thread Eric Blake
 
 2) Similar with getaddrinfo.m4, except there is no need to store
 additional information here.  Beware, the getaddrinfo part of the
 patch is completely untested.

The following patch to getaddrinfo HAS been tested:

http://lists.gnu.org/archive/html/bug-gnulib/2006-02/msg00057.html

And it is essential for CVS coreutils to compile on cygwin with
caching on (sorry you had to duplicate my efforts)


-- 
Eric Blake


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


Re: play nice with AC_CACHE_CHECK

2006-02-24 Thread Ralf Wildenhues
Hi Eric,

* Eric Blake wrote on Thu, Feb 23, 2006 at 08:42:18PM CET:
  
  2) Similar with getaddrinfo.m4, except there is no need to store
  additional information here.  Beware, the getaddrinfo part of the
  patch is completely untested.
 
 The following patch to getaddrinfo HAS been tested:

 And it is essential for CVS coreutils to compile on cygwin with
 caching on (sorry you had to duplicate my efforts)

Oh, I did not research much about pending patches; mine is essentially
the same as yours, which is a good sign.  So yours should be applied.
Sorry about that.

I audited all use of AC_CACHE_CHECK in gnulib.  There is one more open
candidate, AM_GNU_GETTEXT, which I assume to be problematic, but its
logic is more involved.  All other uses look fine.

Cheers,
Ralf


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


Re: play nice with AC_CACHE_CHECK

2006-02-24 Thread Jim Meyering
Ralf Wildenhues [EMAIL PROTECTED] wrote:

 1) readline.m4 gives different results with cached reruns: for example,
 on x86_64-unknown-linux-gnu:

 ./configure -C
 - LIBREADLINE=-lreadline -lncurses
 ./config.status --recheck
 - LIBREADLINE=-lreadline

 This is because the commands to set the cache variable
 `gl_cv_lib_readline' also adjust LIBREADLINE and LTLIBREADLINE.

 The patch below fixes that by (ab)using the cache variable to hold the
 test result contents, making the COMMANDS-TO-SET-IT argument of the
 AC_CACHE_CHECK macro side-effect free.  Do you think the cache variable
 should be renamed (for users keeping the cache over the update; not that
 it was working well before anyway)?

Good catch.  I'm glad you didn't rename the cache variable.  Having a
conforming, well-known name is worth more than avoiding the possibility
of a few ephemeral user problems.  Besides, there may well be packages
that test $gl_cv_lib_readline, and changing the name would make them fail.


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


Re: config.h inclusion leftovers

2006-02-24 Thread Jim Meyering
Ralf Wildenhues [EMAIL PROTECTED] wrote:
 The following patch changes the last files over to the agreed-to style
 for inclusion of `config.h'.

   * lib/mkdtemp.c, lib/setenv.c, lib/unsetenv.c: Normalize
   inclusion of `config.h'.

Thanks.
Applied.


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


`illegal' vs `invalid'

2006-02-24 Thread Werner LEMBERG
[CVS 2006-02-24]

In the files `getopt.c', `glob.c', and `regexprops-generic.texi' I
suggest to replace the word `illegal' with `invalid'.


Werner


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


argp.h/argz.h and error_t

2006-02-24 Thread Ralf Wildenhues
If a project uses both modules argp and argz, error_t may be both
#define'd, and set as typedef in argp.h.  The #define from config.h
(which comes ultimatively from argz.m4) kills the typedef of course.

For example on sparc-sun-solaris2.8:

| cc -DHAVE_CONFIG_H -DEXEEXT=\\ -DEXEEXT=\\ -DLIBDIR=\/usr/local/lib\ 
-I. -I../../dummy-0/lib -I..   -D_REENTRANT  -xarch=v9 -c 
../../dummy-0/lib/argp-eexst.c
| ../../dummy-0/lib/argp.h, line 64: invalid type combination
| ../../dummy-0/lib/argp.h, line 64: warning: useless declaration
| ../../dummy-0/lib/argp.h, line 64: warning: typedef declares no type name
| cc: acomp failed for ../../dummy-0/lib/argp-eexst.c

The hack below fixes that, but I can imagine that it is not an
acceptable fix, given that this is libc code.  Should we rather
AC_DEFINE([__error_t_defined], 1, ..)?

Thoughts?

Cheers,
Ralf

* lib/argp.h: Only declare error_t if not #defined already.

Index: lib/argp.h
===
RCS file: /cvsroot/gnulib/gnulib/lib/argp.h,v
retrieving revision 1.11
diff -u -r1.11 argp.h
--- lib/argp.h  10 Jan 2006 21:49:07 -  1.11
+++ lib/argp.h  22 Feb 2006 17:31:25 -
@@ -61,7 +61,9 @@
 #endif
 
 #ifndef __error_t_defined
+# ifndef error_t
 typedef int error_t;
+# endif
 # define __error_t_defined
 #endif
 


___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib


intprops.h as a module?

2006-02-24 Thread Ben Pfaff
The intprops.h header file seems pretty useful by itself.  Would
it make sense to create a module that just imports that header
file?

-- 
Ben Pfaff 
email: [EMAIL PROTECTED]
web: http://benpfaff.org



___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib