Re: What's cooking in git.git (Jul 2017, #07; Mon, 24)

2017-07-26 Thread Junio C Hamano
Johannes Schindelin  writes:

>> * wd/rebase-conflict-guide (2017-07-17) 1 commit
>>   (merged to 'next' on 2017-07-20 at c78e758b23)
>>  + rebase: make resolve message clearer for inexperienced users
>> 
>>  Code clean-up.
>
> This is not a code clean-up. It is an improvement of the user experience.

Indeed it is.  Thanks for spotting.


Re: What's cooking in git.git (Jul 2017, #07; Mon, 24)

2017-07-25 Thread Junio C Hamano
Johannes Schindelin  writes:

> Hi Junio,
>
> On Mon, 24 Jul 2017, Junio C Hamano wrote:
>
>> * js/blame-lib (2017-07-24) 1 commit
>>  - blame: fix memory corruption scrambling revision name in error message
>> 
>>  A hotfix to a topic already in 'master'.
>> 
>>  Will merge to 'next'.
>
> This sounds more critical than `next`, in particular since you said that
> you do not want to move anything from `next` to `master` before 2.14
> final.

That is why it is not "Will merge to and cook in 'next'" which is a
norm for new things during -rc.

>>  The final batch to "git rebase -i" updates to move more code from
>>  the shell script to C.
>> 
>>  Expecting a reroll.
>
> Since you said yourself that you won't pick up v6...

Read the message again and realize that I said won't during -rc
but may hold onto it.  I am intending to queue it on 2.14 final
to merge to 'pu' until the topic is rerolled again.



Re: What's cooking in git.git (Jul 2017, #07; Mon, 24)

2017-07-25 Thread Johannes Schindelin
Hi Junio,

On Mon, 24 Jul 2017, Junio C Hamano wrote:

> * js/blame-lib (2017-07-24) 1 commit
>  - blame: fix memory corruption scrambling revision name in error message
> 
>  A hotfix to a topic already in 'master'.
> 
>  Will merge to 'next'.

This sounds more critical than `next`, in particular since you said that
you do not want to move anything from `next` to `master` before 2.14
final.

> * js/rebase-i-final (2017-06-15) 10 commits
>  - rebase -i: rearrange fixup/squash lines using the rebase--helper
>  - t3415: test fixup with wrapped oneline
>  - rebase -i: skip unnecessary picks using the rebase--helper
>  - rebase -i: check for missing commits in the rebase--helper
>  - t3404: relax rebase.missingCommitsCheck tests
>  - rebase -i: also expand/collapse the SHA-1s via the rebase--helper
>  - rebase -i: do not invent onelines when expanding/collapsing SHA-1s
>  - rebase -i: remove useless indentation
>  - rebase -i: generate the script via rebase--helper
>  - t3415: verify that an empty instructionFormat is handled as before
> 
>  The final batch to "git rebase -i" updates to move more code from
>  the shell script to C.
> 
>  Expecting a reroll.

Since you said yourself that you won't pick up v6 (even if I made clear
that I have a strong preference for resolving merge conflicts myself
rather than have you guess), it may be a good idea to change this from
"Expecting a reroll" to something else?

> * jc/http-sslkey-and-ssl-cert-are-paths (2017-07-20) 1 commit
>   (merged to 'next' on 2017-07-20 at 5489304b99)
>  + http.c: http.sslcert and http.sslkey are both pathnames
> 
>  The http.{sslkey,sslCert} configuration variables are to be
>  interpreted as a pathname that honors "~[username]/" prefix, but
>  weren't, which has been fixed.
> 
>  Will cook in 'next'.

Just so you know: an identical patch has been cooking in Git for Windows
as 26b08ecec8d37b976be9e85055a0a9e3d16a56da since Dec 11 2015.

> * wd/rebase-conflict-guide (2017-07-17) 1 commit
>   (merged to 'next' on 2017-07-20 at c78e758b23)
>  + rebase: make resolve message clearer for inexperienced users
> 
>  Code clean-up.

This is not a code clean-up. It is an improvement of the user experience.

Ciao,
Dscho

P.S.: Sorry for not branching off of the thread with proper ",
was: What's cooking" subjects, but I am seriously short on time. Please
accept my apologies.


What's cooking in git.git (Jul 2017, #07; Mon, 24)

2017-07-24 Thread Junio C Hamano
Here are the topics that have been cooking.  Commits prefixed with
'-' are only in 'pu' (proposed updates) while commits prefixed with
'+' are in 'next'.  The ones marked with '.' do not appear in any of
the integration branches, but I am still holding onto them.

With help from Jiang, Dscho and Jean-Noël, we agreed on the way to
handle i18n issues around our custom timestamp_t type and its format
PRItime, and tagging of -rc1 has been delayed a bit.  But now it has
happened.  There is a small unrelated change still cooking somewhere
else that may have to go in the final release, but other than that
one, no topic is expected to go from 'next' to 'master' until the
final.  Regression fixes and reverts are possible but let's hope
there are no need for them.

You can find the changes described here in the integration branches
of the repositories listed at

http://git-blame.blogspot.com/p/git-public-repositories.html

--
[Graduated to "master"]

* jc/po-pritime-fix (2017-07-20) 1 commit
  (merged to 'next' on 2017-07-21 at 61f0e3b37f)
 + Makefile: help gettext tools to cope with our custom PRItime format

 We started using "%" PRItime, imitating "%" PRIuMAX and friends, as
 a way to format the internal timestamp value, but this does not
 play well with gettext(1) i18n framework, and causes "make pot"
 that is run by the l10n coordinator to create a broken po/git.pot
 file.  This is a possible workaround for that problem.


* ks/doc-fixes (2017-07-18) 2 commits
  (merged to 'next' on 2017-07-20 at c34b00d0a0)
 + doc: reformat the paragraph containing the 'cut-line'
 + doc: camelCase the i18n config variables to improve readability

 Doc clean-up.


* rj/cygwin-fread-reads-directories (2017-07-21) 1 commit
  (merged to 'next' on 2017-07-21 at 28694cf254)
 + config.mak.uname: set FREAD_READS_DIRECTORIES for cygwin

 It turns out that Cygwin also needs the fopen() wrapper that
 returns failure when a directory is opened for reading.

--
[New Topics]

* js/run-process-parallel-api-fix (2017-07-21) 1 commit
 - run_processes_parallel: change confusing task_cb convention

 API fix.

 Will merge to and cook in 'next'.


* cc/ref-is-hidden-microcleanup (2017-07-24) 1 commit
 - refs: use skip_prefix() in ref_is_hidden()

 Code cleanup.

 Will merge to and cook in 'next'.


* js/blame-lib (2017-07-24) 1 commit
 - blame: fix memory corruption scrambling revision name in error message

 A hotfix to a topic already in 'master'.

 Will merge to 'next'.

--
[Stalled]

* mg/status-in-progress-info (2017-05-10) 2 commits
 - status --short --inprogress: spell it as --in-progress
 - status: show in-progress info for short status

 "git status" learns an option to report various operations
 (e.g. "merging") that the user is in the middle of.

 cf. 


* nd/worktree-move (2017-04-20) 6 commits
 - worktree remove: new command
 - worktree move: refuse to move worktrees with submodules
 - worktree move: accept destination as directory
 - worktree move: new command
 - worktree.c: add update_worktree_location()
 - worktree.c: add validate_worktree()

 "git worktree" learned move and remove subcommands.

 Expecting a reroll.
 cf. <20170420101024.7593-1-pclo...@gmail.com>
 cf. <20170421145916.mknekgqzhxffu...@sigill.intra.peff.net>
 cf. 


* sg/clone-refspec-from-command-line-config (2017-06-16) 2 commits
 - Documentation/clone: document ignored configuration variables
 - clone: respect additional configured fetch refspecs during initial fetch
 (this branch is used by sg/remote-no-string-refspecs.)

 "git clone -c var=val" is a way to set configuration variables in
 the resulting repository, but it is more useful to also make these
 variables take effect while the initial clone is happening,
 e.g. these configuration variables could be fetch refspecs.

 Waiting for a response.
 cf. <20170617112228.vugswym4o4owf...@sigill.intra.peff.net>
 cf. 


* js/rebase-i-final (2017-06-15) 10 commits
 - rebase -i: rearrange fixup/squash lines using the rebase--helper
 - t3415: test fixup with wrapped oneline
 - rebase -i: skip unnecessary picks using the rebase--helper
 - rebase -i: check for missing commits in the rebase--helper
 - t3404: relax rebase.missingCommitsCheck tests
 - rebase -i: also expand/collapse the SHA-1s via the rebase--helper
 - rebase -i: do not invent onelines when expanding/collapsing SHA-1s
 - rebase -i: remove useless indentation
 - rebase -i: generate the script via rebase--helper
 - t3415: verify that an empty instructionFormat is handled as before

 The final batch to "git rebase -i" updates to move more code from
 the shell script to C.

 Expecting a reroll.
 This is at its v5.
 cf.