Re: Text::MediawikiFormat Problems.

2011-11-06 Thread Octavian Rasnita
Maybe the name attribute of the a element was used as a way of targetting 
other links to a certain part of the page using a fragment, instead of using 
the id attribute as it should (because the ID is unique, but the name not).
 
Maybe this was shlomi telling about...

Octavian

- Original Message - 
From: Matthew Musgrove mr.musk...@gmail.com
To: Shlomi Fish shlo...@shlomifish.org
Cc: Derek Price de...@ximbiot.com; Perl Module Authors List 
module-authors@perl.org
Sent: Sunday, November 06, 2011 6:30 PM
Subject: Re: Text::MediawikiFormat Problems.


 Just an FYI...
 In HTML 4.01/XHTML 1.0, name is a perfectly valid attribute in both the
 strict and traditional DTD. See http://www.w3schools.com/tags/tag_a.asp for
 a complete list of supported anchor attributes.
 In HTML5, name is not a valid attribute. See
 http://www.w3schools.com/html5/tag_a.asp and
 http://www.w3schools.com/html5/html5_ref_globalattributes.asp for more
 details.
 
 
 Matt
 
 
 On Sun, Nov 6, 2011 at 5:55 AM, Shlomi Fish shlo...@shlomifish.org wrote:
 
 Hi Derek,

 thanks for Text::MediawikiFormat and your other CPAN work.

 I've ran into the following problems when trying to use
 Text::MediawikiFormat :

 1. It generates non-valid XHTML/HTML with a name=... tags etc. instead
 of
 id=... attributes. HTML tidy does not help much with it. I'd like to fix
 it.

 2. On http://metacpan.org/module/Text::MediawikiFormat you say that it can
 also generate XML and DocBook, but it does not specify how to do that
 exactly.

 3. There are several active bugs in
 https://rt.cpan.org/Public/Dist/Display.html?Name=Text-MediawikiFormat .
 Why haven't they been resolved yet?

 4. There hasn't been a release from you to CPAN since 2008.

 

 If necessary, then I volunteer to help maintain Text::MediawikiFormat ,
 but I
 would prefer some guidance and approval from you.

 Regards,

Shlomi Fish

 --
 -
 Shlomi Fish   http://www.shlomifish.org/
 Why I Love Perl - http://shlom.in/joy-of-perl

 Chuck Norris writes understandable Perl code.

 Please reply to list if it's a mailing list post - http://shlom.in/reply .




New module naming

2011-11-06 Thread Trystan
Hi. I've written few libraries I'd like to release on CPAN and I'm looking
for some advice on how to name them.

I found this idea in Head First OOADhttp://headfirstlabs.com/books/hfooad/,
chapter 5. It's somewhat like a very simple version of Key-Value
Codinghttp://developer.apple.com/library/mac/#documentation/Cocoa/Conceptual/KeyValueCoding/Articles/Overview.html%23//apple_ref/doc/uid/20001838-SW1.
It's also very similar to
Object::Generichttp://search.cpan.org/%7Ejmahoney/Object-Generic-0.13/lib/Object/Generic.pmbut
I didn't use AUTOLOAD and I implemented 'equals' and 'contains'
methods
in order to make the objects searchable within a container.

Here's an example:

 my $a = tbd_name::Object-new();
 my $b = tbd_name::Object-new();

 $a-set( ID, tbd_name::String-new(1234a) );
 $b-set( ID, tbd_name::String-new(1234a) );

 print $a-get(ID);

 $a-equals($b) ? print yes;

 $container = tbd_name::List-new();
 $container-add($a);

 $container-search($b);  #which returns $a

What do I call this thing? I'm thinking the namespace would be 'KeyValue::'
or 'KeyVal::' Would that make sense? (That namespace doesn't seem to be
used.) Should this go in 'Class::'?

Thanks.