Re: [openssl.org #97] About 0.9.6a(b) and des_encrypt1()

2002-06-15 Thread Jani Taskinen

On Fri, 14 Jun 2002, Lutz Jaenicke via RT wrote:

There will not be another release of 0.9.6 before 0.9.7 will be out.
We still maintain the 0.9.6 tree, because we anticipate that due to
incompatible changes between 0.9.6 and 0.9.7 several people will stay
with 0.9.6x for some more time, so we are prepared to release another

Perfectly understandable. btw. is there any list of those
changes anywhere? Just thinking if there are some issues
we should be aware of with PHP's openssl extension..

The change that is required will break binary compatibility between 0.9.6d
and 0.9.6e (because that's the purpose of the change :-). Even though
we try to make clear that we don't promise binary compatibility, a lot

Heh, of course. 

of people expect it. I am therefore a bit reluctant to make the change
and will keep the issue as an open ticket in the request tracker, until
0.9.6e becomes reality or some other member of the team makes a final
decision.

For me it's okay to close this. I've already told the people
who reported this problem to bugs.php.net that this is fixed in 
openssl 0.9.7.. :)

--Jani

__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]



Re: [openssl.org #97] About 0.9.6a(b) and des_encrypt1()

2002-06-14 Thread Geoff Thorpe via RT


On Wed, 8 Aug 2001, [iso-8859-1] Götz Babin-Ebell wrote:

 Richard Levitte - VMS Whacker wrote:
  
  Hmm, it feels like it's really time for a rename (basically, change
  des to DES in all names, and thereby follow the convention used
  everywhere else in OpenSSL), or this becomes an impossible task.
 
 openssl_des_... ?
 
 in the sources we can have a
 #define des_...() openssl_des_...()

If a change is going to be made, it makes sense to bring the naming in line with
the rest of the code, thus DES_*** makes more sense. (IMHO, IANAL, etc :-)

Cheers,
Geoff


__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]
__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]



Re: [openssl.org #97] About 0.9.6a(b) and des_encrypt1()

2002-06-14 Thread Götz Babin-Ebell via RT


Richard Levitte - VMS Whacker wrote:
 
 From: Jani Taskinen [EMAIL PROTECTED]
 
 sniper From CHANGES:
 sniper 
 sniper  *) Rename 'des_encrypt' to 'des_encrypt1'.  This avoids the clashes
 sniper  with des_encrypt() defined on some operating systems, like Solaris
 sniper  and UnixWare.
 sniper  [Richard Levitte]
 sniper 
 sniper
 sniper Just wanted to let you guys know, that also
 sniper this symbol is in use by Solaris (7), libcrypt:
 sniper
 sniper # nm /usr/lib/libcrypt.a | grep des_encrypt
 sniper  U _des_encrypt
 sniper des_encrypt.o:
 sniper  T _des_encrypt1
 sniper  W des_encrypt1
 sniper 025c T _des_encrypt
 sniper  U _des_encrypt1
 sniper 025c W des_encrypt
 sniper 01bc t des_encrypt_nolock
 
 Hmm, it feels like it's really time for a rename (basically, change
 des to DES in all names, and thereby follow the convention used
 everywhere else in OpenSSL), or this becomes an impossible task.

openssl_des_... ?

in the sources we can have a
#define des_...() openssl_des_...()

By

Goetz

-- 
Goetz Babin-Ebell, TC TrustCenter AG, http://www.trustcenter.de
Sonninstr. 24-28, 20097 Hamburg, Germany
Tel.: +49-(0)40 80 80 26 -0,  Fax: +49-(0)40 80 80 26 -126
__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]



Re: [openssl.org #97] About 0.9.6a(b) and des_encrypt1()

2002-06-14 Thread Richard Levitte - VMS Whacker via RT


From: Jani Taskinen [EMAIL PROTECTED]

sniper From CHANGES:
sniper 
sniper  *) Rename 'des_encrypt' to 'des_encrypt1'.  This avoids the clashes
sniper  with des_encrypt() defined on some operating systems, like Solaris
sniper  and UnixWare.
sniper  [Richard Levitte]
sniper 
sniper 
sniper Just wanted to let you guys know, that also
sniper this symbol is in use by Solaris (7), libcrypt:
sniper 
sniper # nm /usr/lib/libcrypt.a | grep des_encrypt
sniper  U _des_encrypt
sniper des_encrypt.o:
sniper  T _des_encrypt1
sniper  W des_encrypt1
sniper 025c T _des_encrypt
sniper  U _des_encrypt1
sniper 025c W des_encrypt
sniper 01bc t des_encrypt_nolock

Hmm, it feels like it's really time for a rename (basically, change
des to DES in all names, and thereby follow the convention used
everywhere else in OpenSSL), or this becomes an impossible task.

For source compatibility, it's of course perfectly possible to provide
macros so older applications don't break immediately.

-- 
Richard Levitte   \ Spannvägen 38, II \ [EMAIL PROTECTED]
Redakteur@Stacken  \ S-168 35  BROMMA  \ T: +46-8-26 52 47
\  SWEDEN   \ or +46-733-72 88 11
Procurator Odiosus Ex Infernis-- [EMAIL PROTECTED]
Member of the OpenSSL development team: http://www.openssl.org/
Software Engineer, GemPlus: http://www.gemplus.com/

Unsolicited commercial email is subject to an archival fee of $400.
See http://www.stacken.kth.se/~levitte/mail/ for more info.
__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]
__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]



Re: [openssl.org #97] About 0.9.6a(b) and des_encrypt1()

2002-06-14 Thread Jani Taskinen via RT


On Fri, 14 Jun 2002, Lutz Jaenicke via RT wrote:


[[EMAIL PROTECTED] - Fri Jun 14 12:02:20 2002]:

 
 From CHANGES:
 
  *) Rename 'des_encrypt' to 'des_encrypt1'.  This avoids the clashes
  with des_encrypt() defined on some operating systems, like Solaris
  and UnixWare.
  [Richard Levitte]
 
 
 Just wanted to let you guys know, that also
 this symbol is in use by Solaris (7), libcrypt:

This problem has been resolved for 0.9.7...

Great. 

Is it worthwile to make a small adjustment for 0.9.6e (in case it will
be released)?

If 0.9.7 is due to be released soon (?) then I don't think 
that's necessary..but of course if there will be another
release of 0.9.6 then it would be nice to have this in it.

--Jani


__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]



Re: [openssl.org #97] About 0.9.6a(b) and des_encrypt1()

2002-06-14 Thread Lutz Jaenicke via RT


On Fri, Jun 14, 2002 at 08:34:06PM +0200, Jani Taskinen via RT wrote:
 On Fri, 14 Jun 2002, Lutz Jaenicke via RT wrote:
 This problem has been resolved for 0.9.7...
 
 Great. 
 
 Is it worthwile to make a small adjustment for 0.9.6e (in case it will
 be released)?
 
 If 0.9.7 is due to be released soon (?) then I don't think 
 that's necessary..but of course if there will be another
 release of 0.9.6 then it would be nice to have this in it.

There will not be another release of 0.9.6 before 0.9.7 will be out.
We still maintain the 0.9.6 tree, because we anticipate that due to
incompatible changes between 0.9.6 and 0.9.7 several people will stay
with 0.9.6x for some more time, so we are prepared to release another
0.9.6e version, if important bugs are found. It is however not clear,
whether there will really be a 0.9.6e release. If 0.9.7 is accepted
fast by our user base, it will never appear.

The change that is required will break binary compatibility between 0.9.6d
and 0.9.6e (because that's the purpose of the change :-). Even though
we try to make clear that we don't promise binary compatibility, a lot
of people expect it. I am therefore a bit reluctant to make the change
and will keep the issue as an open ticket in the request tracker, until
0.9.6e becomes reality or some other member of the team makes a final
decision.

Best regards,
Lutz
-- 
Lutz Jaenicke [EMAIL PROTECTED]
http://www.aet.TU-Cottbus.DE/personen/jaenicke/
BTU Cottbus, Allgemeine Elektrotechnik
Universitaetsplatz 3-4, D-03044 Cottbus
__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]



Re: [openssl.org #97] About 0.9.6a(b) and des_encrypt1()

2002-06-14 Thread Jani Taskinen via RT


On Fri, 14 Jun 2002, Lutz Jaenicke via RT wrote:

There will not be another release of 0.9.6 before 0.9.7 will be out.
We still maintain the 0.9.6 tree, because we anticipate that due to
incompatible changes between 0.9.6 and 0.9.7 several people will stay
with 0.9.6x for some more time, so we are prepared to release another

Perfectly understandable. btw. is there any list of those
changes anywhere? Just thinking if there are some issues
we should be aware of with PHP's openssl extension..

The change that is required will break binary compatibility between 0.9.6d
and 0.9.6e (because that's the purpose of the change :-). Even though
we try to make clear that we don't promise binary compatibility, a lot

Heh, of course. 

of people expect it. I am therefore a bit reluctant to make the change
and will keep the issue as an open ticket in the request tracker, until
0.9.6e becomes reality or some other member of the team makes a final
decision.

For me it's okay to close this. I've already told the people
who reported this problem to bugs.php.net that this is fixed in 
openssl 0.9.7.. :)

--Jani


__
OpenSSL Project http://www.openssl.org
Development Mailing List   [EMAIL PROTECTED]
Automated List Manager   [EMAIL PROTECTED]