Re: CSS Query API: selectorQuery(...)

2007-07-20 Thread Robin Berjon


On Jul 19, 2007, at 19:07, Bjoern Hoehrmann wrote:

  The WebAPI Working Group is considering to conduct a poll to finally
put the method naming issue in the CSS Query API specification to  
rest;
Charles asked us to propose alternatives to selectElement/ 
selectAllEle-

ments. To this end, I would like to propose using two [1] of

  selectorQuery(...) / .selectorQueryAll(...) / .selectorQueryOne(...)


+1 from me.

--
Robin Berjon - http://berjon.com/

Rated R for Robin





Re: CSS Query API: selectorQuery(...)

2007-07-20 Thread Jean-Yves Bitterlich




+0.9

Robin Berjon wrote:

On Jul 19, 2007, at 19:07, Bjoern Hoehrmann wrote:
  
   The WebAPI Working Group is considering to
conduct a poll to finally

put the method naming issue in the CSS Query API specification to rest;

Charles asked us to propose alternatives to selectElement/selectAllEle-

ments. To this end, I would like to propose using two [1] of


 selectorQuery(...) / .selectorQueryAll(...) / .selectorQueryOne(...)

  
  
+1 from me.
  
  


-- 

  

  
  Jean-Yves H. Bitterlich


  Senior Staff Engineer


  Sun Microsystems GmbH


  Sonnenallee 1, 85551 Heimstetten,
Germany


  Mobile: 
  +49-172-8187243


  Phone: 
  +49-89-46008-1097 (x61097)


  Fax: 
  +49-89-46008-2978 (x62978)


  Email: 
  [EMAIL PROTECTED]


  
  Geschftsfhrer: Wolfgang Engels, Dr. Roland Bmer; 
Vorsitzender des Aufsichtsrates: Martin Hring
Amtsgericht Mnchen: HRB 161028, WEEE-Reg.-Nr. DE 20803943
HypoVereinsbank Mnchen, Konto 31 625 009, BLZ 700 202 70
  
  

  






Selectors API Names (was: CSS Query API: selectorQuery(...))

2007-07-19 Thread Doug Schepers


Hi-

Just to alleviate any confusion, Bjoern is referring to the Selectors 
API spec [1] (not CSS Query API, which is not the name of a WebAPI 
spec).


[1] http://www.w3.org/TR/selectors-api/

Regards-
-Doug Schepers
W3C Staff Contact, SVG, CDF, and WebAPI


Bjoern Hoehrmann wrote:

Hi,

  The WebAPI Working Group is considering to conduct a poll to finally
put the method naming issue in the CSS Query API specification to rest;
Charles asked us to propose alternatives to selectElement/selectAllEle-
ments. To this end, I would like to propose using two [1] of 


  selectorQuery(...) / .selectorQueryAll(...) / .selectorQueryOne(...)

instead. I believe these names offer the following benefits:

  * This is the only set of names where I know of no working 
group member with a good reason to strongly dislike them.


  * Many working group members have indicated these names work
for them. Even Anne!

  * They are lexically distant from the selectNodes and select-
SingleNode XPath methods that serve a very similar purpose.

  * They are lexically distant from DOM Range manipulation
methods like DOM TR's .selectNode, Dojo's .selectElement

  * They are quite unlikely to clash with other future DOM
methods and attributes designed for other purposes.

  * In particular, DOM attributes that reflect XML attributes;
selectElement='' is much more likely than selectorQuery='',
c.f. SVG's targetElement='...'

  * They are just as long as the .select(All)Element(s) names.

I understand somebody has to make the same proposal (or second this
one) for it to be considered; if you think these names should be
considered, or even think these would be better than selectElement,
you are very welcome to do that.

[1] There have been arguments that the shorter name should return a
single element so authors write possibly more efficient code,
and that the shorter name should return many elements because
that is required more often and saves a few keystrokes. I think
this is out of scope of the proposal and should be a separate
question in the poll, if we are going to conduct one.

Thanks,


--




Re: CSS Query API: selectorQuery(...)

2007-07-19 Thread Maciej Stachowiak



On Jul 19, 2007, at 10:07 AM, Bjoern Hoehrmann wrote:



Hi,

 The WebAPI Working Group is considering to conduct a poll to finally
put the method naming issue in the CSS Query API specification to  
rest;
Charles asked us to propose alternatives to selectElement/ 
selectAllEle-

ments. To this end, I would like to propose using two [1] of

 selectorQuery(...) / .selectorQueryAll(...) / .selectorQueryOne(...)


I second this proposal. I also propose:

querySelector() / querySelectorAll()
matchSelector() / matchSelectorAll()

Regards,
Maciej