[Sipp-users] Variable in recv timeout

2008-07-24 Thread Ricardo Fernandes
Hello,

How can i put a variable in the timeout field of recv.
Ex:

nop
action
  assignstr assign_to=MillisToWaitTemp value=[field2]/
  todouble assign_to=MillisToWait variable=MillisToWaitTemp/
   /action
nop

recv request=BYE  timeout=[$MillisToWait] ontimeout=Label1
next=LabelBye/

This gives me an error:
message timeout 'timeout' parameter, [$MillisToWait] is not a valid integer!

Is there a way to make this work, or is this a illegal instruction?


TIA
Ricardo Fernandes

-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Sipp-users mailing list
Sipp-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sipp-users


[Sipp-users] Bug in -bind_local parsing?

2008-07-24 Thread Michael Hirschbichler
Hi all,

I noticed a strance behaviour when passing an -bind_local - Argument:

Following the online-help:
./sipp -h
the remotehost must be added as first argument:
sipp remote_host[:remote_port] [options]

entering
./sipp 2.2.2.2 -sn uac -bind_local 1.2.3.4
results in

--- Scenario Screen  [1-9]: Change Screen --
Call-rate(length) Port Total-time  Total-calls Remote-host
10.0(0 ms)/1.000s 5060 1.70 s   17 1.2.3.4:5060(UDP)

which is definitively the wrong remotehost

if I add the remotehost as the last argument,
./sipp -sn uac -bind_local 1.2.3.4 2.2.2.2
then the behavior is correct:

--- Scenario Screen  [1-9]: Change Screen --
Call-rate(length) Port Total-time  Total-calls Remote-host
10.0(0 ms)/1.000s 5060 0.89 s8 2.2.2.2:5060(UDP)


This error affects at least version 3.1 (svn803) and sipp 2.0 (20070426)


BR
Michael

-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Sipp-users mailing list
Sipp-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sipp-users


Re: [Sipp-users] Variable in recv timeout

2008-07-24 Thread Charles P Wright
The timeout field does not accept a variable as input.

Charles




Ricardo Fernandes [EMAIL PROTECTED] 
Sent by: [EMAIL PROTECTED]
07/24/2008 06:14 AM

To
sipp-users@lists.sourceforge.net
cc

Subject
[Sipp-users] Variable in recv timeout






Hello,

How can i put a variable in the timeout field of recv.
Ex:

nop
 action
  assignstr assign_to=MillisToWaitTemp value=[field2]/
  todouble assign_to=MillisToWait 
variable=MillisToWaitTemp/
   /action
nop

recv request=BYE  timeout=[$MillisToWait] ontimeout=Label1
next=LabelBye/

This gives me an error:
message timeout 'timeout' parameter, [$MillisToWait] is not a valid 
integer!

Is there a way to make this work, or is this a illegal instruction?


TIA
Ricardo Fernandes

-
This SF.Net email is sponsored by the Moblin Your Move Developer's 
challenge
Build the coolest Linux based applications with Moblin SDK  win great 
prizes
Grand prize is a trip for two to an Open Source event anywhere in the 
world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Sipp-users mailing list
Sipp-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sipp-users



-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/
___
Sipp-users mailing list
Sipp-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sipp-users


[Sipp-users] Testing Cisco CME using SIPp

2008-07-24 Thread Antoine
I have a Cisco 2651XM router running CME (Call Manager Express) for a couple of 
soft SIP phones (i.e. X-Lite).

I am trying to put some stress on this router to find out how many SIP calls 
CME can handled, unfortunately I was unable to get SIPp to work. I found 
information on how to test an Asterisk server but I have to admit I am a bit 
lost as this is the first time I have been using SIPp.

Has anyone managed to test CME using SIPp?


For info, below is a copy of the config running on the router:
===

SIPRouter#show run
!
ip dhcp excluded-address 10.1.0.1 10.1.0.10
!
ip dhcp pool DATA
   network 10.1.0.0 255.255.255.0
   default-router 10.1.0.1 
!
!
no ip domain lookup
multilink bundle-name authenticated
!
voice service voip 
 allow-connections sip to sip
 redirect ip2ip
 sip
  registrar server expires max 36000 min 600
!
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g711alaw
!
!
voice register global
 mode cme
 source-address 10.1.0.1 port 5060
 max-dn 6
 max-pool 6
 timezone 21
 time-format 24
 hold-alert
 tftp-path flash:
 create profile sync 496932420019
!
voice register dn  1
 number 2001
 call-forward b2bua noan 2002 timeout 10
 name User 1
 no-reg
 label X-Lite 2001
!
voice register dn  2
 number 2003
 call-forward b2bua noan 2004 timeout 10
 name User 2
 no-reg
 label X-Lite 2003
!
voice register pool  1
 id mac 0003.47BA.DC53
 number 1 dn 1
 dtmf-relay rtp-nte sip-notify
 voice-class codec 1
 username 2001 password cisco
!
voice register pool  2
 id mac 001E.3786.3EEA
 number 1 dn 2
 dtmf-relay rtp-nte sip-notify
 voice-class codec 1
 username 2003 password cisco
!
!
interface FastEthernet0/1
 ip address 10.0.0.11 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 100
 network 10.0.0.0
 no auto-summary
!
ip forward-protocol nd



  __
Not happy with your email address?.
Get the one you really want - millions of new email addresses available now at 
Yahoo! http://uk.docs.yahoo.com/ymail/new.html-
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK  win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100url=/___
Sipp-users mailing list
Sipp-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sipp-users