[U-Boot] [PATCH] common/envs: Move conditional compilation to Makefile

2008-08-17 Thread Jean-Christophe PLAGNIOL-VILLARD
rename CFG_ENV_IS_IN_* to CONFIG_ENV_IS_IN_*
and CFG_ENV_IS_NOWHERE to CONFIG_ENV_IS_NOWHERE

Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD [EMAIL PROTECTED]
---
 Makefile|2 +-
 README  |   12 ++--
 board/LEOX/elpt860/README.LEOX  |2 +-
 board/LEOX/elpt860/flash.c  |2 +-
 board/MAI/AmigaOneG3SE/flash_new.c  |2 +-
 board/Marvell/common/bootseq.txt|2 +-
 board/RPXlite_dw/README |2 +-
 board/RRvision/flash.c  |2 +-
 board/a3000/flash.c |4 ++--
 board/amcc/bamboo/flash.c   |4 ++--
 board/amcc/bubinga/flash.c  |2 +-
 board/amcc/ebony/flash.c|2 +-
 board/amcc/kilauea/kilauea.c|2 +-
 board/amcc/luan/flash.c |2 +-
 board/amcc/makalu/makalu.c  |2 +-
 board/amcc/ocotea/flash.c   |2 +-
 board/amcc/sequoia/sequoia.c|2 +-
 board/amcc/taihu/flash.c|2 +-
 board/amcc/walnut/flash.c   |2 +-
 board/amcc/yucca/flash.c|2 +-
 board/atc/flash.c   |2 +-
 board/barco/flash.c |4 ++--
 board/bmw/flash.c   |4 ++--
 board/c2mon/flash.c |4 ++--
 board/cmc_pu2/flash.c   |2 +-
 board/cmi/flash.c   |4 ++--
 board/cogent/flash.c|4 ++--
 board/cpc45/flash.c |4 ++--
 board/cpu86/flash.c |2 +-
 board/cpu87/flash.c |2 +-
 board/cu824/flash.c |4 ++--
 board/emk/common/flash.c|2 +-
 board/ep8260/flash.c|2 +-
 board/esd/pf5200/flash.c|2 +-
 board/esd/pmc440/pmc440.c   |2 +-
 board/evb64260/bootseq.txt  |2 +-
 board/evb64260/flash.c  |2 +-
 board/exbitgen/flash.c  |2 +-
 board/fads/fads.h   |2 +-
 board/fads/flash.c  |4 ++--
 board/flagadm/flash.c   |2 +-
 board/freescale/mpc8260ads/flash.c  |2 +-
 board/freescale/mpc8266ads/flash.c  |4 ++--
 board/funkwerk/vovpn-gw/flash.c |2 +-
 board/gen860t/flash.c   |4 ++--
 board/gw8260/flash.c|2 +-
 board/hidden_dragon/flash.c |4 ++--
 board/icecube/flash.c   |2 +-
 board/icu862/flash.c|4 ++--
 board/ids8247/flash.c   |4 ++--
 board/incaip/flash.c|2 +-
 board/innokom/flash.c   |2 +-
 board/integratorcp/flash.c  |2 +-
 board/ip860/flash.c |4 ++--
 board/iphase4539/flash.c|2 +-
 board/ivm/flash.c   |4 ++--
 board/kup/common/flash.c|2 +-
 board/lantec/flash.c|6 +++---
 board/lwmon/flash.c |6 +++---
 board/mpc8540eval/flash.c   |4 ++--
 board/mpl/common/flash.c|2 +-
 board/musenki/flash.c   |6 +++---
 board/nc650/flash.c |4 ++--
 board/netstal/hcu5/README.txt   |2 +-
 board/netstal/hcu5/hcu5.c   |2 +-
 board/o2dnt/flash.c |2 +-
 board/oxc/flash.c   |2 +-
 board/pcippc2/flash.c   |2 +-
 board/pm520/flash.c |2 +-
 board/pm826/flash.c |2 +-
 board/pm828/flash.c |2 +-
 board/ppmc7xx/flash.c   |2 +-
 board/purple/flash.c|2 +-
 board/r360mpi/flash.c   |4 ++--
 board/rmu/flash.c   |2 +-
 board/rpxsuper/flash.c  |2 +-
 board/rsdproto/flash.c  |2 +-
 board/sacsng/flash.c|4 ++--
 board/sandpoint/flash.c |4 ++--
 board/sbc8260/flash.c   |2 +-
 board/siemens/SCM/flash.c   |2 +-
 board/siemens/pcu_e/flash.c |6 +++---
 board/sl8245/flash.c|4 ++--
 board/stxgp3/flash.c|4 ++--
 board/svm_sc8xx/flash.c |4 ++--
 board/tqc/tqm5200/cam5200_flash.c   |2 +-
 board/tqc/tqm8260/flash.c   |2 +-
 board/tqc/tqm8xx/flash.c|4 ++--
 board/utx8245/flash.c   |4 ++--
 board/westel/amx860/flash.c |6 +++---
 board/xilinx/ml300/ml300.c  |2 +-
 board/xilinx/xilinx_enet/emac_adapter.c |4 ++--
 board/xilinx/xilinx_iic/iic_adapter.c   |2 +-
 

Re: [U-Boot] [PATCH 1/1] add u-boot/types to simplify HOST support

2008-08-17 Thread Wolfgang Denk
Dear Jean-Christophe,

In message [EMAIL PROTECTED] you wrote:

  So it would include linux/types.h for stdint.h for native builds.
  
  With  your  change,  we  have  added  complexity  of  selecting  from
  inttypes.h or stdint.h or unistd.h or nothing.
 
 we can modify it as 

Of course we can modify it - but that doesn't make it less cluttered.

  Are you absolutely sure that this is 100% equivalent and working?
 
 I've test it on MacOs and Linux.

That's just two systems out of N...

Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH, MD: Wolfgang Denk  Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: [EMAIL PROTECTED]
Documentation is the castor oil of programming.
Managers know it must be good because the programmers hate it so much.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] need clarification regarding mmc csd structure declaration

2008-08-17 Thread Gururaja Hebbar K R
 Hi,

 Hi,
 
 I need few clarification regarding mmc csd structure 
 declaration. I was taking Atmel mci as reference.
 
 In ProductManualSDCardv2.2.pdf @ page 34  
 ProdManualSDCardv1.9[1].pdf @ page 39, says 
 
 ...
 ...
 ...
 C_SIZE_MULT   3 bit width
 ERASE_BLK_EN  1 bit width
 SECTOR_SIZE   7 bit width
 WP_GRP_SIZE   7 bit width
 WP_GRP_ENABLE 1 bit width
 ...
 ...
 .. 
 
 But in mmc.h file inside 
 u-boot-1.3.4\include\asm-avr32\arch-at32ap700x.
 
 Here, inside structure mmc_csd @ line 
 
 ...
 ...
 ...
 c_size_mult:3
 sector_size:5
 erase_grp_size:5
 wp_grp_size:5
 wp_grp_enable:1
 ...
 ...
 ...
 
 
 So my doubt is, Shouldn't erase_grp_size come before sector size. 
 
 please correct me if i am wrong.

Could some one clarify my doubt.

TIA

Regards
Gururaja
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot