Re: [webkit-dev] Proposal to change nested namespace indentation rule to match the existing code

2021-10-22 Thread Phil Pizlo via webkit-dev
+1

-Filip


> Wiadomość napisana przez Darin Adler via webkit-dev 
>  w dniu 22.10.2021, o godz. 14:08:
> 
>> On Oct 22, 2021, at 12:33 AM, Kimmo Kinnunen via webkit-dev 
>>  wrote:
>> 
>> 1) Match what seems to already be de-facto used in code.
> 
> Yes, does seem to be what we’re already doing. I like it. The rest of your 
> arguments also seem good.
> 
> — Darin
> ___
> webkit-dev mailing list
> webkit-dev@lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Proposal to change nested namespace indentation rule to match the existing code

2021-10-22 Thread Darin Adler via webkit-dev
> On Oct 22, 2021, at 12:33 AM, Kimmo Kinnunen via webkit-dev 
>  wrote:
> 
> 1) Match what seems to already be de-facto used in code.

Yes, does seem to be what we’re already doing. I like it. The rest of your 
arguments also seem good.

— Darin
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


[webkit-dev] Proposal to change nested namespace indentation rule to match the existing code

2021-10-22 Thread Kimmo Kinnunen via webkit-dev
Hello,
I’d like to propose changing the WebKit coding standard regarding indentation 
of nested namespace contents. 

The change would be to not add indentation for nested namespace contents.

This would be to:
1) Match what seems to already be de-facto used in code.
2) Subjectively simplify the rules. For me personally "never indent” is simple 
to understand.
3) Subjectively no downsides. For me personally indenting contents of nested 
namespaces does not seem to gain readability and does not seem to reduce bugs.
4) Subjectively side-step the issue of what the style guide means. I don’t 
personally understand what "and any nested namespaces with the same scope” 
means.


The change:
https://bugs.webkit.org/show_bug.cgi?id=232073 


Current guide:
https://webkit.org/code-style-guidelines/#indentation 


Please comment if you feel strongly about this.

Now:

namespace WebCore {
namespace Nested {
   struct NestedPayload {
   };
}
struct WebCorePayload {
};
}


After:

namespace WebCore {
namespace Nested {
struct NestedPayload {
};
}
struct WebCorePayload {
};
}

Br,
Kimmo

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev