Re: [PATCH] server: if a debugger is attached to a process, child processes shouldn't get debugged (resend)

2011-10-08 Thread David Laight
On Fri, Oct 07, 2011 at 08:32:27PM +0200, Marcus Meissner wrote:
 On Fri, Oct 07, 2011 at 11:44:24AM +0900, Dmitry Timoshkov wrote:
  Bernhard Loos bernhardl...@googlemail.com wrote:
  
   +int  debug_childs:1;  /* also debug all child 
   processes */
  
  'debug_children' would be a better name.
 
 also
   unsigned intfoo:1;
 please. (int foo:1 works, but is semidefined only ;)

Why the bitfield anyway?
Unless you are allocating a lot of copies of the structure
it is likely to generate more code than the saved memory.

David

-- 
David Laight: da...@l8s.co.uk




Re: user32: Add support for iPaddedBorderWidth in NONCLIENTMETRICS structure.

2011-10-08 Thread Marvin
Hi,

While running your changed tests on Windows, I think I found new failures.
Being a bot and all I'm not very good at pattern recognition, so I might be
wrong, but could you please double-check?
Full results can be found at
http://testbot.winehq.org/JobDetails.pl?Key=14764

Your paranoid android.


=== WINEBUILD (build) ===
Make failed




Re: mpr: Remove DllCanUnloadNow and DllGetClassObject

2011-10-08 Thread André Hentschel
Am 08.10.2011 12:13, schrieb Alistair Leslie-Hughes:
 Hi,
 The native mpr.DLL doesn't have these functions.
 
 
 Changelog:
 mpr: Remove DllCanUnloadNow and DllGetClassObject
 
 
 Best Regards
  Alistair Leslie-Hughes
 
 

no patch?

-- 

Best Regards, André Hentschel




re: Governance of Wine with respect to the Software Freedom Conservancy (update October 2011)

2011-10-08 Thread Dan Kegel
The real way to mount a revolt, of course, would be to
fork wine and maintain a better version of it.  The
likelihood of that ever happening seems slim, but
perhaps in 15 years, after HTML 5 takes over and users
no longer run win32 apps, it's possible that something
like that would happen naturally (say, some computer
museum might become the maintainer).




Re: [PATCH] server: Use syscall(2) instead of inline assembly on Mac OS, too.

2011-10-08 Thread Alexandre Julliard
Charles Davis cda...@mymail.mines.edu writes:

 @@ -268,9 +256,9 @@ int send_thread_signal( struct thread *thread, int sig )
  if (!mach_port_extract_right( process_port, thread-unix_tid,
MACH_MSG_TYPE_COPY_SEND, port, type 
 ))
  {
 -if ((ret = pthread_kill_syscall( port, sig ))  0)
 +if ((ret = syscall( SYS___pthread_kill, port, sig )) != 0)
  {
 -errno = -ret;
 +errno = ret;

syscall is supposed to take care of errno.

-- 
Alexandre Julliard
julli...@winehq.org




Re: jscript: Mark some fall-throughs in switch statements

2011-10-08 Thread Alexandre Julliard
Andrew Talbot andrew.tal...@talbotville.com writes:

 @@ -4037,6 +4037,7 @@ static HRESULT RegExpConstr_leftContext(script_ctx_t 
 *ctx, vdisp_t *jsthis, WORD
  
  V_VT(retv) = VT_BSTR;
  V_BSTR(retv) = ret;
 +/* fall through */
  }
  case DISPATCH_PROPERTYPUT:
  return S_OK;

I don't think that PROPERTYGET is supposed to fall through to
PROPERTYPUT.

-- 
Alexandre Julliard
julli...@winehq.org




Re: inetmib1: Avoid idempotent operation in findSupportedQuery function (Clang)

2011-10-08 Thread Alexandre Julliard
Frédéric Delanoy frederic.dela...@gmail.com writes:

 indexLow is always 0 at that point

This makes it harder to understand what the code is doing here. Probably
needs some restructuring.

-- 
Alexandre Julliard
julli...@winehq.org




Re: jscript: Mark some fall-throughs in switch statements

2011-10-08 Thread Bruno Jesus
On Sat, Oct 8, 2011 at 14:58, Alexandre Julliard julli...@winehq.org wrote:
 Andrew Talbot andrew.tal...@talbotville.com writes:

 @@ -4037,6 +4037,7 @@ static HRESULT RegExpConstr_leftContext(script_ctx_t 
 *ctx, vdisp_t *jsthis, WORD

          V_VT(retv) = VT_BSTR;
          V_BSTR(retv) = ret;
 +        /* fall through */
      }
      case DISPATCH_PROPERTYPUT:
          return S_OK;

 I don't think that PROPERTYGET is supposed to fall through to
 PROPERTYPUT.


Isn't it that way just to save the use of an extra return S_OK?
Instead a break could be used too because that function returns S_OK
by default.

http://source.winehq.org/source/dlls/jscript/regexp.c#L4025

Best regards,
Bruno




Re: jscript: Mark some fall-throughs in switch statements

2011-10-08 Thread Andrew Talbot
 Isn't it that way just to save the use of an extra return S_OK?
 Instead a break could be used too because that function returns S_OK
 by default.
 
 http://source.winehq.org/source/dlls/jscript/regexp.c#L4025
 
 Best regards,
 Bruno

A fall-through would indeed be lazy and not in the spirit of the fact that
DISPATCH_PROPERTYGET and DISPATCH_PROPERTYPUT are kind of the opposite of
each other. It either requires a break in both places (for consistency)
to the common return S_OK or two immediate such returns, instead.

-- 
Andy.





Re: inetmib1: Avoid idempotent operation in findSupportedQuery function (Clang)

2011-10-08 Thread Octavian Voicu
2011/10/2 Frédéric Delanoy frederic.dela...@gmail.com
 -    for (i = (indexLow + indexHigh) / 2; !impl  indexLow = indexHigh;
 -         i = (indexLow + indexHigh) / 2)
 +    for (i = indexHigh / 2; !impl  indexLow = indexHigh; i = (indexLow + 
 indexHigh) / 2)

How about following code:

while (!impl  indexLow = indexHigh)
{
/* ... */
i = (indexLow + indexHigh) / 2;
/* ... */
}

Octavian