Re: gc-pbkdf2-sha1 must not be deprecated

2020-09-23 Thread Bruce Korb
On 9/22/20 10:03 AM, Bruno Haible wrote: I'm not really familiar with these. Does the libgcrypt documentation help, maybe? Bruno I have become much more familiar that I'd really like to be. It seems that without the crypto/gc-pbkdf2-sha1 module defined, then GNULIB_GC_HMAC_SHA1

Re: gc-pbkdf2-sha1 is deprecated

2020-09-22 Thread Bruno Haible
Hi Bruce, > The failing difference isn't whether or not I use gc_pbkdf2_hmac vs. > gc_pbkdf2_sha1, the failing difference is whether or not I specify the > crypto/gc-pbkdf2-sha1 module vs. the crypto/gc-pbkdf2 module. I'm not really familiar with these. Does the libgcrypt documenta

Re: gc-pbkdf2-sha1 is deprecated

2020-09-22 Thread Bruce Korb
Hi Bruno, et al., The failing difference isn't whether or not I use gc_pbkdf2_hmac vs. gc_pbkdf2_sha1, the failing difference is whether or not I specify the crypto/gc-pbkdf2-sha1 module vs. the crypto/gc-pbkdf2 module. The former works, the latter does not, with the rest of my project

Re: gc-pbkdf2-sha1 is deprecated

2020-09-21 Thread Bruce Korb
DF2,// <-- pbkdf2 reprocessing count     hash_output, hash_out_len);     if (rc != GC_OK)     die(GNU_PW_MGR_EXIT_INVALID, pbkdf2_err_fmt, rc); On 9/18/20 9:32 AM, Bruno Haible wrote: Hi Bruce, Next question: what do I do about crypto/gc-pbkdf2-sha1? It is labeled as "

Re: gc-pbkdf2-sha1 is deprecated

2020-09-18 Thread Bruno Haible
Hi Bruce, > Next question: what do I do about crypto/gc-pbkdf2-sha1? It is labeled > as "deprecated", but I need a function that produces precisely the same > result. It really doesn't matter to me that folks have figured out how > to jigger a file to produce an arbitrary

gc-pbkdf2-sha1 is deprecated

2020-09-18 Thread Bruce Korb
Hi Bruno, et al., Next question: what do I do about crypto/gc-pbkdf2-sha1? It is labeled as "deprecated", but I need a function that produces precisely the same result. It really doesn't matter to me that folks have figured out how to jigger a file to produce an arbitrary sha1 s

RFC comments in lib / gc-pbkdf2-sha1.c

2009-11-15 Thread Vladimir 'phcoder' Serbinenko
Hello, all. When importing some gnulib code to GRUB2 I stumbled across lib / gc-pbkdf2-sha1.c having comments taken from RFC2898. As far as I know RFC licence prohibits modifications. This seems to be GPL-incompatible. So is there are any licencing problem with this file? Thanks in advance

Re: RFC comments in lib / gc-pbkdf2-sha1.c

2009-11-15 Thread Simon Josefsson
Vladimir 'phcoder' Serbinenko phco...@gmail.com writes: Hello, all. When importing some gnulib code to GRUB2 I stumbled across lib / gc-pbkdf2-sha1.c having comments taken from RFC2898. As far as I know RFC licence prohibits modifications. This seems to be GPL-incompatible. So

Re: gc-pbkdf2-sha1

2005-10-13 Thread Simon Josefsson
Paul Eggert [EMAIL PROTECTED] writes: Simon Josefsson [EMAIL PROTECTED] writes: Bruno Haible [EMAIL PROTECTED] writes: Simon Josefsson wrote: + l = dkLen / hLen; + if (dkLen % hLen) +l++; An equivalent but faster code is: l = ((dkLen - 1) / hLen) + 1; Perhaps for clarity

gc-pbkdf2-sha1

2005-10-12 Thread Simon Josefsson
+++ ChangeLog 12 Oct 2005 13:12:56 - @@ -1,5 +1,11 @@ 2005-10-12 Simon Josefsson [EMAIL PROTECTED] + * modules/gc-pbkdf2-sha1, modules/gc-pbkdf2-sha1-tests: New files. + + * tests/test-gc-pbkdf2-sha1.c: New file. + +2005-10-12 Simon Josefsson [EMAIL PROTECTED

Re: gc-pbkdf2-sha1

2005-10-12 Thread Ralf Wildenhues
for gnulib yet? Has it been rejected? Index: lib/gc-pbkdf2-sha1.c === RCS file: lib/gc-pbkdf2-sha1.c diff -N lib/gc-pbkdf2-sha1.c --- /dev/null 1 Jan 1970 00:00:00 - +++ lib/gc-pbkdf2-sha1.c 12 Oct 2005 13:12:57 - *snip

Re: gc-pbkdf2-sha1

2005-10-12 Thread Simon Josefsson
Hi Ralf! Thanks for your comments.. Ralf Wildenhues [EMAIL PROTECTED] writes: By the way, has anyone suggested to use one of these documentation- from-source-comments generators for gnulib yet? Has it been rejected? I don't think anyone has proposed it. I'm somewhat biased towards GTK-DOC

Re: [bug-gnulib] gc-pbkdf2-sha1

2005-10-12 Thread Bruno Haible
Simon Josefsson wrote: + l = dkLen / hLen; + if (dkLen % hLen) +l++; An equivalent but faster code is: l = ((dkLen - 1) / hLen) + 1; Bruno ___ bug-gnulib mailing list bug-gnulib@gnu.org

Re: gc-pbkdf2-sha1

2005-10-12 Thread Simon Josefsson
Bruno Haible [EMAIL PROTECTED] writes: Simon Josefsson wrote: + l = dkLen / hLen; + if (dkLen % hLen) +l++; An equivalent but faster code is: l = ((dkLen - 1) / hLen) + 1; Perhaps for clarity we could change it into: #define CEIL_DIV(a,b) (((a) - 1) / (b)) + 1 l = CEIL_DIV

Re: gc-pbkdf2-sha1

2005-10-12 Thread Bruno Haible
Simon Josefsson wrote: Perhaps for clarity we could change it into: #define CEIL_DIV(a,b) (((a) - 1) / (b)) + 1 l = CEIL_DIV (dkLen, hLen); What do you think? People could be tempted to borrow this formula and apply to situations where it doesn't fit. Normally one uses #define