Re: [Graph] Kruskal's algorithm doesn't accept sparse graph

2012-01-31 Thread Simone Tripodi
Hi again, patch applied, tests run like a charme, see issue resolution for details :) Thanks! -Simo http://people.apache.org/~simonetripodi/ http://simonetripodi.livejournal.com/ http://twitter.com/simonetripodi http://www.99soft.org/ On Tue, Jan 31, 2012 at 10:56 AM, Simone Tripodi

Re: [SANDBOX][BeanUtils2] About magic numbers in AccessibleObjectsRegistry.MethodsRegistry.getObjectTransformationCost(Class srcClass, Class destClass)...

2012-01-31 Thread bene
Hey Matt, thanks for the suggestion! I like the idea of having those numbers encapsulated in some sort of data structure. But I don't know if an enum fits the purpose. Maybe I got you wrong. Can you give a code snippet? Defining an enum for float values would require to implement a private

Re: [SANDBOX][BeanUtils2] About magic numbers in AccessibleObjectsRegistry.MethodsRegistry.getObjectTransformationCost(Class srcClass, Class destClass)...

2012-01-31 Thread Simone Tripodi
Hi Benedikt, why do you have the need of declaring constants in a separate interface? Isn't the class itself, where they are used, enough? KISS (keep it simple and straightforward) -Simo PS @Matt: thanks a lot once again for the hight valuable feedbacks, you're a commons-gem!!! -Simo

Re: [SANDBOX][BeanUtils2] About magic numbers in AccessibleObjectsRegistry.MethodsRegistry.getObjectTransformationCost(Class srcClass, Class destClass)...

2012-01-31 Thread bene
Hi Simo, I liked it to have a the interface name as a prefix. But your're right, it's a violation of KISS. I'll create a patch this evening. Thanks again to Matt! Have a nice day, guys ;-) Benedikt - Original Message - From: simonetrip...@apache.org To: dev@commons.apache.org Date:

[Math] Why no AnyVector Interface?

2012-01-31 Thread Bruce A Johnson
Hi, I'm currently working on a scripted interface to Commons Math. I support both Real and Field (Complex) matrices, and Real and Field (Complex) vectors. Checking the size of the matrices is trivial because they both implement AnyMatrix which has row and column size getters, but because

[Math] Package integration (related to MATH-707)

2012-01-31 Thread Gilles Sadowski
Hi. In order to resolve issue MATH-707, one last thing could be changed, to make the whole analysis package self-consistent regarding the class naming scheme: UnivariateRealIntegrator - UnivariateIntegrator Also, the class UnivariateRealIntegratorImpl.java should be renamed. In addition to

Re: [Math] Why no AnyVector Interface?

2012-01-31 Thread Gilles Sadowski
Hello. I'm currently working on a scripted interface to Commons Math. I support both Real and Field (Complex) matrices, and Real and Field (Complex) vectors. Checking the size of the matrices is trivial because they both implement AnyMatrix which has row and column size getters, but

Re: [Math] Package integration (related to MATH-707)

2012-01-31 Thread Brent Worden
On Tue, Jan 31, 2012 at 7:15 AM, Gilles Sadowski gil...@harfang.homelinux.org wrote: Hi. In order to resolve issue MATH-707, one last thing could be changed, to make the whole analysis package self-consistent regarding the class naming scheme: UnivariateRealIntegrator - UnivariateIntegrator

[NET] Release 3.1 ?

2012-01-31 Thread sebb
I think it would be worth releasing NET 3.1 - there have been quite a few fixes and minor improvements since 3.0.1 was released last June. There are still a few outstanding bugs of course, but none of them have patches. I propose to create an RC in the next few days. Last minute patches anyone?

Re: [Math] Package integration (related to MATH-707)

2012-01-31 Thread Dennis Hendriks
I may be overlooking something, but isn't BaseAbstractUnivariateIntegrator double, in the sense that Base and Abstract both refer to an abstract base class that actual integrators can derive from? In other words, wouldn't BaseUnivariateIntegrator or AbstractUnivariateIntegrator be enough?

Re: [Math] Package integration (related to MATH-707)

2012-01-31 Thread Gilles Sadowski
On Tue, Jan 31, 2012 at 04:05:08PM +0100, Dennis Hendriks wrote: I may be overlooking something, but isn't BaseAbstractUnivariateIntegrator double, in the sense that Base and Abstract both refer to an abstract base class that actual integrators can derive from? In other words, wouldn't

Re: [NET] Release 3.1 ?

2012-01-31 Thread Gary Gregory
+1 but no patches from me ATM. Gary On Jan 31, 2012, at 9:46, sebb seb...@gmail.com wrote: I think it would be worth releasing NET 3.1 - there have been quite a few fixes and minor improvements since 3.0.1 was released last June. There are still a few outstanding bugs of course, but none of

Re: [Math] Package integration (related to MATH-707)

2012-01-31 Thread sebb
On 31 January 2012 16:11, Gilles Sadowski gil...@harfang.homelinux.org wrote: On Tue, Jan 31, 2012 at 04:05:08PM +0100, Dennis Hendriks wrote: I may be overlooking something, but isn't BaseAbstractUnivariateIntegrator double, in the sense that Base and Abstract both refer to an abstract base

[Graph] Burovka's algorithm implementation

2012-01-31 Thread Marco Speranza
Hi guys, I just posted on Jira an implementation of Burovka's algorithm (SANDBOX-348) . It's based on Connectivity algorithm for finding the list of connected component and it uses an internal list of vertices in order to reduce the call of the connectivity algorithm. I'm available for comments

Re: [Graph] Burovka's algorithm implementation

2012-01-31 Thread Simone Tripodi
Ciao Marco, thanks for the reminder, I just applied the patch, see r1238692[1]. Please, for future patch, don't reformat the whole code ;) Thanks for contributing! -Simo [1] http://svn.apache.org/viewvc?rev=1238692view=rev http://people.apache.org/~simonetripodi/

Re: [Math] Package integration (related to MATH-707)

2012-01-31 Thread Luc Maisonobe
Le 31/01/2012 14:15, Gilles Sadowski a écrit : Hi. Hi Gilles, In order to resolve issue MATH-707, one last thing could be changed, to make the whole analysis package self-consistent regarding the class naming scheme: UnivariateRealIntegrator - UnivariateIntegrator Also, the class

Re: [Math] Package integration (related to MATH-707)

2012-01-31 Thread Gilles Sadowski
On Tue, Jan 31, 2012 at 04:19:34PM +, sebb wrote: On 31 January 2012 16:11, Gilles Sadowski gil...@harfang.homelinux.org wrote: On Tue, Jan 31, 2012 at 04:05:08PM +0100, Dennis Hendriks wrote: I may be overlooking something, but isn't BaseAbstractUnivariateIntegrator double, in the

Re: [Math] Package integration (related to MATH-707)

2012-01-31 Thread Sébastien Brisard
Hello, I think the opposite: IMHO, as I said above, Base is less redundant than Abstract; and then, the name indicates that the class is the root of the hierarchy for this functionality. I also tend to think that Base or Basic is more meaningful, but any choice is fine by me. Now, if we

Re: [VOTE] Release Configuration 1.8 based on RC1

2012-01-31 Thread Oliver Heger
Hi Gary, Am 30.01.2012 22:37, schrieb Gary Gregory: Hi Oliver: These header issues are not real blockers (hence my -0). I was hoping to nudge you into fixing these but I also know that cutting another RC can be a pain. My POV is that consistency is important. Why make people spend time

Re: [VOTE] Release Configuration 1.8 based on RC1

2012-01-31 Thread Gary Gregory
On Tue, Jan 31, 2012 at 4:08 PM, Oliver Heger oliver.he...@oliver-heger.dewrote: Hi Gary, Am 30.01.2012 22:37, schrieb Gary Gregory: Hi Oliver: These header issues are not real blockers (hence my -0). I was hoping to nudge you into fixing these but I also know that cutting another RC can

[math] Resolve MATH-677?

2012-01-31 Thread Sébastien Brisard
Dear all, I think I've gone through all suggested changes in the package transform (MATH-677). I've left two tasks (namely 3.1 and 3.3 in this issue) - Methods mdfft and verifyDataSet take an argument of type Object (to allow an argument with an unspecified number of dimensions). - For clarity,

[GUMP@vmgump]: Project commons-digester3 (in module apache-commons) failed

2012-01-31 Thread Gump
To whom it may engage... This is an automated request, but not an unsolicited one. For more information please visit http://gump.apache.org/nagged.html, and/or contact the folk at gene...@gump.apache.org. Project commons-digester3 has an issue affecting its community integration. This

Re: [VOTE] Release Configuration 1.8 based on RC1

2012-01-31 Thread Simone Tripodi
+1 too Oliver, great work! -Simo http://people.apache.org/~simonetripodi/ http://simonetripodi.livejournal.com/ http://twitter.com/simonetripodi http://www.99soft.org/ On Tue, Jan 31, 2012 at 11:05 PM, Gary Gregory garydgreg...@gmail.com wrote: On Tue, Jan 31, 2012 at 4:08 PM, Oliver Heger