Reading data from Request Body - Twice!!

2008-05-02 Thread Subra A Narayanan
Hello folks, I really hope someone can point me in the correct direction here. I have an apache module that receives data from clients in the request body and saves the recvd data in a db. The client also sends the Content-MD5 header with the request which I want to verify by computing the MD5

How do I know the character encoding?

2008-05-02 Thread John Zhang
In my output filter, I need to parse the document to search for certain patterns. Where can I get the information about the (character) encoding so that I can parse the document correctly? Eg the document may contain unicode characters and are encoded in a special encoding. Thanks, John

Re: svn commit: r646285 - in /httpd/httpd/trunk: CHANGES docs/manual/mod/mod_auth_form.xml modules/aaa/config.m4 modules/aaa/mod_auth_form.c

2008-05-02 Thread Plüm , Rüdiger , VF-Group
-Ursprüngliche Nachricht- Von: Graham Leggett Gesendet: Freitag, 2. Mai 2008 00:01 An: dev@httpd.apache.org Betreff: Re: svn commit: r646285 - in /httpd/httpd/trunk: CHANGES docs/manual/mod/mod_auth_form.xml modules/aaa/config.m4 modules/aaa/mod_auth_form.c Ruediger Pluem

Re: apache mod_dbd/htaccess

2008-05-02 Thread Graham Leggett
Res wrote: So what would be the impact to having a very large httpd.conf file, having to read in, perhaps many thousands of extra directory blocks? If only 100 or 1000 want it thats fine, but if i end up with 10+K wanting it, I would like to know what impact I may expect, what would be the

Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/

2008-05-02 Thread Graham Leggett
Ruediger Pluem wrote: +/* all is well, set aside the buckets */ +for (bucket = APR_BRIGADE_FIRST(b); + bucket != APR_BRIGADE_SENTINEL(b); + bucket = APR_BUCKET_NEXT(bucket)) +{ +apr_bucket_copy(bucket, e); What about transient buckets? Don't we need to set

Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/

2008-05-02 Thread Plüm , Rüdiger , VF-Group
-Ursprüngliche Nachricht- Von: Graham Leggett Gesendet: Freitag, 2. Mai 2008 12:40 An: dev@httpd.apache.org Betreff: Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/ Ruediger Pluem wrote: +

Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/

2008-05-02 Thread Graham Leggett
Plüm wrote: What about transient buckets? Don't we need to set them aside? I don't follow - does the apr_bucket_copy not do that for us already? No, it does not. Let me look further. In theory, that would mean you could only read the kept_body once. The kept body could be delivered to

Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/

2008-05-02 Thread Plüm , Rüdiger , VF-Group
-Ursprüngliche Nachricht- Von: Graham Leggett Gesendet: Freitag, 2. Mai 2008 13:28 An: dev@httpd.apache.org Betreff: Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/ Plüm wrote: I think

Revamped apachemonitor.exe trunk/ needs review

2008-05-02 Thread William A. Rowe, Jr.
Looking for backport votes in STATUS to move the current trunk/ code into our 2.2.x and 2.0.x branches for apachemonitor.c. The module has been taught ucs-16 service names for our non-western-latin language friends (it's a matter of replacing the /D _MCBS with /D _UNICODE and /D UNICODE in the

Building trunk on Windows

2008-05-02 Thread César Leonardo Blum Silveira
Hi all, Is there any documentation regarding how to build httpd-trunk on Windows? Thanks, -- César L. B. Silveira

Re: Revamped apachemonitor.exe trunk/ needs review

2008-05-02 Thread William A. Rowe, Jr.
William A. Rowe, Jr. wrote: For the few of you who want to test this directly, I've compiled trunk and dropped the binary to http://people.apache.org/~wrowe/ if you just want to avoid compilation. There are VC6 builds for regular as well as the unicode flavor. The VS2005 builds require the

Re: AuthzMergeRules directive

2008-05-02 Thread Chris Darroch
Brad Nicholes wrote: So what I am really trying to say is that intra-block logic and inter-block logic as far as merging goes, are tied together. If we want to change the way that the logic of two block is merged, we would also have to change the base state of each independent block. It's all

Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/

2008-05-02 Thread Roy T. Fielding
On May 2, 2008, at 4:07 AM, Plüm, Rüdiger, VF-Group wrote: +c = low ^ hi; Shouldn't this be c = low + hi ? In theory either should work, which is faster? The AND. I think there is not much difference with respect to speed but using '+' seems to be easier to read.

apr_cvt() in apr_snprintf() - not (L)GPL

2008-05-02 Thread Jim Jagielski
This closes a long standing confusion on some code in apr_snprintf() (and ap_snprintf() in apache-1.3). The comments indicate that the apr_cvt() implementation was pulled from GNU libc. However, the actual origin of the code is from UNIX V7 (at least... it is also possible that this was

Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/

2008-05-02 Thread Ruediger Pluem
On 05/02/2008 07:54 PM, Roy T. Fielding wrote: On May 2, 2008, at 4:07 AM, Plüm, Rüdiger, VF-Group wrote: +c = low ^ hi; Shouldn't this be c = low + hi ? In theory either should work, which is faster? The AND. I agree that an AND () or an OR (|) would be also

Re: svn commit: r647263 - in /httpd/httpd/trunk: ./ docs/manual/mod/ include/ modules/aaa/ modules/filters/ modules/http/ server/

2008-05-02 Thread Roy T. Fielding
On May 2, 2008, at 11:19 AM, Ruediger Pluem wrote: On 05/02/2008 07:54 PM, Roy T. Fielding wrote: On May 2, 2008, at 4:07 AM, Plüm, Rüdiger, VF-Group wrote: +c = low ^ hi; Shouldn't this be c = low + hi ? In theory either should work, which is faster? The AND. I