Re: [VOTE] Release Tobago 1.5.3

2012-02-15 Thread Bernd Bohmann
Here is my

+1

Regards

Bernd

On Tue, Feb 14, 2012 at 6:41 AM, Udo Schnurpfeil u...@schnurpfeil.de wrote:
 +1

 Regards

 Udo


 Am 13.02.2012 um 18:20 schrieb Grant Smith work.gr...@gmail.com:

 +1

 On Mon, Feb 13, 2012 at 9:07 AM, Werner Punz werner.p...@gmail.com wrote:

 +1

 Am 13.02.12 09:18, schrieb Volker Weber:

 Hi,

 +1

 Regards,
     Volker

 Am 12. Februar 2012 00:15 schrieb Bernd
 Bohmannbernd.bohm...@atanion.com:

 Hello,

 I would like to release Tobago 1.5.3.

 For a detail list please consult the release notes:


 http://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12310273styleName=Htmlversion=12319499

 The version is available at the nexus staging repository.

 Staging repository:

 https://repository.apache.org/content/repositories/orgapachemyfaces-222/

 The Vote is open for 72h.

 [ ] +1
 [ ] +0
 [ ] -1

 Regards

 Bernd









 --
 Grant Smith - V.P. Information Technology
 Marathon Computer Systems, LLC.



[RESULT] [VOTE] Release Tobago 1.5.3

2012-02-15 Thread Bernd Bohmann
The vote has passed with the following results:

+1
weber (binding)
werpu (binding)
grantsmith (binding)
lofwyr (binding)
bommel (binding)

I will proceed with the next steps.

Regards,

Bernd

On Wed, Feb 15, 2012 at 9:03 AM, Bernd Bohmann
bernd.bohm...@atanion.com wrote:
 Here is my

 +1

 Regards

 Bernd

 On Tue, Feb 14, 2012 at 6:41 AM, Udo Schnurpfeil u...@schnurpfeil.de wrote:
 +1

 Regards

 Udo


 Am 13.02.2012 um 18:20 schrieb Grant Smith work.gr...@gmail.com:

 +1

 On Mon, Feb 13, 2012 at 9:07 AM, Werner Punz werner.p...@gmail.com wrote:

 +1

 Am 13.02.12 09:18, schrieb Volker Weber:

 Hi,

 +1

 Regards,
     Volker

 Am 12. Februar 2012 00:15 schrieb Bernd
 Bohmannbernd.bohm...@atanion.com:

 Hello,

 I would like to release Tobago 1.5.3.

 For a detail list please consult the release notes:


 http://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12310273styleName=Htmlversion=12319499

 The version is available at the nexus staging repository.

 Staging repository:

 https://repository.apache.org/content/repositories/orgapachemyfaces-222/

 The Vote is open for 72h.

 [ ] +1
 [ ] +0
 [ ] -1

 Regards

 Bernd









 --
 Grant Smith - V.P. Information Technology
 Marathon Computer Systems, LLC.



[jira] [Commented] (TOBAGO-986) Sheet can only sort UIOutput - Nothing happend with UILinkCommand and UIButtonCommand

2012-02-15 Thread Helmut Swaczinna (Commented) (JIRA)

[ 
https://issues.apache.org/jira/browse/TOBAGO-986?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13208292#comment-13208292
 ] 

Helmut Swaczinna commented on TOBAGO-986:
-

Since this fix sorting does not work anymore when a tc:out is embedded in a 
tc:link. Example:

  tc:column 
label=Label
sortable=true
tc:link 
  tc:out 
value=#{var.property}/
/tc:link
  /tc:column

Exception:
java.lang.ClassCastException: xxx cannot be cast to java.lang.Comparable
at java.util.Arrays.mergeSort(Arrays.java:1144)
at java.util.Arrays.sort(Arrays.java:1208)
at java.util.Collections.sort(Collections.java:159)
at org.apache.myfaces.tobago.component.Sorter.invoke(Sorter.java:148)

Please reopen the issue. The probem is that the tc:out will never be found by 
getFirstSortableChild()
I will try to find a fix. In the meantime I'm forced to switch back to the old 
code.


 Sheet can only sort UIOutput - Nothing happend with UILinkCommand and 
 UIButtonCommand
 -

 Key: TOBAGO-986
 URL: https://issues.apache.org/jira/browse/TOBAGO-986
 Project: MyFaces Tobago
  Issue Type: Improvement
  Components: Core
Affects Versions: 1.0.35
Reporter: Sven Bunge
Assignee: Bernd Bohmann
Priority: Minor
 Fix For: 1.0.36, 1.5.0-beta-1, 1.5.0

 Attachments: 
 Patch_for_TOBAGO-986__Make_UILinkCommand_and_UIButtonCommand_sortable.patch


 If a column in a sheet is filled with a tc:link (UILinkCommand) or tc:button 
 (UIButtonCommand) the Sorter-class is unable to sort the sheet.
 There are several problems with the method Sorter#getFirstSortableChild(..):
 * The children of a UICommand are recursive searched for a tc:out - the 
 algorithm look into the tc:link and tc:button.
 * Only tc:out's are returned from the method
 * .. the caller method invoke(..) get only the value-binding named value - 
 The UILinkCommand and UIButtonCommand have no value-field. 
 I optimized the getFirstSortableChild(..)-Method and introduced a new method 
 how returns the ValueBinding.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (TOBAGO-986) Sheet can only sort UIOutput - Nothing happend with UILinkCommand and UIButtonCommand

2012-02-15 Thread Helmut Swaczinna (Commented) (JIRA)

[ 
https://issues.apache.org/jira/browse/TOBAGO-986?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13208343#comment-13208343
 ] 

Helmut Swaczinna commented on TOBAGO-986:
-

This should work for both cases:

  private UIComponent getFirstSortableChild(List children) {
UIComponent child = null;

for (Iterator iter = children.iterator(); iter.hasNext();) {
  child = (UIComponent) iter.next();
  if (child instanceof UISelectMany
  || child instanceof UISelectOne
  || child instanceof UISelectBoolean
  || (child instanceof UIInput  
TobagoConstants.RENDERER_TYPE_HIDDEN.equals(child.getRendererType( {
continue;
// look for a better component if any
  }
  if (child instanceof UIOutput) {
break;
  }
  if (child instanceof javax.faces.component.UICommand  
child.getChildren().isEmpty()) {
// use label attribute of UICommand
break;
  }
  if (child instanceof javax.faces.component.UICommand
  || child instanceof javax.faces.component.UIPanel) {
child = getFirstSortableChild(child.getChildren());
if (child instanceof UIOutput) {
  break;
}
  }
}
return child;
  }


 Sheet can only sort UIOutput - Nothing happend with UILinkCommand and 
 UIButtonCommand
 -

 Key: TOBAGO-986
 URL: https://issues.apache.org/jira/browse/TOBAGO-986
 Project: MyFaces Tobago
  Issue Type: Improvement
  Components: Core
Affects Versions: 1.0.35
Reporter: Sven Bunge
Assignee: Bernd Bohmann
Priority: Minor
 Fix For: 1.0.36, 1.5.0-beta-1, 1.5.0

 Attachments: 
 Patch_for_TOBAGO-986__Make_UILinkCommand_and_UIButtonCommand_sortable.patch


 If a column in a sheet is filled with a tc:link (UILinkCommand) or tc:button 
 (UIButtonCommand) the Sorter-class is unable to sort the sheet.
 There are several problems with the method Sorter#getFirstSortableChild(..):
 * The children of a UICommand are recursive searched for a tc:out - the 
 algorithm look into the tc:link and tc:button.
 * Only tc:out's are returned from the method
 * .. the caller method invoke(..) get only the value-binding named value - 
 The UILinkCommand and UIButtonCommand have no value-field. 
 I optimized the getFirstSortableChild(..)-Method and introduced a new method 
 how returns the ValueBinding.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Created] (TOBAGO-1093) The attribute to set the label for tc:selectBooleanCheckbox should be named as itemLabel instead of label

2012-02-15 Thread Udo Schnurpfeil (Created) (JIRA)
The attribute to set the label for tc:selectBooleanCheckbox should be named as 
itemLabel instead of label
-

 Key: TOBAGO-1093
 URL: https://issues.apache.org/jira/browse/TOBAGO-1093
 Project: MyFaces Tobago
  Issue Type: Task
Affects Versions: 1.5.3
Reporter: Udo Schnurpfeil
Assignee: Udo Schnurpfeil
Priority: Minor


This change make the two tag tc:selectBooleanCheckbox and  
tx:selectBooleanCheckbox more consistent.
The tx tag uses the itemLabel attribute to set the label in the checkbox itself.
In sum we have 3 label to keep consistent:
1. the tobago tx label which was rendered separatly from the component
2. the label of the component
3. the JSF label attribute which is be shown in faces error messages.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Resolved] (TRINIDAD-2215) String - Accessibility enum API

2012-02-15 Thread Andy Schwartz (Resolved) (JIRA)

 [ 
https://issues.apache.org/jira/browse/TRINIDAD-2215?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Andy Schwartz resolved TRINIDAD-2215.
-

   Resolution: Fixed
Fix Version/s: 2.0.2-core

Added Accessibility.displayName() and Accessibility.valueOfDisplayName() APIs 
in r1244522.

 String - Accessibility enum API
 

 Key: TRINIDAD-2215
 URL: https://issues.apache.org/jira/browse/TRINIDAD-2215
 Project: MyFaces Trinidad
  Issue Type: Improvement
Affects Versions: 2.0.0-core
Reporter: Andy Schwartz
Assignee: Andy Schwartz
Priority: Minor
 Fix For: 2.0.2-core

 Attachments: trinidad-2215-take2.patch, trinidad-2215.patch


 The RequestContext.Accessibility enum defines aliases/pretty names for the 
 enum constants:
   public enum Accessibility
   {
 /**
  * Output supports accessibility features
  */
 DEFAULT(default),
 /**
  * Accessibility-specific constructs are stripped out to optimize output 
 size
  */
 INACCESSIBLE(inaccessible),
 /**
  * Accessibility-specific constructs are added to improve behavior under 
 a screen reader
  * (but may affect other users negatively)
  */
 SCREEN_READER(screenReader);
 Accessibility(String name)
 {
   _name = name;
 }
 @Override
 public String toString()
 {
   return _name;
 }
 private final String _name;
   };
 I have several places in my code where I need to translate from the pretty 
 name/alias (eg. screenReader), back to the corresponding enum constant.
 Enum.valueOf() is useless for this, since this only honors the canonical enum 
 constant names (eg. SCREEN_READER).
 I would like an API that performs the equivalent functionality of 
 Enum.valueOf(), but for the pretty names/aliases.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (MYFACES-3459) RegexValidator does not provide label and pattern for first usage of RegexValidator.NOT_MATCHED

2012-02-15 Thread Leonardo Uribe (Commented) (JIRA)

[ 
https://issues.apache.org/jira/browse/MYFACES-3459?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13208578#comment-13208578
 ] 

Leonardo Uribe commented on MYFACES-3459:
-

Added messages for en, es and de languages. I'm not sure about change how this 
validator works, because any change in behavior must be done at spec level.

 RegexValidator does not provide label and pattern for first usage of 
 RegexValidator.NOT_MATCHED
 ---

 Key: MYFACES-3459
 URL: https://issues.apache.org/jira/browse/MYFACES-3459
 Project: MyFaces Core
  Issue Type: Bug
  Components: General
Affects Versions: 2.1.5
 Environment: myfaces trunk
Reporter: Martin Kočí
Assignee: Martin Kočí
Priority: Trivial

 RegexValidator uses javax.faces.validator.RegexValidator.NOT_MATCHED 2x:
 javax.faces.validator.RegexValidator.NOT_MATCHED= the passed value is not a 
 String, or when the pattern does not match the passed value.
 the first usage for if (value instanceof String) check does not provide 
 args for {0} {1} in message.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Created] (MYFACES-3465) Provide stateless extension

2012-02-15 Thread Thomas Andraschko (Created) (JIRA)
Provide stateless extension
---

 Key: MYFACES-3465
 URL: https://issues.apache.org/jira/browse/MYFACES-3465
 Project: MyFaces Core
  Issue Type: New Feature
Reporter: Thomas Andraschko


As discussed with Leonardo, i create an issue with the stateless jsf extension. 
The code: http://www.mediafire.com/?3wr72zlch7ly1wc (also prepared with myfaces 
namespace and checkstyle)

This extension is based on: 
http://industrieit.com/blog/2011/11/stateless-jsf-high-performance-zero-per-request-memory-overhead/
 (Thanks to Rudi!)
I completely refactored the code and made it compatible with mojarra and 
myfaces (with extra modules).





--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira