[PATCH 0/6] Add device tree support for imx spi driver

2011-07-08 Thread Shawn Guo
The patch set makes some cleanups on imx spi driver to get it ready for adding device tree probe and then add the support. Those two dt helper function related patches are carried here to resolve the dependency. They should be on the way to sit on Grant's devicetree/next branch. Rob Herring

[PATCH 1/6] ARM: mxc: remove unnecessary header file inclusion from gpio.h

2011-07-08 Thread Shawn Guo
The mach/gpio.h is included by asm/gpio.h, and in turn it gets included all over the place. Including unnecessary headers there brings indirect inclusion trouble. As an example, spi-imx calls cpu_is_mx21() but never explicitly includes mach/hardware.h. However it works because the header is

[PATCH 2/6] spi/imx: use soc name in spi device type naming scheme

2011-07-08 Thread Shawn Guo
Software defined version number is not stable enough to be used in device type naming scheme. The patch changes it to use implicit soc name for spi device type definition. In this way, we can easily align the naming scheme with device tree binding, which comes later. Signed-off-by: Shawn Guo

[PATCH 3/6] spi/imx: copy gpio number passed by platform data into driver private data

2011-07-08 Thread Shawn Guo
It copies gpio number passed via platform data embedded pointer into driver private data, so that we do not need to refer to this embedded pointer passed by platform data after probe function exits. Signed-off-by: Shawn Guo shawn@linaro.org Cc: Uwe Kleine-König u.kleine-koe...@pengutronix.de

[PATCH 4/6] dt: add helper function to read u32 arrays

2011-07-08 Thread Shawn Guo
From: Rob Herring rob.herr...@calxeda.com Rework of_property_read_u32 to read an array of values. Then of_property_read_u32 becomes an inline with array size of 1. Also make struct device_node ptr const. Signed-off-by: Rob Herring rob.herr...@calxeda.com Cc: Thomas Abraham

[PATCH 5/6] dt: add empty of_property_read_u32[_array] for non-dt

2011-07-08 Thread Shawn Guo
The patch adds empty functions of_property_read_u32 and of_property_read_u32_array for non-dt build, so that drivers migrating to dt can save some '#ifdef CONFIG_OF'. Signed-off-by: Shawn Guo shawn@linaro.org Cc: Rob Herring rob.herr...@calxeda.com Cc: Thomas Abraham thomas.abra...@linaro.org

Re: [PATCH v2 1/5] dt: add of_alias_scan and of_alias_get_id

2011-07-08 Thread Shawn Guo
Hi Grant, I saw neither your comments nor ack on this patch. Where does it go? Regards, Shawn On Sat, Jun 25, 2011 at 02:04:32AM +0800, Shawn Guo wrote: The patch adds function of_alias_scan to populate a global lookup table with the properties of 'aliases' node and function of_alias_get_id

[PATCH v5 3/3] ARM: CSR: initializing L2 cache

2011-07-08 Thread Barry Song
From: Rongjun Ying rongjun.y...@csr.com Signed-off-by: Rongjun Ying rongjun.y...@csr.com Signed-off-by: Barry Song baohua.s...@csr.com Reviewed-by: Arnd Bergmann a...@arndb.de --- arch/arm/mach-prima2/Makefile |1 + arch/arm/mach-prima2/l2x0.c | 59

[PATCH v5 0/3] ARM: CSR: Adding CSR SiRFprimaII platform

2011-07-08 Thread Barry Song
Changelogs: -v5: add lost Reviewed-by: Arnd Bergmann a...@arndb.de in git log add UL suffix to VMALLOC_END -v4: v3 got Reviewed-by: Arnd Bergmann a...@arndb.de stopping the 0x madness for IO_SPACE_LIMIT fix .map_io compiling issue in the 1st patch fix set_next_event in timer.c rename GPU,

[PATCH v5 2/3] ARM: CSR: mapping early DEBUG_LL uart

2011-07-08 Thread Barry Song
Signed-off-by: Barry Song baohua.s...@csr.com Reviewed-by: Arnd Bergmann a...@arndb.de --- arch/arm/mach-prima2/Makefile |1 + arch/arm/mach-prima2/common.h |6 ++ arch/arm/mach-prima2/lluart.c | 25 + arch/arm/mach-prima2/prima2.c |1 + 4 files changed,

Re: [PATCH v3 0/3] Add device tree probe for imx/mxc gpio

2011-07-08 Thread Sascha Hauer
On Thu, Jul 07, 2011 at 01:27:05PM -0600, Grant Likely wrote: On Thu, Jul 07, 2011 at 12:37:40AM +0800, Shawn Guo wrote: The first patch removes the uses of cpu_is_mx(), the second one changes mxc gpio number macro, and the third one adds actual device tree probe support. Changes since

[PATCH] ARM: mmp: remove SPARSE_IRQ for mmp

2011-07-08 Thread Haojian Zhuang
Avoid to use SPARSE_IRQ for mmp. There will be irq domain translation between DT irq specifier and the Linux irq number. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- arch/arm/Kconfig |1 - 1 files changed, 0 insertions(+), 1 deletions(-) diff --git a/arch/arm/Kconfig

[PATCH] mfd: convert devicetree to platform data on max8925

2011-07-08 Thread Haojian Zhuang
Make max8925 to support both platform data and device tree. So a translation between device tree and platform data is added. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- drivers/mfd/max8925-i2c.c | 159 - 1 files changed, 157

[PATCH] ARM: mmp: remove builtin gpio driver support

2011-07-08 Thread Haojian Zhuang
Remove builtin gpio driver support form mmp. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- arch/arm/mach-mmp/include/mach/gpio.h | 27 +++ arch/arm/mach-mmp/mmp2.c | 17 - arch/arm/mach-mmp/pxa168.c| 17

[PATCH] regulator: convert devicetree to platform data on max8649

2011-07-08 Thread Haojian Zhuang
Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- drivers/regulator/max8649.c | 70 +++ 1 files changed, 70 insertions(+), 0 deletions(-) diff --git a/drivers/regulator/max8649.c b/drivers/regulator/max8649.c index 30eb9e5..4316a37 100644 ---

[PATCH] ARM: mmp: add DTS file

2011-07-08 Thread Haojian Zhuang
Add DTS file to support brownstone ttc-dkb. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- arch/arm/boot/dts/mmp2-brownstone.dts | 319 + arch/arm/boot/dts/ttc-dkb.dts | 176 ++ arch/arm/mach-mmp/brownstone.c| 66

[PATCH] ARM: mmp: support OF by default

2011-07-08 Thread Haojian Zhuang
Support open firmware by default. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- arch/arm/Kconfig |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig index 48748fb..7b083a0 100644 --- a/arch/arm/Kconfig +++ b/arch/arm/Kconfig

[PATCH] tty: serial: check ops before registering console

2011-07-08 Thread Haojian Zhuang
Console should be only registered after port-ops assigned. If uart console doesn't match the current uart, port-ops keeps NULL. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- drivers/tty/serial/pxa.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git

[PATCH] tty: serial: support device tree in pxa

2011-07-08 Thread Haojian Zhuang
Support both normal platform driver and device tree driver in serial pxa. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- drivers/tty/serial/Kconfig |4 +- drivers/tty/serial/of_serial.c | 12 + drivers/tty/serial/pxa.c | 91

[PATCH] i2c: pxa: create dynamic platform device from device tree

2011-07-08 Thread Haojian Zhuang
Create two probe function to support both current platform device and created dynamic platform device from device tree. After moving to device tree, original implementation of platform device will be removed. Use property to present polling mode and frequency mode. Signed-off-by: Haojian Zhuang

[PATCH] mfd: convert devicetree to platform on 88pm860x

2011-07-08 Thread Haojian Zhuang
Make 88pm860x to support both platform data and device tree. So a translation between device tree and platform data is added. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- drivers/mfd/88pm860x-i2c.c | 191 +++- 1 files changed, 189

[PATCH] ARM: mmp: parse irq from DT

2011-07-08 Thread Haojian Zhuang
Parse irq sepcifier from DT and translate it to Linux irq number. Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- arch/arm/mach-mmp/Makefile |2 + arch/arm/mach-mmp/common.h |1 + arch/arm/mach-mmp/intc.c | 245 3 files

[PATCH] of: add devicetree API for regulator

2011-07-08 Thread Haojian Zhuang
Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com --- drivers/of/Kconfig |4 + drivers/of/Makefile |1 + drivers/of/of_regulator.c| 166 ++ include/linux/of_regulator.h | 34 + 4 files changed, 205

Re: [PATCH 2/6] spi/imx: use soc name in spi device type naming scheme

2011-07-08 Thread Sascha Hauer
On Fri, Jul 08, 2011 at 04:27:30PM +0800, Shawn Guo wrote: Software defined version number is not stable enough to be used in device type naming scheme. The patch changes it to use implicit soc name for spi device type definition. In this way, we can easily align the naming scheme with

Re: [PATCH 5/6] dt: add empty of_property_read_u32[_array] for non-dt

2011-07-08 Thread Rob Herring
Shawn, On 07/08/2011 03:27 AM, Shawn Guo wrote: The patch adds empty functions of_property_read_u32 and of_property_read_u32_array for non-dt build, so that drivers migrating to dt can save some '#ifdef CONFIG_OF'. Signed-off-by: Shawn Guo shawn@linaro.org Cc: Rob Herring

Re: [RFC PATCH 09/11] arm/dt: Add dt machine definition

2011-07-08 Thread Rob Herring
Grant, On 06/15/2011 11:42 PM, Grant Likely wrote: This patch adds a DT_MACHINE_START macro to use instead of MACHINE_START when creating a machine_desc that supports using the device tree. Signed-off-by: Grant Likely grant.lik...@secretlab.ca --- arch/arm/include/asm/mach/arch.h |9

Re: [PATCH] of: add devicetree API for regulator

2011-07-08 Thread Grant Likely
Hi Haojian, On Fri, Jul 8, 2011 at 4:20 AM, Haojian Zhuang haojian.zhu...@marvell.com wrote: Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com No commit description? ---  drivers/of/Kconfig           |    4 +  drivers/of/Makefile          |    1 +  drivers/of/of_regulator.c    |  

Re: [PATCH v4 2/2] ARM: l2x0: Add OF based initialization

2011-07-08 Thread Rob Herring
Russell, On 07/06/2011 04:26 PM, Arnd Bergmann wrote: On Wednesday 06 July 2011 23:02:37 Grant Likely wrote: On Wed, Jul 06, 2011 at 03:42:59PM -0500, Rob Herring wrote: From: Rob Herring rob.herr...@calxeda.com This adds probing for ARM L2x0 cache controllers via device tree. Support

Re: [PATCH v3 0/3] Add device tree probe for imx/mxc gpio

2011-07-08 Thread Grant Likely
On Fri, Jul 08, 2011 at 12:36:22PM +0200, Sascha Hauer wrote: On Thu, Jul 07, 2011 at 01:27:05PM -0600, Grant Likely wrote: On Thu, Jul 07, 2011 at 12:37:40AM +0800, Shawn Guo wrote: The first patch removes the uses of cpu_is_mx(), the second one changes mxc gpio number macro, and the

Re: [PATCH 5/6] dt: add empty of_property_read_u32[_array] for non-dt

2011-07-08 Thread Grant Likely
On Fri, Jul 08, 2011 at 04:27:33PM +0800, Shawn Guo wrote: The patch adds empty functions of_property_read_u32 and of_property_read_u32_array for non-dt build, so that drivers migrating to dt can save some '#ifdef CONFIG_OF'. Signed-off-by: Shawn Guo shawn@linaro.org Cc: Rob Herring

Re: [PATCH 0/6] Add device tree support for imx spi driver

2011-07-08 Thread Grant Likely
On Fri, Jul 08, 2011 at 04:27:28PM +0800, Shawn Guo wrote: The patch set makes some cleanups on imx spi driver to get it ready for adding device tree probe and then add the support. Those two dt helper function related patches are carried here to resolve the dependency. They should be on

Re: [PATCH] tty/serial: tegra: Use engineering names in DT compatible property

2011-07-08 Thread Greg KH
On Tue, Jul 05, 2011 at 02:07:41PM -0600, Stephen Warren wrote: Engineering names are more stable than marketing names. Hence, use them for Device Tree compatible properties instead. Signed-off-by: Stephen Warren swar...@nvidia.com --- Greg, This builds on patches Grant has (or has said he

Re: [PATCH] of: add devicetree API for regulator

2011-07-08 Thread Mark Brown
On Fri, Jul 08, 2011 at 08:51:17AM -0600, Grant Likely wrote: Hi Haojian, On Fri, Jul 8, 2011 at 4:20 AM, Haojian Zhuang haojian.zhu...@marvell.com wrote: Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com No commit description? Gah, don't bury major API changes like this in the

Re: [PATCH] of: add devicetree API for regulator

2011-07-08 Thread Mark Brown
On Fri, Jul 08, 2011 at 06:20:24PM +0800, Haojian Zhuang wrote: Signed-off-by: Haojian Zhuang haojian.zhu...@marvell.com Overall this looks like a reasonable start but I'm having a hard time seeing how this would actually be used and there's a *lot* of Linux specifics in here which aren't going