Re: [RFC PATCH] tty/serial: atmel_serial: add device tree support

2011-10-04 Thread Nicolas Ferre
On 10/04/2011 03:58 AM, Rob Herring : On 10/03/2011 04:51 AM, Nicolas Ferre wrote: Signed-off-by: Nicolas Ferre nicolas.fe...@atmel.com --- Hi, Here is a first attempt to add device tree support to atmel_serial driver. RS485 data are not handled for the moment. My feeling is that they

Re: [PATCH 2/9] regulator: helper routine to extract regulator_init_data

2011-10-04 Thread Mark Brown
On Tue, Oct 04, 2011 at 10:58:40AM +0530, Rajendra Nayak wrote: The problem is I don't know if the property in the regulator dt node is called vin-supply or vxyz-supply and hence I can parse the property based on a substring alone, which is -supply because all I know is the property name is

Re: [PATCH 2/9] regulator: helper routine to extract regulator_init_data

2011-10-04 Thread Rajendra Nayak
On Tuesday 04 October 2011 03:48 PM, Mark Brown wrote: On Tue, Oct 04, 2011 at 10:58:40AM +0530, Rajendra Nayak wrote: The problem is I don't know if the property in the regulator dt node is called vin-supply or vxyz-supply and hence I can parse the property based on a substring alone, which

Re: [PATCH 2/9] regulator: helper routine to extract regulator_init_data

2011-10-04 Thread Mark Brown
On Tue, Oct 04, 2011 at 05:10:00PM +0530, Rajendra Nayak wrote: On Tuesday 04 October 2011 03:48 PM, Mark Brown wrote: This seems fairly straightforward though it will require some changes within Linux, all we have to do is have the regulators name their supplies. through dt? thats what the

Re: [PATCH 2/9] regulator: helper routine to extract regulator_init_data

2011-10-04 Thread Rajendra Nayak
On Tuesday 04 October 2011 05:21 PM, Mark Brown wrote: On Tue, Oct 04, 2011 at 05:10:00PM +0530, Rajendra Nayak wrote: On Tuesday 04 October 2011 03:48 PM, Mark Brown wrote: This seems fairly straightforward though it will require some changes within Linux, all we have to do is have the

Re: [PATCH 2/9] regulator: helper routine to extract regulator_init_data

2011-10-04 Thread Mark Brown
On Tue, Oct 04, 2011 at 05:32:47PM +0530, Rajendra Nayak wrote: On Tuesday 04 October 2011 05:21 PM, Mark Brown wrote: I wouldn't expect it done through DT (except for things like the fixed voltage regulator) - the driver should just know. something like a int regulator_set_supply(struct

Re: [PATCH 2/9] regulator: helper routine to extract regulator_init_data

2011-10-04 Thread Nayak, Rajendra
On Tue, Oct 4, 2011 at 5:41 PM, Mark Brown broo...@opensource.wolfsonmicro.com wrote: On Tue, Oct 04, 2011 at 05:32:47PM +0530, Rajendra Nayak wrote: On Tuesday 04 October 2011 05:21 PM, Mark Brown wrote: I wouldn't expect it done through DT (except for things like the fixed voltage

Re: [RFC PATCH] tty/serial: atmel_serial: add device tree support

2011-10-04 Thread Rob Herring
Nicolas, On 10/04/2011 03:18 AM, Nicolas Ferre wrote: On 10/04/2011 03:58 AM, Rob Herring : On 10/03/2011 04:51 AM, Nicolas Ferre wrote: Signed-off-by: Nicolas Ferre nicolas.fe...@atmel.com --- Hi, Here is a first attempt to add device tree support to atmel_serial driver. RS485 data are

Re: [PATCH 0/3] GIC OF bindings

2011-10-04 Thread Rob Herring
Grant, On 09/30/2011 02:27 PM, Rob Herring wrote: From: Rob Herring rob.herr...@calxeda.com Another round of GIC devicetree support. This moves the tracking of the starting hwirq number into the irq domain code. Doing this makes hwirq == GIC interrupt ID and simplifies the GIC code

[PATCH v4 07/24] C6X: devicetree support

2011-10-04 Thread Mark Salter
This is the basic devicetree support for C6X. Currently, four boards are supported. Each one uses a different SoC part. Two of the four supported SoCs are multicore. One with 3 cores and the other with 6 cores. There is no coherency between the core-level caches, so SMP is not an option. It is

Re: [PATCH 8/9] regulator: helper to extract regulator node based on supply name

2011-10-04 Thread Grant Likely
On Fri, Sep 30, 2011 at 03:04:45PM +0530, Rajendra Nayak wrote: On Wednesday 28 September 2011 05:56 PM, Mark Brown wrote: On Wed, Sep 28, 2011 at 10:09:30AM +0200, Cousson, Benoit wrote: On 9/27/2011 8:59 PM, Mark Brown wrote: I'm not sure how this should work in a device tree world, I'd

Re: [RFC PATCH] tty/serial: atmel_serial: add device tree support

2011-10-04 Thread Grant Likely
On Tue, Oct 04, 2011 at 08:08:27AM -0500, Rob Herring wrote: Nicolas, On 10/04/2011 03:18 AM, Nicolas Ferre wrote: On 10/04/2011 03:58 AM, Rob Herring : On 10/03/2011 04:51 AM, Nicolas Ferre wrote: +Optional properties: +- atmel,use-dma-rx: use of PDC or DMA for receiving data +-

Re: [PATCH] ahci: add DT binding for Calxeda AHCI controller

2011-10-04 Thread Grant Likely
On Fri, Sep 02, 2011 at 10:10:15AM -0500, Rob Herring wrote: From: Rob Herring rob.herr...@calxeda.com Add devicetree match table to ahci platform driver for Calxeda Highbank AHCI controller. Signed-off-by: Rob Herring rob.herr...@calxeda.com Cc: Jeff Garzik jgar...@pobox.com Cc:

Re: [RFC PATCH] tty/serial: atmel_serial: add device tree support

2011-10-04 Thread Grant Likely
On Mon, Oct 03, 2011 at 08:58:48PM -0500, Rob Herring wrote: On 10/03/2011 04:51 AM, Nicolas Ferre wrote: static int __devinit atmel_serial_probe(struct platform_device *pdev) { struct atmel_uart_port *port; + struct device_node *np = pdev-dev.of_node; struct atmel_uart_data

Re: [PATCH v4 07/24] C6X: devicetree support

2011-10-04 Thread Arnd Bergmann
On Tuesday 04 October 2011 12:43:44 Mark Salter wrote: This is the basic devicetree support for C6X. Currently, four boards are supported. Each one uses a different SoC part. Two of the four supported SoCs are multicore. One with 3 cores and the other with 6 cores. There is no coherency

Re: [PATCHv3] dt: add helper to read 64-bit integers

2011-10-04 Thread Jamie Iles
On Wed, Sep 14, 2011 at 08:49:59PM +0100, Jamie Iles wrote: Add a helper similar to of_property_read_u32() that handles 64-bit integers. v2/v3: constify device node and property name parameters. Cc: Grant Likely grant.lik...@secretlab.ca Reviewed-by: Rob Herring rob.herr...@calxeda.com

Re: [PATCHv3] dt: add helper to read 64-bit integers

2011-10-04 Thread Grant Likely
On Wed, Sep 14, 2011 at 08:49:59PM +0100, Jamie Iles wrote: Add a helper similar to of_property_read_u32() that handles 64-bit integers. v2/v3: constify device node and property name parameters. Cc: Grant Likely grant.lik...@secretlab.ca Reviewed-by: Rob Herring rob.herr...@calxeda.com

Re: [PATCH 2/9] regulator: helper routine to extract regulator_init_data

2011-10-04 Thread Russell King - ARM Linux
On Tue, Sep 27, 2011 at 01:10:04PM +0100, Mark Brown wrote: On Tue, Sep 27, 2011 at 03:42:45PM +0530, Rajendra Nayak wrote: + init_data = devm_kzalloc(dev, sizeof(struct regulator_init_data), +GFP_KERNEL); + if (!init_data) +

Re: [PATCH 1/3] irq: support domains with non-zero hwirq base

2011-10-04 Thread Grant Likely
On Fri, Sep 30, 2011 at 02:27:58PM -0500, Rob Herring wrote: From: Rob Herring rob.herr...@calxeda.com Interrupt controllers can have non-zero starting value for h/w irq numbers. Adding support in irq_domain allows the domain hwirq numbering to match the interrupt controllers' numbering.

Re: [PATCH 2/3] ARM: gic: add irq_domain support

2011-10-04 Thread Grant Likely
On Fri, Sep 30, 2011 at 02:27:59PM -0500, Rob Herring wrote: From: Rob Herring rob.herr...@calxeda.com Convert the gic interrupt controller to use irq domains in preparation for device-tree binding and MULTI_IRQ. This allows for translation between GIC interrupt IDs and Linux irq numbers.

Re: [PATCH 3/3] ARM: gic: add OF based initialization

2011-10-04 Thread Grant Likely
On Fri, Sep 30, 2011 at 02:28:00PM -0500, Rob Herring wrote: From: Rob Herring rob.herr...@calxeda.com This adds ARM gic interrupt controller initialization using device tree data. The initialization function is intended to be called by of_irq_init function like this: const static

Re: [PATCH 2/9] regulator: helper routine to extract regulator_init_data

2011-10-04 Thread Grant Likely
On Wed, Oct 05, 2011 at 12:01:27AM +0100, Russell King - ARM Linux wrote: On Tue, Sep 27, 2011 at 01:10:04PM +0100, Mark Brown wrote: On Tue, Sep 27, 2011 at 03:42:45PM +0530, Rajendra Nayak wrote: + init_data = devm_kzalloc(dev, sizeof(struct regulator_init_data), +