Re: [PATCH v5 5/9] ARM: versatile: Map local timers using Device Tree when possible

2011-12-12 Thread Pawel Moll
Morning, On Sat, 2011-12-10 at 15:27 +, Sergei Shtylyov wrote: int __cpuinit local_timer_setup(struct clock_event_device *evt) { +#if defined(CONFIG_OF) + if (!twd_base) { + struct device_node *np = of_find_compatible_node(NULL, + NULL,

Re: [PATCH v5 5/9] ARM: versatile: Map local timers using Device Tree when possible

2011-12-12 Thread Sergei Shtylyov
Hello. On 12-12-2011 15:03, Pawel Moll wrote: int __cpuinit local_timer_setup(struct clock_event_device *evt) { +#if defined(CONFIG_OF) + if (!twd_base) { + struct device_node *np = of_find_compatible_node(NULL, + NULL, arm,smp-twd); + +

Re: [PATCH v5 5/9] ARM: versatile: Map local timers using Device Tree when possible

2011-12-12 Thread Pawel Moll
On Mon, 2011-12-12 at 11:18 +, Sergei Shtylyov wrote: I think if of_iomap() fails, it's because the system is out of memory, so -ENOMEM seems more proper error in this case. Although... it's not the only case when of_iomap() fails. I actually think that in this use case it's much

Re: [PATCH v5 5/9] ARM: versatile: Map local timers using Device Tree when possible

2011-12-12 Thread Russell King - ARM Linux
On Fri, Dec 09, 2011 at 07:03:48PM +, Pawel Moll wrote: If twd_base is not set, try to map the TWD registers from arm,smp-twd Device Tree node (compatible value as used in Highbank's DT). Please do it the other way around - allow DT to override twd_base if the DT node is present. The

Re: [PATCH v5 5/9] ARM: versatile: Map local timers using Device Tree when possible

2011-12-12 Thread Pawel Moll
On Mon, 2011-12-12 at 14:04 +, Russell King - ARM Linux wrote: On Fri, Dec 09, 2011 at 07:03:48PM +, Pawel Moll wrote: If twd_base is not set, try to map the TWD registers from arm,smp-twd Device Tree node (compatible value as used in Highbank's DT). Please do it the other way

Re: [PATCH] mfd: Add basic device tree binding for wm8994

2011-12-12 Thread Samuel Ortiz
Hi Mark, On Tue, Nov 22, 2011 at 06:59:28PM +, Mark Brown wrote: Add a placeholder device tree binding for the wm8994 driver. At present the binding is essentially null as none of the platform data is supported, and at least some of that will depend on the pending regulator bindings. I

[PATCH v3 0/3] Add device tree support for mc13892 regulator driver

2011-12-12 Thread Shawn Guo
Changes since v2: * Drop '[PATCH v2 2/4] regulator: pass device_node to of_get_regulator_init_data()' which has been picked up by Mark * Add a note on how driver matches regulator device and the node in binding document Changes since v1: * Drop '[PATCH 2/5] regulator: fix label names

[PATCH v3 1/3] mfd: mc13xxx: add device tree probe support

2011-12-12 Thread Shawn Guo
It adds device tree probe support for mc13xxx mfd driver. Signed-off-by: Shawn Guo shawn@linaro.org Cc: Samuel Ortiz sa...@linux.intel.com --- Documentation/devicetree/bindings/mfd/mc13xxx.txt | 53 ++ drivers/mfd/mc13xxx-core.c| 106 +++--

[PATCH v3 3/3] arm/imx: add mc13892 support into imx51-babbage.dts

2011-12-12 Thread Shawn Guo
It adds mc13892 support into imx51-babbage device tree source. Signed-off-by: Shawn Guo shawn@linaro.org Cc: Sascha Hauer s.ha...@pengutronix.de --- arch/arm/boot/dts/imx51-babbage.dts | 103 ++- 1 files changed, 101 insertions(+), 2 deletions(-) diff --git

[PATCH v3 2/3] regulator: mc13892: add device tree probe support

2011-12-12 Thread Shawn Guo
It adds device tree probe support for mc13892-regulator driver. Signed-off-by: Shawn Guo shawn@linaro.org Cc: Mark Brown broo...@opensource.wolfsonmicro.com Cc: Liam Girdwood l...@ti.com --- drivers/regulator/mc13892-regulator.c | 43 +++-

[PATCH 0/2] ARM: Exynos: Adapt to generic power domain

2011-12-12 Thread Thomas Abraham
The power domains available on Exynos4 are made controllable using the generic power domain infrastructure. The existing power domain code is not removed by this patchset. Support for both DT and non-DT Exynos platforms is added. The first patch adds device tree support for generic power domain.

[PATCH 2/2] ARM: Exynos: Hook up power domains to generic power domain infrastructure

2011-12-12 Thread Thomas Abraham
The generic power domain infrastructure is used to control the power domains available on Exynos4. For non-dt platforms, the power domains are statically instantiated. For dt platforms, the power domain nodes found in the device tree are instantiated. Cc: Kukjin Kim kgene@samsung.com Cc: Rob

Re: [PATCH v3] mfd: mc13xxx: add device tree probe support

2011-12-12 Thread Samuel Ortiz
Hi Shawn, On Tue, Dec 06, 2011 at 11:04:43PM +0800, Shawn Guo wrote: It adds device tree probe support for mc13xxx mfd driver. Thanks, I applied this one. Cheers, Samuel. -- Intel Open Source Technology Centre http://oss.intel.com/ ___

Re: [PATCH 4/6] tegra: Add tegra keyboard support

2011-12-12 Thread Stephen Warren
On 12/08/2011 02:56 PM, Simon Glass wrote: Hi Stephen, On Wed, Dec 7, 2011 at 2:02 PM, Stephen Warren swar...@nvidia.com wrote: On 12/02/2011 07:57 PM, Simon Glass wrote: Add support for internal matrix keyboard controller for Nvidia Tegra platforms. This driver uses the fdt decode

Re: [PATCH v2 3/4] regulator: mc13892: add device tree probe support

2011-12-12 Thread Samuel Ortiz
On Thu, Dec 01, 2011 at 05:21:07PM +0800, Shawn Guo wrote: It adds device tree probe support for mc13892-regulator driver. Signed-off-by: Shawn Guo shawn@linaro.org Cc: Mark Brown broo...@opensource.wolfsonmicro.com Cc: Liam Girdwood l...@ti.com Acked-by: Samuel Ortiz

Re: [PATCH 4/6] tegra: Add tegra keyboard support

2011-12-12 Thread Simon Glass
Hi Stephen, On Mon, Dec 12, 2011 at 10:00 AM, Stephen Warren swar...@nvidia.com wrote: On 12/08/2011 02:56 PM, Simon Glass wrote: Hi Stephen, On Wed, Dec 7, 2011 at 2:02 PM, Stephen Warren swar...@nvidia.com wrote: On 12/02/2011 07:57 PM, Simon Glass wrote: Add support for internal matrix

Re: [PATCH v2 09/17] tegra: usb: fdt: Add additional device tree definitions for USB ports

2011-12-12 Thread Stephen Warren
On 12/08/2011 02:10 PM, Simon Glass wrote: Hi Stephen, On Wed, Dec 7, 2011 at 3:36 PM, Stephen Warren swar...@nvidia.com wrote: On 12/06/2011 02:09 PM, Simon Glass wrote: On Tue, Dec 6, 2011 at 12:28 PM, Stephen Warren swar...@nvidia.com wrote: On 12/05/2011 05:55 PM, Simon Glass wrote: On

Re: [PATCH 10/14] tegra: usb: Add support for USB peripheral

2011-12-12 Thread Stephen Warren
On 12/08/2011 02:24 PM, Simon Glass wrote: On Wed, Dec 7, 2011 at 3:46 PM, Stephen Warren swar...@nvidia.com wrote: On 12/06/2011 02:23 PM, Simon Glass wrote: ... I think the best implementation would be to enumerate everything solely based on compatible flags, and allowing usb start to accept

Re: [PATCH 4/6] tegra: Add tegra keyboard support

2011-12-12 Thread Stephen Warren
On 12/12/2011 11:10 AM, Simon Glass wrote: On Mon, Dec 12, 2011 at 10:00 AM, Stephen Warren swar...@nvidia.com wrote: On 12/08/2011 02:56 PM, Simon Glass wrote: ... I'd like to ask for comments in linux-input in case they have any other ideas, e.g. whether a set of separately documented

Re: [PATCH 10/14] tegra: usb: Add support for USB peripheral

2011-12-12 Thread Simon Glass
Hi Stephen, On Mon, Dec 12, 2011 at 10:18 AM, Stephen Warren swar...@nvidia.com wrote: On 12/08/2011 02:24 PM, Simon Glass wrote: On Wed, Dec 7, 2011 at 3:46 PM, Stephen Warren swar...@nvidia.com wrote: On 12/06/2011 02:23 PM, Simon Glass wrote: ... I think the best implementation would be

Re: [PATCH v2 09/17] tegra: usb: fdt: Add additional device tree definitions for USB ports

2011-12-12 Thread Simon Glass
Hi Stephen, On Mon, Dec 12, 2011 at 10:13 AM, Stephen Warren swar...@nvidia.com wrote: On 12/08/2011 02:10 PM, Simon Glass wrote: Hi Stephen, On Wed, Dec 7, 2011 at 3:36 PM, Stephen Warren swar...@nvidia.com wrote: On 12/06/2011 02:09 PM, Simon Glass wrote: On Tue, Dec 6, 2011 at 12:28 PM,

Keyboard device tree bindings, and modifier mapping representation

2011-12-12 Thread Stephen Warren
Simon Glass is attempting to define a device tree binding for the Tegra KBC controller, for use in U-Boot. I raised some issues re: how to represent modifier mappings. We'd like the ask for any insight from the Linux input people regarding this. Tegra's KBC is a matrix keyboard controller. The

Re: [PATCH v2 2/6] ASoC: Allow the DAPM routes to be stored in device tree

2011-12-12 Thread Stephen Warren
On 12/10/2011 05:49 AM, Mark Brown wrote: On Fri, Dec 09, 2011 at 01:52:00PM -0800, Stephen Warren wrote: I'd originally made this property specific to the Tegra+WM8903 machine driver, and you'd asked me to make it generic. Is there room to use the binding above for the Tegra+WM8903 machine

RE: [PATCH v2 2/6] ASoC: Allow the DAPM routes to be stored in device tree

2011-12-12 Thread Stephen Warren
Mark Brown wrote at Saturday, December 10, 2011 5:49 AM: On Fri, Dec 09, 2011 at 01:52:00PM -0800, Stephen Warren wrote: ... This would be a fair bit of work to implement, but what are your thoughts on the binding example below? It's very strongly based on ASoC, but since that's so strongly

Re: [PATCH 4/6] tegra: Add tegra keyboard support

2011-12-12 Thread Simon Glass
Hi Stephen, On Mon, Dec 12, 2011 at 10:31 AM, Stephen Warren swar...@nvidia.com wrote: On 12/12/2011 11:10 AM, Simon Glass wrote: On Mon, Dec 12, 2011 at 10:00 AM, Stephen Warren swar...@nvidia.com wrote: On 12/08/2011 02:56 PM, Simon Glass wrote: ... I'd like to ask for comments in

[PATCH v2 REPOST] dtc: Add support for named integer constants

2011-12-12 Thread Stephen Warren
You may define constants as follows: /define/ TWO 2; /define/ FOUR 4; /define/ OTHER FOUR; And properties may use these values as follows: foo = 1 TWO 3 FOUR 5; Signed-off-by: Stephen Warren swar...@nvidia.com --- I posted this back in early September. I'd like to ask again that this feature

Re: [PATCH v2 REPOST] dtc: Add support for named integer constants

2011-12-12 Thread Simon Glass
Hi Stephen, On Mon, Dec 12, 2011 at 12:04 PM, Stephen Warren swar...@nvidia.com wrote: You may define constants as follows: /define/ TWO 2; /define/ FOUR 4; /define/ OTHER FOUR; And properties may use these values as follows: foo = 1 TWO 3 FOUR 5; Signed-off-by: Stephen Warren

Initial DT clock bindings

2011-12-12 Thread Grant Likely
Hi everyone, Here's my second posting of initial device tree bindings for clocks. I'm a lot happier with how this is looking now, and Versatile is pretty much entirely converted. In fact, the realview, integrator and vexpress platforms are pretty close now too. Just for fun I went and

[RFC v2 1/9] arm/versatile*: merge all versatile struct clk definitions

2011-12-12 Thread Grant Likely
There is no little value to each versatile type platform having it's own struct clk definition. Merge all of them into plat-versatile to eliminate duplication. This patch probably conflicts with the common struct clk work, but the timeline for that larger work is still uncertain, and this patch

[RFC v2 3/9] of: Add of_property_match_string() to find index into a string list

2011-12-12 Thread Grant Likely
Add a helper function for finding the index of a string in a string list property. This helper is useful for bindings that use a separate *-name property for attaching names to tuples in another property such as 'reg' or 'gpios'. Signed-off-by: Grant Likely grant.lik...@secretlab.ca ---

[RFC v2 6/9] arm/dt: add devicetree support to sp804 timer support

2011-12-12 Thread Grant Likely
This patch adds support to the sp804 code for retrieving timer configuration from the device tree. sp804 channels can be used as a clock event device or a clock source. Signed-off-by: Grant Likely grant.lik...@secretlab.ca Cc: Russell King li...@arm.linux.org.uk --- arch/arm/common/timer-sp.c

[RFC v2 4/9] of: add clock providers

2011-12-12 Thread Grant Likely
Based on work by Ben Herrenschmidt and Jeremy Kerr, this patch adds an of_clk_get function to allow platforms to retrieve clock data from the device tree. Platform register a provider through of_clk_add_provider, which will be called when a device references the provider's OF node for a clock

[RFC v2 2/9] arm/versatile*: Consolidate clk_ops and setvco implementations.

2011-12-12 Thread Grant Likely
All of the icst setvco routines for ARM development boards are pretty close to identical. Consolidate them all to one implementation. Note: This might be broken on Integrator. To simplify the common function, it always does a read/modify/write on the register. Integrator only does a simple

[RFC v2 7/9] arm/dt: Common plat-versatile support for icst and sp804 based system clocks

2011-12-12 Thread Grant Likely
Signed-off-by: grant.lik...@secretlab.ca Cc: Russell King li...@arm.linux.org.uk --- arch/arm/plat-versatile/clock.c | 130 ++ arch/arm/plat-versatile/include/plat/clock.h |3 + 2 files changed, 133 insertions(+), 0 deletions(-) diff --git

[RFC v2 9/9] arm/highbank: Use clock binding common support code

2011-12-12 Thread Grant Likely
This patch makes the Calxeda Highbank platform use the common DT clock binding support code for setting up timers and fixed clocks. Signed-off-by: Grant Likely grant.lik...@secretlab.ca Cc: Rob Herring rob.herr...@calxeda.com --- arch/arm/Kconfig |1 +

[RFC v2 8/9] dt/arm: versatile add clock parsing

2011-12-12 Thread Grant Likely
Signed-off-by: Grant Likely grant.lik...@secretlab.ca Cc: Russell King li...@arm.linux.org.uk Cc: Mike Turquette mturque...@ti.com --- arch/arm/boot/dts/versatile-ab.dts | 79 arch/arm/mach-versatile/core.c | 39 +--

Re: Initial DT clock bindings

2011-12-12 Thread Rob Herring
On 12/12/2011 04:00 PM, Grant Likely wrote: Hi everyone, Here's my second posting of initial device tree bindings for clocks. I'm a lot happier with how this is looking now, and Versatile is pretty much entirely converted. In fact, the realview, integrator and vexpress platforms are

Re: [RFC v2 4/9] of: add clock providers

2011-12-12 Thread Jamie Iles
Hi Grant, I'm still going through these and trying to digest them but a couple of quick questions/comments. Jamie On Mon, Dec 12, 2011 at 03:02:04PM -0700, Grant Likely wrote: diff --git a/Documentation/devicetree/bindings/clock/clock-bindings.txt

Re: [RFC v2 6/9] arm/dt: add devicetree support to sp804 timer support

2011-12-12 Thread Rob Herring
Grant, On 12/12/2011 04:02 PM, Grant Likely wrote: This patch adds support to the sp804 code for retrieving timer configuration from the device tree. sp804 channels can be used as a clock event device or a clock source. Signed-off-by: Grant Likely grant.lik...@secretlab.ca Cc: Russell

Re: [RFC v2 6/9] arm/dt: add devicetree support to sp804 timer support

2011-12-12 Thread Grant Likely
On Dec 12, 2011 4:54 PM, Rob Herring robherri...@gmail.com wrote: Grant, On 12/12/2011 04:02 PM, Grant Likely wrote: This patch adds support to the sp804 code for retrieving timer configuration from the device tree. sp804 channels can be used as a clock event device or a clock source.

Re: [PATCH v2 2/6] ASoC: Allow the DAPM routes to be stored in device tree

2011-12-12 Thread Mark Brown
On Mon, Dec 12, 2011 at 12:08:24PM -0700, Stephen Warren wrote: So, does the following sound reasonable: Add: snd_soc_of_parse_card_name(struct snd_soc_card *card, const char *prop); .. and have the machine driver call that whenever it decides, rather than having

Re: [PATCH v2 2/6] ASoC: Allow the DAPM routes to be stored in device tree

2011-12-12 Thread Mark Brown
On Mon, Dec 12, 2011 at 11:34:13AM -0800, Stephen Warren wrote: Mark Brown wrote at Saturday, December 10, 2011 5:49 AM: It's starting to get an idiomatic way of representing the external nodes, HDA is probably a good source of inspiration :) We do need to have a think about the jacks,