Re: [PATCH 1/2] staging: wfx: fix use of uninitialized pointer

2020-10-19 Thread Nathan Chancellor
On Mon, Oct 19, 2020 at 06:06:03PM +0200, Jerome Pouiller wrote: > From: Jérôme Pouiller > > With -Wuninitialized, the compiler complains: > > drivers/staging/wfx/data_tx.c:34:19: warning: variable 'band' is > uninitialized when used here [-Wuninitialized] > if (rate->idx >=

Re: [RFC] treewide: cleanup unreachable breaks

2020-10-19 Thread Jason Gunthorpe
On Mon, Oct 19, 2020 at 12:42:15PM -0700, Nick Desaulniers wrote: > On Sat, Oct 17, 2020 at 10:43 PM Greg KH wrote: > > > > On Sat, Oct 17, 2020 at 09:09:28AM -0700, t...@redhat.com wrote: > > > From: Tom Rix > > > > > > This is a upcoming change to clean up a new warning treewide. > > > I am

Re: [PATCH] staging: wfx: make a const array static, makes object smaller

2020-10-19 Thread Christophe JAILLET
Le 17/10/2020 à 02:11, Joe Perches a écrit : On Fri, 2020-10-16 at 23:33 +0100, Colin King wrote: From: Colin Ian King Don't populate const array filter_ies on the stack but instead make it static. Makes the object code smaller by 261 bytes. Before: text data bss dec

[PATCH v3] staging: comedi: tests: Simplify conditional evaluation

2020-10-19 Thread Deepak R Varma
Boolean comparison of the condition inside unittest function is unnecessary and can be simplified by directly using the condition outcome for evaluation. Issue reported by : scripts/coccinelle/misc/boolinit.cocci Signed-off-by: Deepak R Varma --- Changes since v2: - Update patch subject to

Re: [PATCH v2] staging: comedi: Simplify conditional evaluation

2020-10-19 Thread Ian Abbott
On 19/10/2020 15:45, Deepak R Varma wrote: Boolean comparison of the condition inside unittest function is unnecessary and can be simplified by directly using the condition outcome for evaluation. Issue reported by : scripts/coccinelle/misc/boolinit.cocci Signed-off-by: Deepak R Varma ---

[PATCH] vme: remove unneeded break

2020-10-19 Thread trix
From: Tom Rix A break is not needed if it is preceded by a return or goto Signed-off-by: Tom Rix --- drivers/vme/bridges/vme_tsi148.c | 7 --- drivers/vme/vme.c| 9 - 2 files changed, 16 deletions(-) diff --git a/drivers/vme/bridges/vme_tsi148.c

[PATCH 2/2] staging: wfx: fix test on return value of gpiod_get_value()

2020-10-19 Thread Jerome Pouiller
From: Jérôme Pouiller The commit 8522d62e6bca ("staging: wfx: gpiod_get_value() can return an error") has changed the way the driver test the value returned by gpiod_get_value(). The new code was wrong. Fixes: 8522d62e6bca ("staging: wfx: gpiod_get_value() can return an error") Signed-off-by:

[PATCH 1/2] staging: wfx: fix use of uninitialized pointer

2020-10-19 Thread Jerome Pouiller
From: Jérôme Pouiller With -Wuninitialized, the compiler complains: drivers/staging/wfx/data_tx.c:34:19: warning: variable 'band' is uninitialized when used here [-Wuninitialized] if (rate->idx >= band->n_bitrates) { ^~~~ Reported-by: kernel test robot

[PATCH] Fixed issues with alignment to open parenthesis.

2020-10-19 Thread Tabot Kevin
This patch fixes the following: - Made sure alignment matched open parenthesis. Signed-off-by: Tabot Kevin --- drivers/staging/greybus/audio_codec.c | 9 - 1 file changed, 4 insertions(+), 5 deletions(-) diff --git a/drivers/staging/greybus/audio_codec.c

[PATCH v2] staging: comedi: Simplify conditional evaluation

2020-10-19 Thread Deepak R Varma
Boolean comparison of the condition inside unittest function is unnecessary and can be simplified by directly using the condition outcome for evaluation. Issue reported by : scripts/coccinelle/misc/boolinit.cocci Signed-off-by: Deepak R Varma --- Changes since v1: - Corrected wrongly

Re: [Outreachy kernel] Re: [PATCH 2/2] staging: comedi: combine split lines for improved readability

2020-10-19 Thread Ian Abbott
On 19/10/2020 12:49, Deepak R Varma wrote: On Mon, Oct 19, 2020 at 12:34:15PM +0100, Ian Abbott wrote: On 19/10/2020 11:57, Deepak R Varma wrote: On Mon, Oct 19, 2020 at 12:41:14PM +0200, Julia Lawall wrote: On Mon, 19 Oct 2020, Ian Abbott wrote: On 18/10/2020 20:49, Deepak R Varma wrote:

Re: [Outreachy kernel] Re: [PATCH 2/2] staging: comedi: combine split lines for improved readability

2020-10-19 Thread Deepak R Varma
On Mon, Oct 19, 2020 at 12:34:15PM +0100, Ian Abbott wrote: > On 19/10/2020 11:57, Deepak R Varma wrote: > > On Mon, Oct 19, 2020 at 12:41:14PM +0200, Julia Lawall wrote: > > > > > > > > > On Mon, 19 Oct 2020, Ian Abbott wrote: > > > > > > > On 18/10/2020 20:49, Deepak R Varma wrote: > > > > >

Re: [Outreachy kernel] Re: [PATCH 2/2] staging: comedi: combine split lines for improved readability

2020-10-19 Thread Ian Abbott
On 19/10/2020 11:57, Deepak R Varma wrote: On Mon, Oct 19, 2020 at 12:41:14PM +0200, Julia Lawall wrote: On Mon, 19 Oct 2020, Ian Abbott wrote: On 18/10/2020 20:49, Deepak R Varma wrote: Instructions split on multiple lines can be combined on a single line for improved readability of the

Re: [Outreachy kernel] Re: [PATCH 2/2] staging: comedi: combine split lines for improved readability

2020-10-19 Thread Deepak R Varma
On Mon, Oct 19, 2020 at 12:41:14PM +0200, Julia Lawall wrote: > > > On Mon, 19 Oct 2020, Ian Abbott wrote: > > > On 18/10/2020 20:49, Deepak R Varma wrote: > > > Instructions split on multiple lines can be combined on a single line > > > for improved readability of the code. > > > > > >

Re: [PATCH 1/2] staging: comedi: Simplify conditional evaluation

2020-10-19 Thread Deepak R Varma
On Mon, Oct 19, 2020 at 11:17:38AM +0100, Ian Abbott wrote: > On 18/10/2020 20:48, Deepak R Varma wrote: > > Boolean comparison of the condition inside unittest function is > > unnecessary and can be simplified by directly using the condition > > outcome for evaluation. Issue reported by : > >

Re: [Outreachy kernel] Re: [PATCH 2/2] staging: comedi: combine split lines for improved readability

2020-10-19 Thread Julia Lawall
On Mon, 19 Oct 2020, Ian Abbott wrote: > On 18/10/2020 20:49, Deepak R Varma wrote: > > Instructions split on multiple lines can be combined on a single line > > for improved readability of the code. > > > > Signed-off-by: Deepak R Varma > > --- > >

Re: [PATCH 2/2] staging: comedi: combine split lines for improved readability

2020-10-19 Thread Ian Abbott
On 18/10/2020 20:49, Deepak R Varma wrote: Instructions split on multiple lines can be combined on a single line for improved readability of the code. Signed-off-by: Deepak R Varma --- .../staging/comedi/drivers/tests/ni_routes_test.c| 12 1 file changed, 4 insertions(+), 8

Re: [PATCH 1/2] staging: comedi: Simplify conditional evaluation

2020-10-19 Thread Ian Abbott
On 18/10/2020 20:48, Deepak R Varma wrote: Boolean comparison of the condition inside unittest function is unnecessary and can be simplified by directly using the condition outcome for evaluation. Issue reported by : scripts/coccinelle/misc/boolinit.cocci Signed-off-by: Deepak R Varma ---

Re: [PATCH] staging: wfx: make a const array static, makes object smaller

2020-10-19 Thread Jérôme Pouiller
On Monday 19 October 2020 10:09:19 CEST David Laight wrote: > From: Joe Perches > > Sent: 17 October 2020 01:12 > > > > On Fri, 2020-10-16 at 23:33 +0100, Colin King wrote: > > > From: Colin Ian King > > > > > > Don't populate const array filter_ies on the stack but instead > > > make it static.

Re: [PATCH v2 net] staging: octeon: Drop on uncorrectable alignment or FCS error

2020-10-19 Thread Alexander Sverdlin
Hello Andrew, thank you for your review! On 17/10/2020 23:02, Andrew Lunn wrote: >> diff --git a/drivers/staging/octeon/ethernet-rx.c >> b/drivers/staging/octeon/ethernet-rx.c >> index 2c16230..9ebd665 100644 >> --- a/drivers/staging/octeon/ethernet-rx.c >> +++

RE: [PATCH] staging: wfx: make a const array static, makes object smaller

2020-10-19 Thread David Laight
From: Joe Perches > Sent: 17 October 2020 01:12 > > On Fri, 2020-10-16 at 23:33 +0100, Colin King wrote: > > From: Colin Ian King > > > > Don't populate const array filter_ies on the stack but instead > > make it static. Makes the object code smaller by 261 bytes. > > > > Before: > >text

Re: [PATCH] arch: um: convert tasklets to use new tasklet_setup() API

2020-10-19 Thread Anton Ivanov
On 17/08/2020 10:15, Allen Pais wrote: From: Allen Pais In preparation for unconditionally passing the struct tasklet_struct pointer to all tasklet callbacks, switch to using the new tasklet_setup() and from_tasklet() to pass the tasklet pointer explicitly. Signed-off-by: Romain Perier