Re: [fricas-devel] should =$List check for cyclic list

2017-03-05 Thread oldk1331
> I think it make more sense to have List essentially as > now, saying that it may loop on cycles and does not > check and another domain or package offering operations > that correctly handle cycles. Package may be more > appropriate because once list is verfied to be acyclic > normal List

[fricas-devel] overload elt to treat space as multiplication (like MMA)

2017-03-05 Thread oldk1331
I find that it's possible to define "elt" for varies types as multiplication, to achieve similar effect like MMA. I think that's very interesting, and Spad is really flexible. -- You received this message because you are subscribed to the Google Groups "FriCAS - computer algebra system" group.

[fricas-devel] [PATCH] ratDenom modifies its argument

2017-03-05 Thread oldk1331
ratDenom uses algkernels, which uses select!, modifies its argument. I would also suggest to rename algkernels to algkernels!. sed -i 's/algkernels/algkernels!/' expr.spad manip.spad --- a/src/algebra/manip.spad +++ b/src/algebra/manip.spad @@ -252,7 +252,7 @@ dummy := kernel(new()$SY)$K

[fricas-devel] [PATCH] output tweak for SExpression and Multiset

2017-03-05 Thread oldk1331
In output of "multiset [1,1]", there will be a space on both side of the colon. And for SExpression, '1 pretend SEX' and '"1" pretend SEX' will be distinguishable from their output. --- a/src/algebra/mset.spad +++ b/src/algebra/mset.spad @@ -90,7 +90,7 @@ coerce(ms : %) : OutputForm ==

Re: [fricas-devel] [PATCH] tweak the output of AGGLST

2017-03-05 Thread oldk1331
> I don't know what the issues are in this particular case but, > as a general principle, I don't like adding spaces in command > line output if there is any danger that the extra width will trigger > line wrapping. I think if adding spaces pleases people's eyes, then we should do it. There are

Re: [fricas-devel] FriCAS SPAD Style

2017-03-05 Thread oldk1331
I would like to have a formal code style guide. I have one style to add to it: Function application parenthesis - For one argument function, "f(a)" vs. "f a", which is better? -- You received this message because you are subscribed to the Google Groups "FriCAS - computer algebra system"

[fricas-devel] FriCAS SPAD Style

2017-03-05 Thread Martin Baker
On 05/03/17 18:45, Waldek Hebisch wrote: I worked with various code and IME it is much easier to work with generous whitspace. When lines are getting to long just break them up. One should try to make code simpler and smaller, but squeezing more code in small space is counterproductive. It

Re: [fricas-devel] [PATCH] tweak the output of AGGLST

2017-03-05 Thread Waldek Hebisch
Martin Baker wrote: > > On 05/03/17 13:09, oldk1331 wrote: > > The output of "[1,2]" is "[1,2]", I think adding a space > > after a comma is better. And multiline list already does > > this: [1,2,10^100]. > > I don't know what the issues are in this particular case but, as a > general

Re: [fricas-devel] [PATCH] tweak the output of AGGLST

2017-03-05 Thread Martin Baker
On 05/03/17 13:09, oldk1331 wrote: The output of "[1,2]" is "[1,2]", I think adding a space after a comma is better. And multiline list already does this: [1,2,10^100]. I don't know what the issues are in this particular case but, as a general principle, I don't like adding spaces in

[fricas-devel] Re: [PATCH] tweak the output of AGGLST

2017-03-05 Thread oldk1331
> Also, I want to add space after a numer in product. Also, I want to add a space after a number in product. -- You received this message because you are subscribed to the Google Groups "FriCAS - computer algebra system" group. To unsubscribe from this group and stop receiving emails from it,

[fricas-devel] Re: [PATCH] tweak the output of AGGLST

2017-03-05 Thread oldk1331
Also, I want to add space after a numer in product. So 2*sin(3*x) will be "2 sin(3 x)" instead of "2sin(3x)". Most other CASs have this behavior (maxima, mma; sympy uses a dot instead of a space.) Opinions? --- a/src/interp/i-output.boot +++ b/src/interp/i-output.boot @@ -501,13 +501,10 @@

[fricas-devel] [PATCH] tweak the output of AGGLST

2017-03-05 Thread oldk1331
The output of "[1,2]" is "[1,2]", I think adding a space after a comma is better. And multiline list already does this: [1,2,10^100]. --- a/src/interp/i-output.boot +++ b/src/interp/i-output.boot @@ -639,14 +639,14 @@ --% Aggregates aggWidth u == - rest u is [a,:l] => WIDTH a + +/[1+WIDTH x