Re: [PATCH 4/7] Support -fdebug-cpp option

2011-08-21 Thread Alexandre Oliva
On Jul 16, 2011, Dodji Seketeli do...@redhat.com wrote: This patch adds -fdebug-cpp option. When used with -E this dumps the relevant macro map before every single token. This clutters the output a lot but has proved to be invaluable in tracking some bugs during the development of the virtual

Re: [4.7][google]Support for getting CPU type and feature information at run-time. (issue4893046)

2011-08-21 Thread Richard Guenther
On Sat, Aug 20, 2011 at 11:02 PM, Richard Henderson r...@redhat.com wrote: On 08/19/2011 02:04 AM, Richard Guenther wrote: So make sure that __cpu_indicator initially has a conservative correct value?  I'd still prefer the constructor-in-libgcc option - if only because then the compiler-side

Re: [PATCH, testsuite, i386] BMI2 support for GCC

2011-08-21 Thread Uros Bizjak
On Sat, Aug 20, 2011 at 11:52 PM, Richard Henderson r...@redhat.com wrote: On 08/20/2011 02:16 PM, Uros Bizjak wrote: +(define_insn bmi2_umulmodedwi3_1 +  [(set (match_operand:DWI 0 register_operand =r) +     (mult:DWI +       (zero_extend:DWI +         (match_operand:DWIH 1

Re: [wwwdocs] Buildstat update for 4.3

2011-08-21 Thread Gerald Pfeifer
On Sat, 20 Aug 2011, Tom G. Christensen wrote: Latest results for 4.3.x. All yours? :-) Thanks, applied. Gerald

Re: [PATCH 4/7] Support -fdebug-cpp option

2011-08-21 Thread Jakub Jelinek
On Sun, Aug 21, 2011 at 04:51:54AM -0300, Alexandre Oliva wrote: On Jul 16, 2011, Dodji Seketeli do...@redhat.com wrote: This patch adds -fdebug-cpp option. When used with -E this dumps the relevant macro map before every single token. This clutters the output a lot but has proved to be

Re: [Patch, Fortran, OOP] PR 49638: [OOP] length parameter is ignored when overriding type bound character functions with constant length.

2011-08-21 Thread Thomas Koenig
If we really wanted to do this The Right Way, there would be seven cases to be considered, best expressed as three flags. I'll call them CAN_BE_LESS, CAN_BE_EQUAL and CAN_BE_MORE. Comparing a vs. a+1 would yield CAN_BE_LESS for integers and CAN_BE_LESS | CAN_BE_EQUAL for floats. Comparing 3

Re: [PATCH, testsuite, i386] BMI2 support for GCC

2011-08-21 Thread Jakub Jelinek
On Sun, Aug 21, 2011 at 12:55:41AM +0200, Uros Bizjak wrote: (define_attr enabled - (cond [(eq_attr isa noavx) (symbol_ref !TARGET_AVX) + (cond [(eq_attr isa bmi2) (symbol_ref TARGET_BMI) Shouldn't this be TARGET_BMI2 ? + (eq_attr isa noavx) (symbol_ref !TARGET_AVX) (eq_attr

Re: [PATCH, testsuite, i386] BMI2 support for GCC

2011-08-21 Thread Uros Bizjak
On Sat, Aug 20, 2011 at 11:31 PM, H.J. Lu hjl.to...@gmail.com wrote: The patch is currently in RFC/RFT state, since I have no way to properly test it. The patch bootstraps OK and regression test is clean We are using HSW emulator (SDE):

Re: [patch] PR25508 - document MULTILIB_OSDIRNAMES

2011-08-21 Thread Joseph S. Myers
On Sun, 21 Aug 2011, Matthias Klose wrote: On 08/21/2011 12:21 AM, Joseph S. Myers wrote: On Sat, 20 Aug 2011, Matthias Klose wrote: +@findex MULTILIB_OSDIRNAMES +@item MULTILIB_OSDIRNAMES +If @code{MULTILIB_OPTIONS} is used, this variable specifies the list +of OS subdirectory

Re: [patch] support for multiarch systems

2011-08-21 Thread Joseph S. Myers
On Sun, 21 Aug 2011, Matthias Klose wrote: powerpc-linux-gnuspe As noted, that's ambiguous; --enable-e500-double determines whether it's e500v1 or e500v2, and since those have slightly different symbols exported from libc I think they should be considered different here. For MIPS, the

Re: [patch, fortran] PR 47659 - extend conversion warnings to assignments

2011-08-21 Thread Thomas Koenig
Hello everybody, now that I have found a little time, here is an updated version of the patch, which incorporates Tobias' suggestions. Regression-tested. OK for trunk? Thomas 2011-08-21 Thomas Koenig tkoe...@gcc.gnu.org PR fortran/47659 * expr.c (gfc_check_assign):

[PATCH v3, i386] BMI2 support for GCC, mulx, rorx, shiftx part

2011-08-21 Thread Uros Bizjak
Hello! This is the third version of BMI2 support that includes generation of mulx, rorx, shiftx part. This patch includes all comments on previous version, splits all insn post-reload, uses enable attribute and avoids new register modifiers. As a compromise (see previous posts), the mulx insn is

[patch, fortran, committed] Fix PR 50130

2011-08-21 Thread Thomas Koenig
Hello world, I committed the attached patch as obvious after regression-testing. Revision is 177940. Will commit to 4.6 in a few days. Thomas 2011-08-21 Thomas Koenig tkoe...@gcc.gnu.org PR fortran/50130 * resolve.c (resolve_array_ref): Don't calculate upper bound

Re: [wwwdocs] Buildstat update for 4.4

2011-08-21 Thread Gerald Pfeifer
On Sat, 20 Aug 2011, Tom G. Christensen wrote: Latest results for 4.4.x. Thanks, this is life now. Gerald

Re: [patch, fortran] PR 47659 - extend conversion warnings to assignments

2011-08-21 Thread Tobias Burnus
Thomas Koenig wrote: now that I have found a little time, here is an updated version of the patch, which incorporates Tobias' suggestions. Regression-tested. OK for trunk? OK. Thanks for the patch! Tobias 2011-08-21 Thomas Koenig tkoe...@gcc.gnu.org PR fortran/47659 *

Re: [patch, fortran] PR 47659 - extend conversion warnings to assignments

2011-08-21 Thread Thomas Koenig
Hello Tobias, OK. Thanks for the patch! Sende fortran/ChangeLog Sende fortran/expr.c Sende testsuite/ChangeLog Sende testsuite/gfortran.dg/warn_conversion_2.f90 Hinzufügen testsuite/gfortran.dg/warn_conversion_3.f90 Übertrage Daten . Revision

Re: [wwwdocs] Buildstat update for 4.5

2011-08-21 Thread Gerald Pfeifer
On Sat, 20 Aug 2011, Tom G. Christensen wrote: Latest results for 4.5.x Applied, thanks! Gerald

Re: [Ada] Add a link between body and spec scopes in ALFA section of ALI file

2011-08-21 Thread Gerald Pfeifer
As agreed with Arnaud I am fixing up some ChangeLog entries of this month's commit. Applied. Gerald Index: ChangeLog === --- ChangeLog (revision 177943) +++ ChangeLog (working copy) @@ -3307,15 +3307,15 @@ 2011-08-03

Re: [build] Move gthr to toplevel libgcc

2011-08-21 Thread Nathan Sidwell
On 08/08/11 08:47, Rainer Orth wrote: This patch moves gthr*.h and related code to toplevel libgcc. Unlike the other outstanding patches (libgcc1, libgcc2, crtstuff, shlib), it is pretty independent from the rest, so I'm posting it first. It was developed last, so there may be conflicts

Re: [wwwdocs] Buildstat update for 4.6

2011-08-21 Thread Gerald Pfeifer
On Sat, 20 Aug 2011, Tom G. Christensen wrote: Latest results for 4.6.x Thanks, Tom! Gerald

Re: [RFC] Cleanup DW_CFA_GNU_args_size handling

2011-08-21 Thread Eric Botcazou
I'm afraid this patch casues i386 bootstraps to fail: Comparing stages 2 and 3 warning: gcc/cc1-checksum.o differs warning: gcc/cc1plus-checksum.o differs warning: gcc/cc1obj-checksum.o differs Bootstrap comparison failure! libiberty/pic/cplus-dem.o differs

Re: [PATCH] PR middle-end/38509: add -Wfree-nonheap-object warning option

2011-08-21 Thread Mark Heffernan
Ping? Mark On Fri, Aug 12, 2011 at 9:41 AM, Mark Heffernan meh...@google.com wrote: This patch adds an option for enabling/disabling the warning for attempting to free nonheap objects (PR/38509).  The warning is imprecise and can issue false positives. Bootstrapped on x86-64.  Ok for trunk?

Re: PING: PATCH: PR target/46770: Use .init_array/.fini_array sections

2011-08-21 Thread David Edelsohn
This patch broke bootstrap on AIX. It emits a .section op in assembly but .section is an ELF syntax op not AIX XCOFF. FE..initialize_critical: .section.init_array varasm.c should not be generating ELF ops for non-ELF targets. config.log shows: gcc_cv_initfini_array=yes

Re: PING: PATCH: PR target/46770: Use .init_array/.fini_array sections

2011-08-21 Thread H.J. Lu
On Sun, Aug 21, 2011 at 4:19 PM, David Edelsohn dje@gmail.com wrote: This patch broke bootstrap on AIX.  It emits a .section op in assembly but .section is an ELF syntax op not AIX XCOFF. FE..initialize_critical:        .section        .init_array varasm.c should not be generating ELF

Re: PING: PATCH: PR target/46770: Use .init_array/.fini_array sections

2011-08-21 Thread David Edelsohn
On Sun, Aug 21, 2011 at 8:09 PM, H.J. Lu hjl.to...@gmail.com wrote: I didn't know .init_array section was enabled for AIX.  Does this patch work for you? Sorry about the breakage. I am not exactly sure why .init_array sections are enabled for AIX. The configure test succeeds. Is the problem

Re: PING: PATCH: PR target/46770: Use .init_array/.fini_array sections

2011-08-21 Thread Jakub Jelinek
On Sun, Aug 21, 2011 at 05:09:59PM -0700, H.J. Lu wrote: I didn't know .init_array section was enabled for AIX. Does this patch work for you? Some ELF targets (e.g. arm*-linux*) don't use elfos.h. IMHO you should instead add #ifndef __ELF__ #error NonELF #endif to gcc_AC_INITFINI_ARRAY test.