Re: [PATCH 1/2] gcc symbol database

2012-06-05 Thread Yunfeng ZHANG
To Dodji Seketeli: Thanks, I will republish my libcpp patch later. 2012/6/4 Dodji Seketeli do...@redhat.com: Hello YunFeng, Thank you for taking the time to work on this.  I cannot accept or deny your patches, but I thought I could maybe comment on some parts of them. First, IMHO, some of

Re: libgo patch committed: Include TLS size in stack size

2012-06-05 Thread Jakub Jelinek
On Mon, Jun 04, 2012 at 11:19:46PM -0700, Ian Lance Taylor wrote: This patch to libgo includes the TLS size in the requested stack size of a new thread, if possible. This relies on the glibc-specific (and undocumented) _dl_get_tls_static_info call. This is particularly necessary when using

Re: [line-map] simple oneliner that speeds up track-macro-expansion

2012-06-05 Thread Dodji Seketeli
Dimitrios Apostolou ji...@gmx.net writes: Hi Dodji, On Mon, 4 Jun 2012, Dodji Seketeli wrote: Hello Dimitrios, I cannot approve or deny your patch, but I have one question. Who should I CC then? Do not worry, I am CC-ing the maintainers. I just forgot to CC them when I replied.

Re: [patch][PCH] Do not write/read asm_out_file

2012-06-05 Thread Richard Guenther
On Mon, Jun 4, 2012 at 8:23 PM, Steven Bosscher stevenb@gmail.com wrote: Hello, The attached patch removes one more #include output.h, this time from c-family/c-pch.c. Anything written out to asm_out_file between pch_init and c_common_write_pch is read back in by c_common_write_pch and

Re: _FORTIFY_SOURCE for std::vector

2012-06-05 Thread Richard Guenther
On Mon, Jun 4, 2012 at 9:07 PM, Marc Glisse marc.gli...@inria.fr wrote: On Mon, 4 Jun 2012, Florian Weimer wrote: On 06/01/2012 01:34 PM, Jakub Jelinek wrote: Have you looked at the assembly differences with this in? It's not great. Here's an example: void write(std::vectorfloat blob,

[ARM Patch 4/n]PR53447: optimizations of 64bit ALU operation with constant

2012-06-05 Thread Carrot Wei
Hi This is the fourth part of the patches that deals with 64bit ior. It directly extends the patterns iordi3, iordi3_insn and iordi3_neon to handle 64bit constant operands. Tested on arm qemu without regression. OK for trunk? thanks Carrot 2012-06-05 Wei Guozhi car...@google.com PR

Re: libgo patch committed: Include TLS size in stack size

2012-06-05 Thread Richard Guenther
On Tue, Jun 5, 2012 at 9:20 AM, Jakub Jelinek ja...@redhat.com wrote: On Mon, Jun 04, 2012 at 11:19:46PM -0700, Ian Lance Taylor wrote: This patch to libgo includes the TLS size in the requested stack size of a new thread, if possible.  This relies on the glibc-specific (and undocumented)

Re: [PATCH][RFC] Extend memset recognition

2012-06-05 Thread Richard Guenther
On Thu, 31 May 2012, Richard Guenther wrote: On Wed, 30 May 2012, Richard Guenther wrote: The patch below extents memset recognition to cover a few more non-byte-size store loops and all byte-size store loops. This exposes issues with our builtins.exp testsuite which has custom

Re: [Fortran, DRAFT patch] PR 46321 - [OOP] Polymorphic deallocation

2012-06-05 Thread Paul Richard Thomas
Hi Alessandro, I am glad to see that Janus is giving you a helping hand, in addition to Tobias. I am so tied up with every aspect of life that gfortran is not figuring much at all. When you clean up the patch, you might consider making this into a separate function: + if (free_proc) +

GCC 4.7.1 Status Report (2012-06-05), branch frozen

2012-06-05 Thread Richard Guenther
The GCC 4.7 branch is now frozen for creating a first release candidate of the GCC 4.7.1 release. All changes need explicit release manager approval until the final release of GCC 4.7.1 which should happen roughly one week after the release candidate if no issues show up with it. Previous

[PATCH][8/7] loop distribution TLC

2012-06-05 Thread Richard Guenther
Well - this replaces passing down a flag pointer with a new member in the partition struct. Bootstrapped and tested on x86_64-unknown-linux-gnu, applied. Richard. 2012-06-05 Richard Guenther rguent...@suse.de * tree-loop-distribution.c (struct partition_s): Add has_writes

Re: PATCH: --with-abi=x32 without --with-multilib-list doesn't work

2012-06-05 Thread Uros Bizjak
On Mon, Jun 4, 2012 at 8:09 PM, H.J. Lu hongjiu...@intel.com wrote: We should enable x32 run-time library if --with-abi={x32|mx32} is used to configure GCC i[34567]86-*-* and x86_64-*-*.  Tested on Linux/x86-64. OK for trunk? 2012-06-04  H.J. Lu  hongjiu...@intel.com        PR target/53575

Merge from gcc-4_7-branch to gccgo branch

2012-06-05 Thread Ian Lance Taylor
I've merged gcc-4_7-branch revision 188231 to the gccgo branch. Ian

[PATCH] Fix part of PR30442

2012-06-05 Thread Richard Guenther
PR30442 shows that we do not vectorize basic-blocks if the to-be vectorized data-references are followed by something that find_data_references_in_stmt does not know how to analyze (any call or asm for example). The following re-organizes how we create data-references in vect_analyze_data_refs

Re: PATCH: --with-abi=x32 without --with-multilib-list doesn't work

2012-06-05 Thread H.J. Lu
On Tue, Jun 5, 2012 at 5:24 AM, Uros Bizjak ubiz...@gmail.com wrote: On Mon, Jun 4, 2012 at 8:09 PM, H.J. Lu hongjiu...@intel.com wrote: We should enable x32 run-time library if --with-abi={x32|mx32} is used to configure GCC i[34567]86-*-* and x86_64-*-*.  Tested on Linux/x86-64. OK for

Re: PATCH: --with-abi=x32 without --with-multilib-list doesn't work

2012-06-05 Thread Uros Bizjak
On Tue, Jun 5, 2012 at 2:47 PM, H.J. Lu hjl.to...@gmail.com wrote: We should enable x32 run-time library if --with-abi={x32|mx32} is used to configure GCC i[34567]86-*-* and x86_64-*-*.  Tested on Linux/x86-64. Why all three ABIs here? Didn't user specify -with-abi=mx32 only, so

Re: libgo patch committed: Include TLS size in stack size

2012-06-05 Thread Ian Lance Taylor
Jakub Jelinek ja...@redhat.com writes: On Mon, Jun 04, 2012 at 11:19:46PM -0700, Ian Lance Taylor wrote: This patch to libgo includes the TLS size in the requested stack size of a new thread, if possible. This relies on the glibc-specific (and undocumented) _dl_get_tls_static_info call.

Re: [trunk] Copy TREE_STATIC() property from id in dwarf2asm.c (issue 6133061)

2012-06-05 Thread Diego Novillo
On Thu, May 31, 2012 at 8:10 PM, asha...@chromium.org wrote: Reviewers: xur, davidxl, iant2, Diego Novillo, Message: The relevant bug is this: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53546. This bug does not affect trunk. Only the google branches where LIPO is implemented. Diego.

Re: [PATCH] Fix part of PR30442

2012-06-05 Thread Nathan Froyd
On Tue, Jun 05, 2012 at 02:35:30PM +0200, Richard Guenther wrote: Index: gcc/tree-vect-data-refs.c ! gimple stmt = gsi_stmt (gsi); ! if (!find_data_references_in_stmt (NULL, stmt, ! BB_VINFO_DATAREFS (bb_vinfo))) ! { ! /*

Re: [gimplefe] Adding more preliminary tests

2012-06-05 Thread Diego Novillo
On 12-06-04 23:08 , Sandeep Soni wrote: Hi, I have added some more preliminary tests for the gimple front end.. These are really simple individual statement tests which have helped me get a hang of the testing mechanism in gcc. I will be adding a few more tests tonight. Sounds good. At this

Re: [PATCH] vrp: fold ffs to ctz

2012-06-05 Thread Paolo Bonzini
Il 04/06/2012 11:31, Richard Guenther ha scritto: +val = compare_range_with_value (NE_EXPR, vr, integer_zero_node, sop); +if (!val || !integer_onep (val)) + return false; please add a value_range_nonzero_p helper alongside value_range_nonnegative_p. +

Re: [PATCH] Fix part of PR30442

2012-06-05 Thread Richard Guenther
On Tue, 5 Jun 2012, Nathan Froyd wrote: On Tue, Jun 05, 2012 at 02:35:30PM +0200, Richard Guenther wrote: Index: gcc/tree-vect-data-refs.c ! gimple stmt = gsi_stmt (gsi); ! if (!find_data_references_in_stmt (NULL, stmt, !BB_VINFO_DATAREFS

Re: User directed Function Multiversioning via Function Overloading (issue5752064)

2012-06-05 Thread H.J. Lu
On Mon, Jun 4, 2012 at 3:29 PM, Sriraman Tallam tmsri...@google.com wrote: Bug fixed and new patch attached. Patch also available for review at http://codereview.appspot.com/5752064 I think you should also export __cpu_indicator_init in libgcc_s.so. Also, is this feature C++ only? Can you

Re: [PATCH 2/2] Better system header location detection for built-in macro tokens

2012-06-05 Thread Jason Merrill
On 06/05/2012 12:14 AM, Mike Stump wrote: On Jun 4, 2012, at 7:46 PM, Mike Stump wrote: g++.dg/other/warning1.C -std=c++11 (test for warnings, line 10) g++.dg/other/warning1.C -std=c++11 (test for warnings, line 11) g++.dg/other/warning1.C -std=c++11 (test for excess errors)

Re: [C++ Patch] PR 53567

2012-06-05 Thread Jason Merrill
On 06/05/2012 07:00 AM, Paolo Carlini wrote: (construct_virtual_base): Adjust LOOKUP_COMPLAIN - LOOKUP_NORMAL. This and the similar changes elsewhere seem dangerous; they're adding adding LOOKUP_PROTECT that wasn't there before. Instead, let's replace LOOKUP_COMPLAIN with 0 or some

Re: [PATCH] Fix part of PR30442

2012-06-05 Thread Richard Guenther
On Tue, 5 Jun 2012, Richard Guenther wrote: On Tue, 5 Jun 2012, Nathan Froyd wrote: On Tue, Jun 05, 2012 at 02:35:30PM +0200, Richard Guenther wrote: Index: gcc/tree-vect-data-refs.c ! gimple stmt = gsi_stmt (gsi); ! if (!find_data_references_in_stmt (NULL, stmt,

[PATCH][RFC] Recognize memcpy/memmove - fix PR53081

2012-06-05 Thread Richard Guenther
This adds memcpy/memmove recognition to loop distribution (and cleans it up some more). Issues are similar to memset and not handled (and I just noticed we generate memset/memcpy even with -fno-builtin ...). Bootstrapped on x86_64-unknown-linux-gnu, testing in progress. Richard. 2012-06-05

Re: No documentation of -fsched-pressure-algorithm

2012-06-05 Thread Ulrich Weigand
Richard Sandiford wrote: Ian Lance Taylor i...@google.com writes: Richard Sandiford rdsandif...@googlemail.com writes: gcc/ * doc/invoke.texi (sched-pressure-algorithm): Document new --param. * common.opt (fsched-pressure-algorithm=): Remove. * flag-types.h

Re: arm-rtems switch default target to EABI

2012-06-05 Thread Sebastian Huber
Hi, what is the blocking point for the integration of these patches? -- Sebastian Huber, embedded brains GmbH Address : Obere Lagerstr. 30, D-82178 Puchheim, Germany Phone : +49 89 18 90 80 79-6 Fax : +49 89 18 90 80 79-9 E-Mail : sebastian.hu...@embedded-brains.de PGP : Public key

Re: [C++] Return error_mark_node from cp_parser_constant_expression

2012-06-05 Thread Florian Weimer
On 06/04/2012 10:46 PM, Jason Merrill wrote: On 06/04/2012 04:12 PM, Florian Weimer wrote: This doesn't make sense to me. parser-integral_constant_expression_p should always be true at this point if you're moving the restore later (which also seems unnecessary). I think

Re: arm-rtems switch default target to EABI

2012-06-05 Thread Sebastian Huber
On 05/14/2012 08:51 PM, Joseph S. Myers wrote: On Mon, 14 May 2012, Joel Sherrill wrote: There is a long explanation in the PR but the short version is that although we fully intended to switch the arm-rtems target from ELF to EABI we never intended the target name arm-*-rtemseabi* to become

[PATCH][Cilkplus] Patch to fix array notation bug

2012-06-05 Thread Iyer, Balaji V
Hello Everyone, This patch is for the Cilkplus branch affecting the C++ compiler. This patch will fix some cases were array notation is not decomposed correctly in parser. Thanking You, Yours Sincerely, Balaji V. Iyer. Index: gcc/cp/parser.c

[RFC, ivopts] fix bugs in ivopts address cost computation

2012-06-05 Thread Sandra Loosemore
My colleagues and I have been working on the GCC port for the Qualcomm Hexagon. Along the way I noticed that we were getting poor results from the ivopts pass no matter how we adjusted the target-specific RTX costs. In many cases ivopts was coming up with candidate use costs that seemed

Re: [C++ Patch] PR 53567

2012-06-05 Thread Paolo Carlini
Hi, We could, but I think it's fine to have it as an alias for LOOKUP_PROTECT; the LOOKUP_NORMAL name implies that we're doing a normal name lookup, whereas LOOKUP_PROTECT is what that implies. Believe it or not, yesterday for a few minutes I had it exactly as an alias. Ok, I'll do that.

Re: [patch] Fix PR ada/52362

2012-06-05 Thread Diego Novillo
On Fri, May 18, 2012 at 5:05 PM, Eric Botcazou ebotca...@adacore.com wrote:        * configure.ac (HAVE_GNU_LD): Move to after config.gcc inclusion.        (HAVE_GNU_AS): Likewise.        * config.in: Regenerate.        * configure: Likewise. Eric, This change is breaking bootstraps in one

Re: [C++] Return error_mark_node from cp_parser_constant_expression

2012-06-05 Thread Jason Merrill
On 06/05/2012 11:19 AM, Florian Weimer wrote: True. But if we want cascading errors, cp_parser_constant_expression really cannot return error_mark_node, so this approach is a dead end. (For example, build_enumerator replaces error_mark_node in the enumeration value with nothing, i.e., the next

Re: [C++] Return error_mark_node from cp_parser_constant_expression

2012-06-05 Thread Gabriel Dos Reis
On Tue, Jun 5, 2012 at 12:05 PM, Jason Merrill ja...@redhat.com wrote: In the operator new case, the non-constant expression error followed by the VLA warning is not as helpful, as the latter ignores the former. Perhaps the right way to deal with this is to allow non-constant expressions in

Re: [PATCH][C++] Fix PR52841

2012-06-05 Thread Jason Merrill
OK. Jason

Re: [google] New fdo summary-based icache sensitive unrolling (issue 6282045)

2012-06-05 Thread davidxl
http://codereview.appspot.com/6282045/diff/1/gcc/gcov-io.h File gcc/gcov-io.h (right): http://codereview.appspot.com/6282045/diff/1/gcc/gcov-io.h#newcode544 gcc/gcov-io.h:544: gcov_unsigned_t sum_cutoff_percent;/* sum_all cutoff percentage computed Is there a need to record this?

[PATCH, testsuite] Fix gcc.target/powerpc/lhs-1.c for 32-bit

2012-06-05 Thread Pat Haugen
The following fixes a problem with my recently added testcase that resulted in failure for 32-bit since instructions to stack a frame reduced the number of nop's that were needed to force the load into a separate dispatch group. Tested on powerpc64-linux, committed as obvious. -Pat

Re: [wwwdocs] Make codingconventions.html pass W3 validator.

2012-06-05 Thread Gerald Pfeifer
Hi Lawrence, On Mon, 4 Jun 2012, Lawrence Crowl wrote: The following source change enables coddingconventions.html to pass the HTML validator at validator.w3.org. the web pages will be preprocessed before the are put on the server (this transparently happens upon checkin) and as part of that

[patch][cris] Clean up some cris-aout remnants

2012-06-05 Thread Steven Bosscher
Hello, This patch just cleans up some remaining code for removed cris-aout subtarget by folding away code that was conditional on TARGET_ELF. Tested with a x86_64-linux X cris-elf cross-compiler. OK for trunk? Ciao! Steven cris_small_cleanups.diff Description: Binary data

Re: [PR49888, VTA] don't keep VALUEs bound to modified MEMs

2012-06-05 Thread Alexandre Oliva
On May 23, 2012, Jakub Jelinek ja...@redhat.com wrote: On Wed, May 23, 2012 at 06:27:21AM -0300, Alexandre Oliva wrote: + for (loc = var-var_part[0].loc_chain; loc; loc = loc-next) +if (GET_CODE (loc-loc) == MEM + !nonoverlapping_memrefs_p (loc-loc, mloc, false))

Re: [RFA] PowerPC e5500 and e6500 cores support

2012-06-05 Thread Edmar
The patch I submitted had an omission. I failed to regenerate rs6000-tables.opt (Sorry, I misunderstood gcc_update --touch instructions) OK to commit the update ? 2012-06-05 Edmar Wienskoski ed...@freescale.com * config/rs6000/rs6000-tables.opt: Regenerated. On 06/04/2012 08:45 PM,

Re: [wwwdocs] Make codingconventions.html pass W3 validator.

2012-06-05 Thread Lawrence Crowl
On 6/5/12, Gerald Pfeifer ger...@pfeifer.com wrote: On Mon, 4 Jun 2012, Lawrence Crowl wrote: The following source change enables coddingconventions.html to pass the HTML validator at validator.w3.org. the web pages will be preprocessed before the are put on the server (this transparently

[RFC] [PowerPC] Patch to create new attribute type: popcnt

2012-06-05 Thread Edmar
David, Michael, Here is the new type popcnt patch that I had separated from previous E5500/E6500 submission, also added the changes suggested by Michael Meissner (detailed bellow). I am missing some details for power6. (Could not find any documentation) Bootstrapped with no regressions, all

[PATCH, 4.6, committed] Backport fix for g++ -E -C issue in gthr-posix.h

2012-06-05 Thread Peter Bergner
I committed the following patch to the FSF 4.6 branch which Jakub approved on IRC. Peter Backport from mainline 2011-08-29 Jakub Jelinek ja...@redhat.com * gthr-posix.h (__gthread_active_p): Do not use preprocessor conditionals and comments inside macro

Re: Support for Runtime CPU type detection via builtins (issue5754058)

2012-06-05 Thread Sriraman Tallam
Hi H.J., I am attaching a patch to add __cpu_indicator_init to the list of symbols to be versioned and exported in libgcc_s.so. Also, updating builtin_target.c test to explicitly do a CPUID and check if the features are identified correctly like you had suggested earlier. Patch ok? *

Re: [PATCH] gcc/config/freebsd-spec.h: Fix building PIE executables. Link them with crt{begin,end}S.o and Scrt1.o which are PIC instead of crt{begin,end}.o and crt1.o which are not. Spec synced from g

2012-06-05 Thread Alexis Ballier
ping ? is there any problem with that patch ?

[PATCH][Cilkplus] Did an induction variable optimization

2012-06-05 Thread Iyer, Balaji V
Hello Everyone, This patch is for the Cilkplus branch affecting the C compiler. This patch will remove an unwanted conversion of the induction variable in the cilk_for function. Thanking You, Yours Sincerely, Balaji V. Iyer.Index: gcc/cilk-spawn.c

Re: [PATCH] vrp: fold ffs to ctz

2012-06-05 Thread Matt Thomas
On Jun 5, 2012, at 6:46 AM, Paolo Bonzini wrote: Do we always have CTZ if we have FFS? Can't there be a target that implements FFS as opcode but not CTZ, so you'd slow down things? Thus, should the transform be conditonal on target support for CTZ or no target support for FFS? Hmm, SH

Re: [C++ Patch] PR 53567

2012-06-05 Thread Jason Merrill
On 06/05/2012 08:23 PM, Paolo Carlini wrote: @@ -1695,6 +1695,8 @@ implicit_conversion (tree to, tree from, tree expr |LOOKUP_NO_TEMP_BIND|LOOKUP_NO_RVAL_BIND|LOOKUP_PREFER_RVALUE |LOOKUP_NO_NARROWING|LOOKUP_PROTECT); + complain= ~tf_error; I don't think we want

Re: [google] Add options to pattern match function name for hotness attributes

2012-06-05 Thread Dehao Chen
Patch updated: using regex to match the function name: http://codereview.appspot.com/6281047 Thanks, Dehao 2012-06-01 Dehao Chen de...@google.com * gcc/cgraph.c (cgraph_node): Add attribute to function decl. * gcc/opts-global.c (add_attribute_pattern): New function.

Re: [google] Add options to pattern match function name for hotness attributes

2012-06-05 Thread Xinliang David Li
Please document it in doc/invoke.texi with examples. thanks, David On Tue, Jun 5, 2012 at 7:28 PM, Dehao Chen de...@google.com wrote: Patch updated: using regex to match the function name: http://codereview.appspot.com/6281047 Thanks, Dehao 2012-06-01  Dehao Chen  de...@google.com    

Re: [google] Add options to pattern match function name for hotness attributes

2012-06-05 Thread Xinliang David Li
Also needs to get the attribute spec and call the attribute handler .. David On Tue, Jun 5, 2012 at 9:28 PM, Xinliang David Li davi...@google.com wrote: Please document it in doc/invoke.texi with examples. thanks, David On Tue, Jun 5, 2012 at 7:28 PM, Dehao Chen de...@google.com wrote: