Re: Reducing CPU load on git server

2016-08-28 Thread Jeff King
On Sun, Aug 28, 2016 at 12:42:52PM -0700, W. David Jarvis wrote: > The actual replication process works as follows: > > 1. The primary git server receives a push and sends a webhook with the > details of the push (repo, ref, sha, some metadata) to a "publisher" > box > > 2. The publisher

Re: Working with public-inbox.org

2016-08-28 Thread Johannes Schindelin
Hi Kuba, On Sun, 28 Aug 2016, Jakub Narębski wrote: > W dniu 28.08.2016 o 10:36, Johannes Schindelin pisze: > > On Sun, 28 Aug 2016, Jakub Narębski wrote: > > > >> Arguably for some federated/decentralized tools are preferred > >> (for philosophical reasons), even if they do not achieve even

Re: Suspected Bug in git install procedure [ git-daemon-run (version 1:2.9.3-1) ]

2016-08-28 Thread Jeff King
On Mon, Aug 29, 2016 at 06:29:04AM +0200, Jean-Marc B. van Schendel wrote: > Symptoms: > On a fresh new install of Debian "Stretch" (8.5 alpha7, dated 2016-06-30), > Trying to install a subset of Git packages (roughly, all those listed > in git-all, except CVS-related packages) > Install of

Suspected Bug in git install procedure [ git-daemon-run (version 1:2.9.3-1) ]

2016-08-28 Thread Jean-Marc B. van Schendel
Hi, Not really a bad bug, apparently just one little detail... Symptoms: On a fresh new install of Debian "Stretch" (8.5 alpha7, dated 2016-06-30), Trying to install a subset of Git packages (roughly, all those listed in git-all, except CVS-related packages) Install of package git-daemon-run

Re: Feature Request: Branch-Aware Submodules

2016-08-28 Thread Jacob Keller
On Fri, Aug 26, 2016 at 8:12 AM, Hedges Alexander wrote: >> On 25 Aug 2016, at 19:45, Stefan Beller wrote: >> [1] https://github.com/jlehmann/git-submod-enhancements >> which has some attempts for checkout including the submodules. >> I also tried

[PATCH 13/20] builtin/rm: convert to use struct object_id

2016-08-28 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/rm.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/builtin/rm.c b/builtin/rm.c index 109969d5..3f3e24eb 100644 --- a/builtin/rm.c +++ b/builtin/rm.c @@ -107,7 +107,7 @@ static int

[PATCH 09/20] builtin/checkout: convert some static functions to struct object_id

2016-08-28 Thread brian m. carlson
Convert all the static functions that are not callbacks to struct object_id. Signed-off-by: brian m. carlson --- builtin/checkout.c | 66 +++--- 1 file changed, 33 insertions(+), 33 deletions(-) diff --git

[PATCH 20/20] builtin/reset: convert to use struct object_id

2016-08-28 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/reset.c | 52 ++-- 1 file changed, 26 insertions(+), 26 deletions(-) diff --git a/builtin/reset.c b/builtin/reset.c index 9020ec66..5aa86079 100644 --- a/builtin/reset.c +++

[PATCH 08/20] streaming: make stream_blob_to_fd take struct object_id

2016-08-28 Thread brian m. carlson
Since all of its callers have been updated, modify stream_blob_to_fd to take a struct object_id. Signed-off-by: brian m. carlson --- builtin/cat-file.c | 6 +++--- builtin/fsck.c | 2 +- builtin/log.c | 4 ++-- entry.c| 2 +- streaming.c

[PATCH 11/20] Convert read_mmblob to take struct object_id.

2016-08-28 Thread brian m. carlson
Since all of its callers have been updated, convert read_mmblob to take a pointer to struct object_id. Signed-off-by: brian m. carlson --- builtin/apply.c| 6 +++--- builtin/checkout.c | 6 +++--- merge-recursive.c | 6 +++--- notes-merge.c | 6 +++---

[PATCH 05/20] builtin/cat-file: convert struct expand_data to use struct object_id

2016-08-28 Thread brian m. carlson
Convert struct cache_entry to use struct object_id by applying the following semantic patch and the object_id transforms from contrib: @@ struct expand_data E1; @@ - E1.sha1 + E1.oid.hash @@ struct expand_data *E1; @@ - E1->sha1 + E1->oid.hash @@ struct expand_data E1; @@ - E1.delta_base_sha1 +

[PATCH 14/20] notes: convert init_notes to use struct object_id

2016-08-28 Thread brian m. carlson
Signed-off-by: brian m. carlson --- notes.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/notes.c b/notes.c index df4660fe..2bab961a 100644 --- a/notes.c +++ b/notes.c @@ -993,7 +993,7 @@ const char *default_notes_ref(void) void

[PATCH 19/20] builtin/commit-tree: convert to struct object_id

2016-08-28 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/commit-tree.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/builtin/commit-tree.c b/builtin/commit-tree.c index 8a674bc9..60501726 100644 --- a/builtin/commit-tree.c +++

[PATCH 15/20] builtin/update-index: convert file to struct object_id

2016-08-28 Thread brian m. carlson
Convert all functions to use struct object_id, and replace instances of hardcoded 40, 41, and 42 with appropriate references to GIT_SHA1_HEXSZ. Signed-off-by: brian m. carlson --- builtin/update-index.c | 61 +- 1

[PATCH 12/20] builtin/blame: convert file to use struct object_id

2016-08-28 Thread brian m. carlson
Convert this file to use struct object_id, and additionally convert some uses of the constant 40 to GIT_SHA1_HEXSZ. Signed-off-by: brian m. carlson --- builtin/blame.c | 28 ++-- 1 file changed, 14 insertions(+), 14 deletions(-) diff --git

[PATCH 03/20] builtin/blame: convert struct origin to use struct object_id

2016-08-28 Thread brian m. carlson
Convert struct origin to use struct object_id by applying the following semantic patch and the object_id transforms from contrib: @@ struct origin E1; @@ - E1.blob_sha1 + E1.blob_oid.hash @@ struct origin *E1; @@ - E1->blob_sha1 + E1->blob_oid.hash Signed-off-by: brian m. carlson

[PATCH 16/20] sha1_name: convert get_sha1_mb to struct object_id

2016-08-28 Thread brian m. carlson
All of the callers of this function use struct object_id, so rename it to get_oid_mb and make it take struct object_id instead of unsigned char *. Signed-off-by: brian m. carlson --- builtin/checkout.c | 2 +- cache.h| 2 +- sha1_name.c| 18

[PATCH 10/20] notes-merge: convert struct notes_merge_pair to struct object_id

2016-08-28 Thread brian m. carlson
Convert each of this structure's members from an unsigned char array to a struct object_id. Signed-off-by: brian m. carlson --- notes-merge.c | 122 +- 1 file changed, 62 insertions(+), 60 deletions(-) diff

[PATCH 04/20] builtin/log: convert some static functions to use struct object_id

2016-08-28 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/log.c | 44 ++-- 1 file changed, 22 insertions(+), 22 deletions(-) diff --git a/builtin/log.c b/builtin/log.c index 92dc34dc..226212c9 100644 --- a/builtin/log.c +++ b/builtin/log.c

[PATCH 06/20] builtin/cat-file: convert some static functions to struct object_id

2016-08-28 Thread brian m. carlson
Convert all of the static functions that are not callbacks to use struct object_id. Signed-off-by: brian m. carlson --- builtin/cat-file.c | 50 +- 1 file changed, 25 insertions(+), 25 deletions(-) diff --git

[PATCH 17/20] refs: add an update_ref_oid function.

2016-08-28 Thread brian m. carlson
Several places around the codebase want to pass update_ref data from struct object_id, but update_ref may also be passed NULL pointers. Instead of checking and dereferencing in every caller, create an update_ref_oid which wraps update_ref and provides this functionality. Signed-off-by: brian m.

[PATCH 07/20] builtin: convert textconv_object to use struct object_id

2016-08-28 Thread brian m. carlson
Since all of its callers have been updated, make textconv_object take a struct object_id. Signed-off-by: brian m. carlson --- builtin.h | 2 +- builtin/blame.c| 12 ++-- builtin/cat-file.c | 2 +- builtin/log.c | 2 +- 4 files changed,

[PATCH 18/20] builtin/am: convert to struct object_id

2016-08-28 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/am.c | 138 +-- 1 file changed, 69 insertions(+), 69 deletions(-) diff --git a/builtin/am.c b/builtin/am.c index 739b34dc..632d4288 100644 --- a/builtin/am.c +++

[PATCH 01/20] cache: convert struct cache_entry to use struct object_id

2016-08-28 Thread brian m. carlson
Convert struct cache_entry to use struct object_id by applying the following semantic patch and the object_id transforms from contrib: @@ struct cache_entry E1; @@ - E1.sha1 + E1.oid.hash @@ struct cache_entry *E1; @@ - E1->sha1 + E1->oid.hash Signed-off-by: brian m. carlson

[PATCH 00/20] object_id part 5

2016-08-28 Thread brian m. carlson
This is the fifth in a series of series to convert from unsigned char [20] to struct object_id. This series converts many of the files in the builtin directory to use struct object_id. This gets us almost to the point where we can convert get_tree_entry to use struct object_id, but not quite.

[PATCH 02/20] builtin/apply: convert static functions to struct object_id

2016-08-28 Thread brian m. carlson
There were several static functions using unsigned char arrays for SHA-1 values. Convert them to use struct object_id. Signed-off-by: brian m. carlson --- builtin/apply.c | 96 - 1 file changed, 48

git submodules implementation question

2016-08-28 Thread Uma Srinivasan
Hi, I am new to git source and internal development. Recently I've been looking at a problem where issuing "git status" in a corrupted workspace handed over to me by a user, forks several thousand child processes recursively. The symptoms of the corrupted workspace to reproduce this problem are

Re: Reducing CPU load on git server

2016-08-28 Thread W. David Jarvis
My assumption is that pack bitmaps are enabled since the primary server is a GitHub Enterprise instance, but I'll have to confirm. On Sun, Aug 28, 2016 at 2:20 PM, Jakub Narębski wrote: > W dniu 28.08.2016 o 21:42, W. David Jarvis pisze: > >> The ultimate goal for us is just

Re: [Ksummit-discuss] checkkpatch (in)sanity ?

2016-08-28 Thread Joe Perches
On Sun, 2016-08-28 at 23:24 +0200, Dennis Kaarsemaker wrote: > > There are some that want an ncurses only version of git blame > > that could use arrow-key style navigation for historical commit > > line-ranges. > > > > git gui blame kind of works, but it's not ncurses/text based. > > git-cola

Re: [Ksummit-discuss] checkkpatch (in)sanity ?

2016-08-28 Thread Dennis Kaarsemaker
On zo, 2016-08-28 at 12:52 -0700, Joe Perches wrote: > On Sun, 2016-08-28 at 11:59 +0200, Julia Lawall wrote: > > > > On Sun, 28 Aug 2016, Alexey Dobriyan wrote: > [] > > > > > > > > The problem is that c-h.pl generates noise in the commit history > > > and > > > makes git-blame less useful

Re: Reducing CPU load on git server

2016-08-28 Thread Jakub Narębski
W dniu 28.08.2016 o 21:42, W. David Jarvis pisze: > The ultimate goal for us is just figuring out how we can best reduce > the CPU load on the primary instance so that we don't find ourselves > in a situation where we're not able to run basic git operations > anymore. I assume that you have

Re: [Ksummit-discuss] checkkpatch (in)sanity ?

2016-08-28 Thread Jiri Kosina
On Sun, 28 Aug 2016, Joe Perches wrote: > Are there other existing tools for blame history viewing? fugitive vim plugin has 'Gblame' command, which I personally find rather useful, and given the text-oriented nature could potentially be useful for your needs. -- Jiri Kosina SUSE Labs -- To

Re: [Ksummit-discuss] checkkpatch (in)sanity ?

2016-08-28 Thread Joe Perches
On Sun, 2016-08-28 at 11:59 +0200, Julia Lawall wrote: > On Sun, 28 Aug 2016, Alexey Dobriyan wrote: [] > > The problem is that c-h.pl generates noise in the commit history and > > makes git-blame less useful than it can be. > > Could it be that this is a problem with git blame, rather than with

Reducing CPU load on git server

2016-08-28 Thread W. David Jarvis
Hi all - I've run into a problem that I'm looking for some help with. Let me describe the situation, and then some thoughts. The company I work for uses git. We use GitHub Enterprise as a frontend for our primary git server. We're using Chef solo to manage a fleet of upwards of 10,000 hosts,

Re: Working with public-inbox.org [Was: [PATCH] rev-parse: respect core.hooksPath in --git-path]

2016-08-28 Thread Jakub Narębski
Hello Johannes, W dniu 25.08.2016 o 15:21, Johannes Schindelin pisze: > On Mon, 22 Aug 2016, Jakub Narębski wrote: >> W dniu 22.08.2016 o 15:18, Johannes Schindelin pisze: >> >>> So unfortunately this thread has devolved. Which is sad. Because all I >>> wanted is to have a change in Git's

Re: Notation for current branch?

2016-08-28 Thread Jakub Narębski
W dniu 28.08.2016 o 12:51, Kevin Daudt pisze: > On Sun, Aug 28, 2016 at 05:58:18PM +0800, ryenus wrote: >> I wonder if there's an easy to use notation to refer to the current branch? >> which is expected be friendly to scripting. >> >> For HEAD, there's @, which is short and concise. What's

Announcing Git User's Survey 2016 [was: Working with public-inbox.org]

2016-08-28 Thread Jakub Narębski
Hello Johannes, W dniu 28.08.2016 o 10:38, Johannes Schindelin pisze: > On Sun, 28 Aug 2016, Jakub Narębski wrote: >> W dniu 22.08.2016 o 15:15, Duy Nguyen pisze: >>> On Mon, Aug 22, 2016 at 8:06 PM, Johannes Schindelin >>> wrote: My point stands. We are way

Re: [PATCH v5 09/12] doc: revisions - define `reachable`

2016-08-28 Thread Jakub Narębski
W dniu 12.08.2016 o 09:07, Philip Oakley pisze: [...] > History traversing commands such as `git log` operate on a set > -of commits, not just a single commit. To these commands, > -specifying a single revision with the notation described in the > -previous section means the set of commits

[PATCH] p3400: make test script executable

2016-08-28 Thread René Scharfe
Signed-off-by: Rene Scharfe --- This script was added by v2.10.0-rc0~3^2. t/perf/p3400-rebase.sh | 0 1 file changed, 0 insertions(+), 0 deletions(-) mode change 100644 => 100755 t/perf/p3400-rebase.sh diff --git a/t/perf/p3400-rebase.sh b/t/perf/p3400-rebase.sh old mode 100644

Re: Working with public-inbox.org

2016-08-28 Thread Jakub Narębski
Hello Johannes, W dniu 28.08.2016 o 10:36, Johannes Schindelin pisze: > On Sun, 28 Aug 2016, Jakub Narębski wrote: >> W dniu 25.08.2016 o 14:58, Johannes Schindelin pisze: >>> On Mon, 22 Aug 2016, Eric Wong wrote: Johannes Schindelin wrote: > I just want

Re: [RFC] Proposed questions for "Git User's Survey 2016"

2016-08-28 Thread Jakub Narębski
W dniu 28.08.2016 o 11:49, Eric Wong pisze: > Jakub Narębski wrote: >> W dniu 26.08.2016 o 08:15, Eric Wong pisze: >> >>> Not directly-related to the survey questions, but can you ensure >>> it's accessible to folks without JavaScript/graphics, and >>> perhaps also ensure it is

Re: Notation for current branch?

2016-08-28 Thread Kevin Daudt
On Sun, Aug 28, 2016 at 05:58:18PM +0800, ryenus wrote: > I wonder if there's an easy to use notation to refer to the current branch? > which is expected be friendly to scripting. > > For HEAD, there's @, which is short and concise. > > But for the current branch, it seems one has to either use

Notation for current branch?

2016-08-28 Thread ryenus
I wonder if there's an easy to use notation to refer to the current branch? which is expected be friendly to scripting. For HEAD, there's @, which is short and concise. But for the current branch, it seems one has to either use a not so friendly plumbing command, or grep/parse the output of `git

Re: [RFC] Proposed questions for "Git User's Survey 2016"

2016-08-28 Thread Eric Wong
Jakub Narębski wrote: > W dniu 26.08.2016 o 08:15, Eric Wong pisze: > > > Not directly-related to the survey questions, but can you ensure > > it's accessible to folks without JavaScript/graphics, and > > perhaps also ensure it is on a host that is Tor-friendly? > > I plan on

Re: Working with public-inbox.org [Was: [PATCH] rev-parse: respect core.hooksPath in --git-path]

2016-08-28 Thread Johannes Schindelin
Hi Kuba & Duy, On Sun, 28 Aug 2016, Jakub Narębski wrote: > W dniu 22.08.2016 o 15:15, Duy Nguyen pisze: > > On Mon, Aug 22, 2016 at 8:06 PM, Johannes Schindelin > > wrote: > >> > >> My point stands. We are way more uninviting to contributors than > >> necessary. And

Re: Working with public-inbox.org

2016-08-28 Thread Johannes Schindelin
Hi Kuba, On Sun, 28 Aug 2016, Jakub Narębski wrote: > W dniu 25.08.2016 o 14:58, Johannes Schindelin pisze: > > On Mon, 22 Aug 2016, Eric Wong wrote: > >> Johannes Schindelin wrote: > >> > >>> I just want developers who are already familiar with Git, and come up with