Re: [PATCH 21/28] commit_packed_refs(): use a staging file separate from the lockfile

2017-07-21 Thread Junio C Hamano
Jonathan Nieder writes: >> Do we care about the ancient layout that used symlinks to emulate >> the more modern worktree one? > > I think we do care. In the context of people's changing workflows, > "git worktree" is a relatively new tool. Breaking the older >

Re: [PATCH 21/28] commit_packed_refs(): use a staging file separate from the lockfile

2017-07-21 Thread Junio C Hamano
Junio C Hamano writes: > The general strategy we take for these atomic update of a file > entity at $path is to: > > (1) try to create $path.lock exclusively; if we cannot, somebody > else holds the lock so fail (or backoff and retry, which > amounts to the same

Re: fatal: bad numeric config value '60 days' for 'gc.rerereresolved': invalid unit

2017-07-21 Thread Uwe Hausbrand
Yeah, after I checked the code I saw that this is interpreted as integer and fixed my configuration 2017-07-21 16:33 GMT+02:00 Junio C Hamano : > Uwe Hausbrand writes: > >> seems like there is a bug with "git rerere gc" not understanding grace >> periods

[PATCH] config.mak.uname: set FREAD_READS_DIRECTORIES for cygwin

2017-07-21 Thread Ramsay Jones
Signed-off-by: Ramsay Jones --- Hi Junio, My 'make test' run for the v2.14.0-rc0 on cygwin turned up a new test failure (over and above the v2.13.0 failures), namely t1308.23. Running the test in the debugger showed that cygwin was fopen-ing the 'a-directory'

Re: git gc seems to break --symbolic-full-name

2017-07-21 Thread Junio C Hamano
Stas Sergeev writes: > I do the following: > > $ git rev-parse --symbolic-full-name devel > refs/heads/devel > $ ls -l .git/`git rev-parse --symbolic-full-name devel` > -rw-rw-r-- 1 stas stas 41 июл 21 15:05 .git/refs/heads/devel > > This is fine. But after git gc: > > $ git

Re: [PATCH v2] l10n: de.po: update German translation

2017-07-21 Thread Junio C Hamano
Ralf Thielow writes: > after applying the patch, entries in date.c turned into this > > -#: date.c:122 date.c:129 date.c:136 date.c:143 date.c:149 date.c:156 > date.c:167 > -#: date.c:175 date.c:180 > -msgid "%" > -msgid_plural "%" > -msgstr[0] "%" > -msgstr[1] "%" > +#:

git gc seems to break --symbolic-full-name

2017-07-21 Thread Stas Sergeev
Hello. I do the following: $ git rev-parse --symbolic-full-name devel refs/heads/devel $ ls -l .git/`git rev-parse --symbolic-full-name devel` -rw-rw-r-- 1 stas stas 41 июл 21 15:05 .git/refs/heads/devel This is fine. But after git gc: $ git rev-parse --symbolic-full-name devel

Re: Binary files

2017-07-21 Thread Igor Djordjevic
On 20/07/2017 22:40, Junio C Hamano wrote: > Igor Djordjevic writes: >> On 20/07/2017 09:41, Volodymyr Sendetskyi wrote: >>> It is known, that git handles badly storing binary files in its >>> repositories at all. >>> This is especially about large files: even without

Re: git gc seems to break --symbolic-full-name

2017-07-21 Thread Stas Sergeev
21.07.2017 21:56, Junio C Hamano пишет: Stas Sergeev writes: I do the following: $ git rev-parse --symbolic-full-name devel refs/heads/devel $ ls -l .git/`git rev-parse --symbolic-full-name devel` -rw-rw-r-- 1 stas stas 41 июл 21 15:05 .git/refs/heads/devel This is fine. But

Re: [PATCH] config.mak.uname: set FREAD_READS_DIRECTORIES for cygwin

2017-07-21 Thread Junio C Hamano
Ramsay Jones writes: > Signed-off-by: Ramsay Jones > --- > > Hi Junio, > > My 'make test' run for the v2.14.0-rc0 on cygwin turned up a new > test failure (over and above the v2.13.0 failures), namely t1308.23. > Running the test in the

[PATCH] refs: use skip_prefix() in ref_is_hidden()

2017-07-21 Thread Christian Couder
This saves one line, makes the code a bit easier to understand and perhaps a bit faster too. Signed-off-by: Christian Couder --- refs.c | 7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/refs.c b/refs.c index ba22f4acef..15cb36d426 100644 ---

Re: [PATCH 0/6] 2.14 RelNotes improvements

2017-07-21 Thread Ævar Arnfjörð Bjarmason
On Thu, Jul 20 2017, Junio C. Hamano jotted: > Ævar Arnfjörð Bjarmason writes: > >> Here's a few patches to improve the relnotes. I started just writing >> 6/6 since I think (I don't care about the wording) that we should in >> some way mention the items in the list in the

fatal: bad numeric config value '60 days' for 'gc.rerereresolved': invalid unit

2017-07-21 Thread Uwe Hausbrand
Hi all, seems like there is a bug with "git rerere gc" not understanding grace periods like "60 days" defined in the config. What I did: git config gc.rerereresolved "60 days" git gc results in: Counting objects: 158790, done. Delta compression using up to 8 threads. Compressing objects: 100%

Re: [PATCH] PRItime: wrap PRItime for better l10n compatibility

2017-07-21 Thread Jiang Xin
2017-07-21 2:19 GMT+08:00 Junio C Hamano : > Junio C Hamano writes: > >> Johannes Schindelin writes: >> >>> But there may be hope. Since the character sequence "PRItime" is highly >>> unlikely to occur in Git's source code in any

Re: [PATCH] PRItime: wrap PRItime for better l10n compatibility

2017-07-21 Thread Junio C Hamano
Jiang Xin writes: > Sorry, I'm late. I want to try a safer way to change PRItime to > PRInMax using a hacked version of gettext. Why? A vanilla version of gettext tool that is fed a known PRIuMAX in its input would be a safer choice, I would have thought. I've

Re: fatal: bad numeric config value '60 days' for 'gc.rerereresolved': invalid unit

2017-07-21 Thread Junio C Hamano
Uwe Hausbrand writes: > seems like there is a bug with "git rerere gc" not understanding grace > periods like "60 days" defined in the config. > > What I did: > > git config gc.rerereresolved "60 days" Let's see how the variable is explained in the documentation.

Re: fatal: bad numeric config value '60 days' for 'gc.rerereresolved': invalid unit

2017-07-21 Thread Martin Ågren
On 21 July 2017 at 14:59, Uwe Hausbrand wrote: > git config gc.rerereresolved "60 days" > git gc > > results in: [...] > fatal: bad numeric config value '60 days' for 'gc.rerereresolved': invalid > unit > error: failed to run rerere It's not entirely clear, but "man

Re: [PATCH] git-contacts: Add recognition of Reported-by

2017-07-21 Thread Junio C Hamano
Eric Blake writes: > It's nice to cc someone that reported a bug, in order to let > them know that a fix is being considered, and possibly even > get their help in reviewing/testing the patch. > > Signed-off-by: Eric Blake > --- I don't know if this new

Re: [PATCH] PRItime: wrap PRItime for better l10n compatibility

2017-07-21 Thread Jean-Noël Avila
Le 20/07/2017 à 20:57, Junio C Hamano a écrit : > > + git diff --quiet HEAD && git diff --quiet --cached > + > + @for s in $(LOCALIZED_C) $(LOCALIZED_SH) $(LOCALIZED_PERL); \ Does PRIuMAX make sense for perl and sh files? > + do \ > + sed -e 's|PRItime|PRIuMAX|g' <"$$s"

Re: [PATCH] PRItime: wrap PRItime for better l10n compatibility

2017-07-21 Thread Junio C Hamano
Jean-Noël Avila writes: > Le 20/07/2017 à 20:57, Junio C Hamano a écrit : >> >> +git diff --quiet HEAD && git diff --quiet --cached >> + >> +@for s in $(LOCALIZED_C) $(LOCALIZED_SH) $(LOCALIZED_PERL); \ > > Does PRIuMAX make sense for perl and sh files? Not really; I

[PATCH] git-contacts: Add recognition of Reported-by

2017-07-21 Thread Eric Blake
It's nice to cc someone that reported a bug, in order to let them know that a fix is being considered, and possibly even get their help in reviewing/testing the patch. Signed-off-by: Eric Blake --- contrib/contacts/git-contacts | 2 +- 1 file changed, 1 insertion(+), 1

Re: [PATCH] PRItime: wrap PRItime for better l10n compatibility

2017-07-21 Thread Jiang Xin
2017-07-22 6:40 GMT+08:00 Junio C Hamano : > Jiang Xin writes: > >> Sorry, I'm late. I want to try a safer way to change PRItime to >> PRInMax using a hacked version of gettext. > > Why? A vanilla version of gettext tool that is fed a known PRIuMAX >

[PATCH] Makefile: generate pot file using a tweaked version of xgettext

2017-07-21 Thread Jiang Xin
Instead of doing a sed (s|PRItime|PRIuMAX) in working tree directly, we can use a tweaked version of gettext, which can replace PRItime macro to PRIuMAX (version 1.x) in runtime. We do not need to reset our working tree anymore, and this operation can be run without a version controlled working

Re: [PATCH] PRItime: wrap PRItime for better l10n compatibility

2017-07-21 Thread Junio C Hamano
Jiang Xin writes: > But it is rare to maintain po/git.pot file for 'maint' branch. And if > I need, I will switch to a different version of gettext. Makefile > will throw a error message, if I use a wrong version of gettext. Is that the "v1" in the check in your

Re: [PATCH] PRItime: wrap PRItime for better l10n compatibility

2017-07-21 Thread Junio C Hamano
Jiang Xin writes: > A very small hack on gettext. When extract l10n messages to pot file > with `xgettext`, will grep "PRItime", and do "sed s/PRItime/PRIuMAX" > inside `xgettext`. > > See this patch: >

Re: [PATCH] PRItime: wrap PRItime for better l10n compatibility

2017-07-21 Thread Jiang Xin
2017-07-22 7:34 GMT+08:00 Junio C Hamano : > Jiang Xin writes: > >> A very small hack on gettext. When extract l10n messages to pot file >> with `xgettext`, will grep "PRItime", and do "sed s/PRItime/PRIuMAX" >> inside `xgettext`. >> >> See this

Re: [RFC PATCH v2 2/4] promised-object, fsck: introduce promised objects

2017-07-21 Thread Jonathan Tan
On Fri, 21 Jul 2017 12:24:52 -0400 Ben Peart wrote: > Today we have 3.5 million objects * 30 bytes per entry = 105 MB of > promises. Given the average developer only hydrates 56K files (2 MB > promises) that is 103 MB to download that no one will ever need. We > would like

[PATCH v2] refs: use skip_prefix() in ref_is_hidden()

2017-07-21 Thread Christian Couder
This is shorter, makes the logic a bit easier to follow, and is perhaps a bit faster too. The logic is to make the final decision only when "subject" is there, its early part matches "match", and the match is at the slash boundary (or the whole thing). Signed-off-by: Christian Couder

Re: [RFC PATCH v2 4/4] sha1_file: support promised object hook

2017-07-21 Thread Ben Peart
On 7/20/2017 5:18 PM, Jonathan Tan wrote: On Thu, 20 Jul 2017 16:58:16 -0400 Ben Peart wrote: This is meant as a temporary measure to ensure that all Git commands work in such a situation. Future patches will update some commands to either tolerate promised objects

Re: [PATCH] refs: use skip_prefix() in ref_is_hidden()

2017-07-21 Thread Junio C Hamano
Christian Couder writes: > This saves one line, makes the code a bit easier to understand > and perhaps a bit faster too. > > Signed-off-by: Christian Couder > --- > refs.c | 7 +++ > 1 file changed, 3 insertions(+), 4 deletions(-) > >

[PATCH v3] l10n: de.po: update German translation

2017-07-21 Thread Ralf Thielow
Signed-off-by: Ralf Thielow --- v3 contains updated translations in date.c where %lu turned into %. po/de.po | 169 --- 1 file changed, 87 insertions(+), 82 deletions(-) diff --git a/po/de.po b/po/de.po index

Re: [PATCH] git-contacts: Add recognition of Reported-by

2017-07-21 Thread Eric Blake
On 07/21/2017 09:37 AM, Junio C Hamano wrote: > Eric Blake writes: > >> It's nice to cc someone that reported a bug, in order to let >> them know that a fix is being considered, and possibly even >> get their help in reviewing/testing the patch. >> >> Signed-off-by: Eric Blake

Re: [PATCH v2] l10n: de.po: update German translation

2017-07-21 Thread Ralf Thielow
Hi, after applying the patch, entries in date.c turned into this -#: date.c:122 date.c:129 date.c:136 date.c:143 date.c:149 date.c:156 date.c:167 -#: date.c:175 date.c:180 -msgid "%" -msgid_plural "%" -msgstr[0] "%" -msgstr[1] "%" +#: date.c:122 +#, fuzzy, c-format +msgid "% second ago"

Re: Reducing redundant build at Travis?

2017-07-21 Thread Junio C Hamano
Lars Schneider writes: > To answer your question: I don't see an easy solution to the problem. That's OK. Thanks for digging. I am wondering if the attached would be acceptable as a minimum impact patch to address this issue. I think I got the "are we building a

Re: [RFC PATCH v2 2/4] promised-object, fsck: introduce promised objects

2017-07-21 Thread Ben Peart
On 7/20/2017 5:13 PM, Jonathan Tan wrote: On Thu, 20 Jul 2017 15:58:51 -0400 Ben Peart wrote: On 7/19/2017 8:21 PM, Jonathan Tan wrote: Currently, Git does not support repos with very large numbers of objects or repos that wish to minimize manipulation of certain blobs

[PATCH v2] l10n: de.po: update German translation

2017-07-21 Thread Ralf Thielow
Signed-off-by: Ralf Thielow --- Hi Matthias, 2017-07-20 20:36 GMT+02:00 Matthias Rüster : > Hi Ralf, > > I think the following should be "hinzugefügt": > Sure. Thanks for review! Ciao, Ralf po/de.po | 123

Re: Handling of paths

2017-07-21 Thread Junio C Hamano
Victor Toni writes: > 2017-07-20 22:30 GMT+02:00 Junio C Hamano : >> >> I've read the function again and I think the attached patch covers >> everything that ought to be a filename. >> > Your swift reaction is very much appreciated. > With the background

Re: [PATCH] git-contacts: Add recognition of Reported-by

2017-07-21 Thread Junio C Hamano
Eric Blake writes: > You mean, something like > > git config --add contacts.autocc Reported-by > git config --add contacts.autocc Suggested-by > > where contacts.autocc would be a new multi-valued config option > specifying additional Tag: patterns to scrape out of the commit

Re: [PATCH v2] l10n: de.po: update German translation

2017-07-21 Thread Junio C Hamano
Ralf Thielow writes: > #: date.c:116 > msgid "in the future" > msgstr "in der Zukunft" > > #: date.c:122 date.c:129 date.c:136 date.c:143 date.c:149 date.c:156 > date.c:167 > #: date.c:175 date.c:180 > msgid "%" > msgid_plural "%" > -msgstr[0] "" > -msgstr[1] ""

Re: Reducing redundant build at Travis?

2017-07-21 Thread Lars Schneider
> On 20 Jul 2017, at 17:16, Junio C Hamano wrote: > > Lars Schneider writes: > >>> On 14 Jul 2017, at 17:32, Jeff King wrote: >>> >>> I don't know if Travis's cache storage is up to that challenge. We could >>> probably build such