[jira] [Updated] (SANDBOX-362) Create basic unit tests for all classes

2012-01-20 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-362: Attachment: ArgumentTest.zip I've attached a jUnit Test for Argument. Please let me know,

[jira] [Updated] (SANDBOX-363) Check if value is of the correct type in Argument.argument( ClassT type, V value )

2012-01-21 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-363?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-363: Attachment: SANDBOX-363.txt I have implemented a patch for this issue, but it breaks an

[jira] [Updated] (SANDBOX-363) Check if value is of the correct type in Argument.argument( ClassT type, V value )

2012-01-22 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-363?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-363: Comment: was deleted (was: Ciao Simo, here are a few thoughts about your comment on

[jira] [Updated] (SANDBOX-365) Extend Assertions for checking null references in arrays

2012-01-22 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-365?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-365: Attachment: SANDBOX-365.txt As discussed at SANDBOX-363 I implemented checkNoneIsNull(T[]

[jira] [Updated] (SANDBOX-363) Check if value is of the correct type in Argument.argument( ClassT type, V value )

2012-01-22 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-363?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-363: Attachment: SANDBOX-363v2.txt I implemented the changes mentioned by Simone. Please make

[jira] [Updated] (SANDBOX-362) Create basic unit tests for all classes

2012-01-23 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-362: Attachment: SANDBOX-362-RefactoringOfArgumentTest.txt Based on a discussion we had on the

[jira] [Updated] (SANDBOX-362) Create basic unit tests for all classes

2012-01-24 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-362: Attachment: SANDBOX-362-TypeUtilsTest.txt Hi, I have created a patch that adds a unit

[jira] [Updated] (SANDBOX-362) Create basic unit tests for all classes

2012-01-26 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-362: Attachment: SANDBOX-362-RefactoringOfAssertionsTest.txt As announced on the mailing list,

[jira] [Updated] (SANDBOX-362) Create basic unit tests for all classes

2012-01-27 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-362: Attachment: SANDBOX-362-BeanUtilsTest.txt I have created a very basic Test for BeanUtils.

[jira] [Updated] (SANDBOX-362) Create basic unit tests for all classes

2012-01-27 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-362?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-362: Attachment: SANDBOX-362-ConstructorTestCase.txt Hi again, I have attached a patch for

[jira] [Updated] (SANDBOX-371) [BeanUtils2] Make sure that a property is readable in DefaultBeanAccessor.getProperty( String name )

2012-01-30 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-371?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-371: Attachment: SANDBOX-371.txt I've created a patch. Summary: * Added the above mentioned

[jira] [Updated] (SANDBOX-373) [BeanUtils2] Implement setProperty( String name ) on DefaultBeanAccessor

2012-01-30 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-373?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-373: Attachment: SANDBOX-373.txt I've implemented a patch. It should be applied after

[jira] [Updated] (SANDBOX-376) [BeanUtils2] Extract magic numbers in AccessibleObjectsRegistry.getObjectTransformationCosts(...) to constants

2012-01-31 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-376?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-376: Attachment: SANDBOX-376.txt I've created a patch for that issue. I prefixed the constants

[jira] [Updated] (SANDBOX-377) [BeanUtils2] Implement invoke(Exact)Method(...) on DefaultBeanAccessor

2012-01-31 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-377?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-377: Attachment: SANDBOX-377.txt I've created a patch for this issue. Summary: * implemented

[jira] [Updated] (SANDBOX-378) [BeanUtils2] Extend StaticMethodsTestCase

2012-01-31 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-378?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-378: Attachment: SANDBOX-378.txt Patch has been attached! [BeanUtils2]

[jira] [Updated] (SANDBOX-379) [BeanUtils2] Implement describe() on DefaultBeanAccessor

2012-02-03 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-379?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-379: Attachment: SANDBOX-379v2.txt Patch modified. Summary: * renamed {{BeanAccessorTestCase}}

[jira] [Updated] (SANDBOX-387) [BeanUtils2] Implement possibility to find out if a property readable and/or wirtable

2012-02-06 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-387?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-387: Attachment: SANDBOX-387.txt Patch for this issue created and attached. I implemented

[jira] [Updated] (SANDBOX-389) [BeanUtils2] Implement populate() on DefaultBeanAccessor

2012-02-07 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-389?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-389: Attachment: SANDBOX-389.txt I've attached a patch: * Implemented {{populate()}} on

[jira] [Updated] (SANDBOX-390) [BeanUtils2] Make sure that the internal package does not get exported when packaging as OSGi bundle

2012-02-07 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-390?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-390: Attachment: SANDBOX-390.txt Patch attached :) [BeanUtils2] Make sure

[jira] [Updated] (SANDBOX-389) [BeanUtils2] Implement populate() on DefaultBeanAccessor

2012-02-10 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-389?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-389: Attachment: SANDBOX-389v2.txt I finally got the time to review and fix my patch. I

[jira] [Updated] (SANDBOX-396) [BeanUtils2] Implement clone() on DefaultBeanAccessor

2012-02-20 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-396?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-396: Attachment: SANDBOX-396.txt I've attached a patch for this issue. There is one thing

[jira] [Updated] (SANDBOX-396) [BeanUtils2] Implement clone() on DefaultBeanAccessor

2012-02-25 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-396?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-396: Attachment: SANDBOX-396v2.txt I've corrected the patch the way you suggested. Regards,

[jira] [Updated] (SANDBOX-397) [BeanUtils2] Replace NullPointerExceptions been thrown in DefaultBeanAccessor with NoSuchMethodEceptions

2012-02-25 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-397: Attachment: SANDBOX-397.txt I have created a patch for this issue. Because there was a

[jira] [Updated] (SANDBOX-397) [BeanUtils2] Replace NullPointerExceptions been thrown in DefaultBeanAccessor with NoSuchMethodEceptions

2012-02-25 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-397: Attachment: SANDBOX-397_SRP.txt I have created another patch, that builds upon the first

[jira] [Updated] (SANDBOX-398) [BeanUtils2] Implement unit tests for BeanUtils.onClassName()

2012-02-26 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-398?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-398: Attachment: SANDBOX-398.txt Patch attached ;) [BeanUtils2] Implement

[jira] [Updated] (SANDBOX-399) [BeanUtils2] Handle methods that return void separatly

2012-02-26 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-399?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-399: Attachment: SANDBOX-399.txt I've implemented {{NullBeanAccessor}} as a special case

[jira] [Updated] (SANDBOX-397) [BeanUtils2] Replace NullPointerExceptions been thrown in DefaultBeanAccessor with NoSuchMethodEceptions

2012-02-26 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-397: Attachment: SANDBOX-397_SRPv2.txt I've thought about the {{Properties}} class some more

[jira] [Updated] (SANDBOX-401) [BeanUtils2] Performance improvement: store hash code of AccessibleObjectDescriptor as member variable

2012-03-02 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-401?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-401: Attachment: SANDBOX-401.txt I've attached a patch. TIA for reviewing ;) Benedikt

[jira] [Updated] (SANDBOX-403) [BeanUtils2] Refactor Unit tests for better readability

2012-03-03 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-403?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-403: Attachment: SANDBOX-403v2.txt While implementing {{CopyPropertiesToTestCase}} I have just

[jira] [Updated] (SANDBOX-405) [BeanUtils2] Implement copyPropertiesTo(T target) on DefaultBeanAccessor

2012-03-03 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-405?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-405: Attachment: SANDBOX-405.txt I've implemented a patch for this issue, but it requires my

[jira] [Updated] (SANDBOX-401) [BeanUtils2] Performance improvement: store hash code of AccessibleObjectDescriptor as member variable

2012-03-05 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/SANDBOX-401?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated SANDBOX-401: Attachment: SANDBOX-401v2.txt Improved! I've also configured my IDE to use wildcard

[jira] [Updated] (CSV-55) Replace while(true)-loop in CSVParser.getRecord() with do-while-loop

2012-03-12 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/CSV-55?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated CSV-55: --- Attachment: CSV-55.txt patch attached ;) Replace while(true)-loop in

[jira] [Updated] (CSV-57) CSVParser.getRecords() contract is confusing

2012-03-13 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/CSV-57?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated CSV-57: --- Attachment: CSV-57.txt Hi, I've created a patch, that does some very minor refactoring: * use for each

[jira] [Updated] (LANG-793) Fix CheckStyle Errors in SerializationUtils

2012-03-13 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/LANG-793?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated LANG-793: - Attachment: LANG-793.txt I have created a patch for this very minor issue. Fix

[jira] [Updated] (CSV-69) Eliminate CSVPrinterTest.equals(String[][], String[][]) by using Assert.assertArrayEquals

2012-03-16 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/CSV-69?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated CSV-69: --- Attachment: CSV-69.patch I've created a patch. Note that CSVParserTest uses

[jira] [Updated] (CSV-71) Add convenience Methods to CSVLexer

2012-03-16 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/CSV-71?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated CSV-71: --- Attachment: CSV-71.patch I've added a patch for this issue. Add convenience Methods to

[jira] [Updated] (CSV-71) Add convenience Methods to CSVLexer

2012-03-16 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/CSV-71?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated CSV-71: --- Attachment: Emmanuels_Performance_Test.patch The one that Emmanuel posted a while ago on the ML. I'm

[jira] [Updated] (CSV-86) Remove current character input parameter from Lexer methods

2012-03-25 Thread Benedikt Ritter (Updated) (JIRA)
[ https://issues.apache.org/jira/browse/CSV-86?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Benedikt Ritter updated CSV-86: --- Attachment: CSV-86.patch I have created a patch. Performance measurements for this patch: * Before: