[PATCH] crypto: drop unnecessary return statements

2017-08-28 Thread Geliang Tang
/marvell/cesa.c:81: FILE: drivers/crypto/ux500/cryp/cryp_core.c:1755: Signed-off-by: Geliang Tang <geliangt...@gmail.com> --- crypto/rmd128.c | 2 -- crypto/rmd160.c | 2 -- crypto/rmd256.c | 2 -- crypto/rm

[PATCH] crypto: mediatek - drop .owner field in mtk_crypto_driver

2017-05-06 Thread Geliang Tang
Drop .owner field in mtk_crypto_driver, since platform_driver_register() will set it automatically. Signed-off-by: Geliang Tang <geliangt...@gmail.com> --- drivers/crypto/mediatek/mtk-platform.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/crypto/mediatek/mtk-platform.c b/d

[PATCH] crypto: ixp4xx - Use sg_virt()

2017-03-23 Thread Geliang Tang
Use sg_virt() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@gmail.com> --- drivers/crypto/ixp4xx_crypto.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/crypto/ixp4xx_crypto.c b/drivers/crypto/ixp4xx_crypto.c index 7868765..771dd26

[PATCH] crypto: nx - drop duplicate header types.h

2016-11-11 Thread Geliang Tang
Drop duplicate header types.h from nx.c. Signed-off-by: Geliang Tang <geliangt...@gmail.com> --- drivers/crypto/nx/nx.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/crypto/nx/nx.c b/drivers/crypto/nx/nx.c index 42f0f22..036057a 100644 --- a/drivers/crypto/nx/nx.c +++ b/d

[PATCH] crypto: jitterentropy - drop duplicate header module.h

2016-11-11 Thread Geliang Tang
Drop duplicate header module.h from jitterentropy-kcapi.c. Signed-off-by: Geliang Tang <geliangt...@gmail.com> --- crypto/jitterentropy-kcapi.c | 1 - 1 file changed, 1 deletion(-) diff --git a/crypto/jitterentropy-kcapi.c b/crypto/jitterentropy-kcapi.c index c4938497..787dccc

[PATCH] crypto: skcipher - remove unused header cpumask.h

2016-06-01 Thread Geliang Tang
Remove unused header cpumask.h from crypto/ablkcipher.c. Signed-off-by: Geliang Tang <geliangt...@gmail.com> --- crypto/ablkcipher.c | 1 - 1 file changed, 1 deletion(-) diff --git a/crypto/ablkcipher.c b/crypto/ablkcipher.c index e5b5721..6b80516 100644 --- a/crypto/ablkcipher.c +++ b/

[PATCH] crypto: hifn_795x, picoxcell - use ablkcipher_request_cast

2015-12-28 Thread Geliang Tang
Use ablkcipher_request_cast() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/crypto/hifn_795x.c| 4 ++-- drivers/crypto/picoxcell_crypto.c | 3 +-- 2 files changed, 3 insertions(+), 4 deletions(-) diff --git a/drivers/crypto/hifn_79

[PATCH] crypto: ccp - use to_pci_dev and to_platform_device

2015-12-23 Thread Geliang Tang
Use to_pci_dev() and to_platform_device() instead of open-coding. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/crypto/ccp/ccp-pci.c | 8 drivers/crypto/ccp/ccp-platform.c | 6 ++ 2 files changed, 6 insertions(+), 8 deletions(-) diff --git a/drivers/cryp

[PATCH v2] crypto: qat - use list_for_each_entry*

2015-12-19 Thread Geliang Tang
Use list_for_each_entry*() instead of list_for_each*() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> --- Changes in v2: - only to qat_crypto.c, and adf_ctl_drv.c. --- drivers/crypto/qat/qat_common/adf_ctl_drv.c | 13 - drivers/crypto/qat/qat_

[PATCH] crypto: qat - use list_for_each_entry*

2015-12-16 Thread Geliang Tang
Use list_for_each_entry*() instead of list_for_each*() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/crypto/qat/qat_common/adf_cfg.c | 35 +++ drivers/crypto/qat/qat_common/adf_ctl_drv.c | 13 +++ drivers/crypto/qat/qat_

[PATCH] crypto: padlock-aes - use offset_in_page macro

2015-11-21 Thread Geliang Tang
Use offset_in_page macro instead of (addr & ~PAGE_MASK). Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/crypto/padlock-aes.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/crypto/padlock-aes.c b/drivers/crypto/padlock-aes.c index da2d67

[PATCH 2/2] crypto: mcryptd - use list_first_entry_or_null()

2015-11-16 Thread Geliang Tang
Simplify mcryptd_opportunistic_flush() with list_first_entry_or_null(). Signed-off-by: Geliang Tang <geliangt...@163.com> --- crypto/mcryptd.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git a/crypto/mcryptd.c b/crypto/mcryptd.c index fe5b495a..f78d4fc

[PATCH 1/2] crypto: api - use list_first_entry_or_null and list_next_entry

2015-11-16 Thread Geliang Tang
Simplify crypto_more_spawns() with list_first_entry_or_null() and list_next_entry(). Signed-off-by: Geliang Tang <geliangt...@163.com> --- crypto/algapi.c | 9 - 1 file changed, 4 insertions(+), 5 deletions(-) diff --git a/crypto/algapi.c b/crypto/algapi.c index 59bf491..7be76aa

[PATCH] crypto: blkcipher and ablkcipher should it be static

2015-09-27 Thread Geliang Tang
-by: Geliang Tang <geliangt...@163.com> --- crypto/skcipher.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/crypto/skcipher.c b/crypto/skcipher.c index dd5fc1b..7591928 100644 --- a/crypto/skcipher.c +++ b/crypto/skcipher.c @@ -91,7 +91,7 @@ stati