Re: [PATCH v5 4/4] crypto: Add Allwinner Security System crypto accelerator

2014-10-20 Thread Vladimir Zapolskiy
Hello LABBE, On 19.10.2014 17:16, LABBE Corentin wrote: > Add support for the Security System included in Allwinner SoC A20. > The Security System is a hardware cryptographic accelerator that support > AES/MD5/SHA1/DES/3DES/PRNG algorithms. > > Signed-off-by: LABBE Corentin > --- > drivers/cry

Re: [PATCH v5 4/4] crypto: Add Allwinner Security System crypto accelerator

2014-10-21 Thread Vladimir Zapolskiy
Hi Corentin, On 21.10.2014 19:25, Corentin LABBE wrote: > On 10/21/14 01:28, Vladimir Zapolskiy wrote: >> Hello LABBE, >> >> On 19.10.2014 17:16, LABBE Corentin wrote: >>> Add support for the Security System included in Allwinner SoC A20. >>> The Secu

Re: [PATCH 1/2] crypto: Add Imagination Technologies hw hash accelerator

2014-11-10 Thread Vladimir Zapolskiy
Hello James, On 10.11.2014 14:10, James Hartley wrote: > This adds support for the Imagination Technologies hash > accelerator that provides hardware acceleration for > SHA1 SHA224 SHA256 and MD5 Hashes. > > Signed-off-by: James Hartley > --- [snip] > diff --git a/drivers/crypto/img-hash.c b/d

Re: [PATCH 1/2] crypto: Add Imagination Technologies hw hash accelerator

2014-11-11 Thread Vladimir Zapolskiy
Hi James, On 11.11.2014 16:59, James Hartley wrote: > Hi Vladimir, thanks for the review! > >> -Original Message----- >> From: Vladimir Zapolskiy [mailto:vladimir_zapols...@mentor.com] >> Sent: 10 November 2014 15:10 >> To: James Hartley; herb...@gondor.apa

Re: [PATCH v5] crypto: s5p-sss: Add HASH support for Exynos

2017-10-12 Thread Vladimir Zapolskiy
Hello Kamil, thank you for the change, please find below a number of minor review comments. On 10/09/2017 02:12 PM, Kamil Konieczny wrote: > Add support for MD5, SHA1, SHA256 hash algorithms for Exynos HW. > It uses the crypto framework asynchronous hash api. > It is based on omap-sham.c driver.

Re: [PATCH v7 2/2] crypto: s5p-sss: Add HASH support for Exynos

2017-10-22 Thread Vladimir Zapolskiy
Hi Kamil, thank you for updates, I have just a few more comments. On 10/17/2017 02:28 PM, Kamil Konieczny wrote: > Add support for MD5, SHA1, SHA256 hash algorithms for Exynos HW. > It uses the crypto framework asynchronous hash api. > It is based on omap-sham.c driver. > S5P has some HW differen

Re: [PATCH v7 1/2] crypto: s5p-sss: change spaces into tabs in defines

2017-10-22 Thread Vladimir Zapolskiy
Hi Kamil, On 10/17/2017 02:28 PM, Kamil Konieczny wrote: > change spaces into tabs in defines Here a grammatically correct sentence in English is welcome. > > Signed-off-by: Kamil Konieczny > --- Please feel free to add a tag Acked-by: Vladimir Zapolskiy -- With best wishes, Vladimir

Re: [PATCH v7 1/2] crypto: s5p-sss: change spaces into tabs in defines

2017-10-24 Thread Vladimir Zapolskiy
Hi Kamil, On 10/24/2017 01:19 PM, Kamil Konieczny wrote: > Hi Vladimir, > > Thank you for review. > > On 22.10.2017 12:18, Vladimir Zapolskiy wrote: >> Hi Kamil, >> >> On 10/17/2017 02:28 PM, Kamil Konieczny wrote: >>> change spaces into tabs in

Re: [PATCH v7 2/2] crypto: s5p-sss: Add HASH support for Exynos

2017-10-24 Thread Vladimir Zapolskiy
l apply almost all of your remarks, > see answers below. > > On 22.10.2017 12:18, Vladimir Zapolskiy wrote: >> Hi Kamil, >> >> thank you for updates, I have just a few more comments. >> [snip] >>> +/** >>> + * s5p_hash_import - import hash state

[PATCH] crypto: ux500: fix checks of error code returned by devm_ioremap_resource()

2016-03-05 Thread Vladimir Zapolskiy
The change fixes potential oops while accessing iomem on invalid address, if devm_ioremap_resource() fails due to some reason. The devm_ioremap_resource() function returns ERR_PTR() and never returns NULL, which makes useless a following check for NULL. Signed-off-by: Vladimir Zapolskiy Fixes

[PATCH] crypto: atmel: fix checks of error code returned by devm_ioremap_resource()

2016-03-05 Thread Vladimir Zapolskiy
The change fixes potential oops while accessing iomem on invalid address, if devm_ioremap_resource() fails due to some reason. The devm_ioremap_resource() function returns ERR_PTR() and never returns NULL, which makes useless a following check for NULL. Signed-off-by: Vladimir Zapolskiy Fixes

Re: [PATCH 1/2] crypto: s5p-sss - Minor coding cleanups

2016-03-06 Thread Vladimir Zapolskiy
5000+ goto labels one day, though it is better to have an officially agreed policy beforehand. Anyway I do not strictly object against the change, see one my comment below and feel free to add my Acked-by: Vladimir Zapolskiy > Signed-off-by: Krzysztof Kozlowski > --- > drivers/c

Re: [PATCH 2/2] crypto: s5p-sss - Handle unaligned buffers

2016-03-06 Thread Vladimir Zapolskiy
like s5p-sss etc. Anyway since it is a valid improvement, please feel free to add my Acked-by: Vladimir Zapolskiy > Signed-off-by: Krzysztof Kozlowski > --- > drivers/crypto/s5p-sss.c | 149 > +++ > 1 file changed, 137 insertio

Re: [PATCH 1/2] crypto: s5p-sss - Minor coding cleanups

2016-03-09 Thread Vladimir Zapolskiy
Hi Krzysztof, On 07.03.2016 06:05, Krzysztof Kozlowski wrote: > On 07.03.2016 10:01, Vladimir Zapolskiy wrote: >> Hi Krzysztof, >> >> On 06.03.2016 12:17, Krzysztof Kozlowski wrote: >>> Remove unneeded inclusion of delay.h and get rid of indentation from >>

Re: [PATCH v2 3/3] hwrng: mxc-fsl - add support for Freescale RNGC

2016-03-11 Thread Vladimir Zapolskiy
On 11.03.2016 16:06, Steffen Trumtrar wrote: > The driver is ported from Freescales Linux git and can be > found in the > > vendor/freescale/imx_2.6.35_maintain > > branch. > > According to that code, the RNGC is found on Freescales i.MX3/5 SoCs. > The i.MX2x actually has an RNGB, which ha

Re: [PATCH] crypto: s5p-sss - Enable COMPILE_TEST

2016-03-14 Thread Vladimir Zapolskiy
_S5PV210 || ARCH_EXYNOS || COMPILE_TEST > + depends on HAS_IOMEM && HAS_DMA > select CRYPTO_AES > select CRYPTO_BLKCIPHER > help > Acked-by: Vladimir Zapolskiy -- With best wishes, Vladimir -- To unsubscribe from this list: send the line "u

Re: [PATCH v2 3/3] crypto: s5p-sss - Sort the headers to improve readability

2016-03-14 Thread Vladimir Zapolskiy
On 10.03.2016 03:31, Krzysztof Kozlowski wrote: > Sort the headers alphabetically to improve readability and to spot > duplications easier. > > Suggested-by: Vladimir Zapolskiy > Signed-off-by: Krzysztof Kozlowski > > --- > > Changes since v1: > 1. New patch.

Re: How to detect availability of asynchronous ciphers at runtime?

2016-03-26 Thread Vladimir Zapolskiy
On 26.03.2016 20:06, Jeffrey Walton wrote: > Hi Everyone, > > Please forgive my ignorance here... I'm trying to detect the > availability of asynchronous ciphers support at runtime. The back > story is there's some feature tests going on based on hard coded > kernel version numbers (namely, 4.1).

Re: [PATCH 2/2] crypto: s5p-sss - Remove useless hash interrupt handler

2016-04-20 Thread Vladimir Zapolskiy
ash interrupt bit. > > Driver does not provide hash functions so it is safe to remove the hash > interrupt related code and to not require the interrupt in Device Tree. > > Signed-off-by: Krzysztof Kozlowski Thank you for the change. Acked-by: Vladimir Zapolskiy > --- >

Re: [PATCH 1/2] crypto: s5p-sss - Fix use after free of copied input buffer in error path

2016-04-20 Thread Vladimir Zapolskiy
rt have just applied the changes, but anyway I reviewed them and they are good in my opinion. Acked-by: Vladimir Zapolskiy > --- > drivers/crypto/s5p-sss.c | 1 - > 1 file changed, 1 deletion(-) > > diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5p-sss.c > index 4

Re: [PATCH] crypto: s5p-sss: fix incorrect usage of scatterlists api

2016-04-26 Thread Vladimir Zapolskiy
rypto: s5p-sss - add S5PV210 advanced crypto engine > support") > Fixes: 9e4a1100a445 ("crypto: s5p-sss - Handle unaligned buffers") > Cc: > Signed-off-by: Marek Szyprowski Acked-by: Vladimir Zapolskiy thank you for the fix. -- With best wishes, Vladimir -- To unsubsc

Re: [PATCH] crypto: s5p-sss - Use consistent indentation for variables and members

2016-05-28 Thread Vladimir Zapolskiy
g usage of such indentation and lack of it. >When removing indentation, reorder variables in >reversed-christmas-tree order with first variables being initialized >ones. > > Signed-off-by: Krzysztof Kozlowski it looks like a trivial and nice change, thank you. Acked-by: Vla

Re: [PATCH] MAINTAINERS: Add Krzysztof Kozlowski as maintainer of crypto/s5p-sss

2017-03-10 Thread Vladimir Zapolskiy
Hi Krzysztof, On 03/10/2017 09:10 PM, Krzysztof Kozlowski wrote: > Beside developing of this driver recently, I handle also reviews and > bug reports from users so having a maintainer entry will ensure that I > will be CC-ed on important emails. if you assume that the driver needs a special maint

Re: [PATCH v2] MAINTAINERS: Add maintianer entry for crypto/s5p-sss

2017-03-11 Thread Vladimir Zapolskiy
On 03/11/2017 08:11 AM, Krzysztof Kozlowski wrote: > Add Krzysztof Kozlowski and Vladimir Zapolskiy as maintainers of s5p-sss > driver for handling reviews, testing and getting bug reports from the > users. > > Cc: Vladimir Zapolskiy > Cc: Herbert Xu > Signed-off-by

crypto_alg and alignment

2011-04-01 Thread Vladimir Zapolskiy
Hello Herbert, I'm trying to implement a driver for one hardware crypto engine, and on the current stage I work with AES algorithm, and I have a couple of open questions. 1) What shall be guaranteed from crypto engine by providing cra_blocksize and cra_alignmask values in crypto_alg definition

[PATCH] crypto: add S5PV210 advanced crypto engine support.

2011-04-02 Thread Vladimir Zapolskiy
This change adds support for AES encrypting and decrypting using advanced crypto engine found on Samsung S5PV210 and S5PC110 SoCs. Signed-off-by: Vladimir Zapolskiy --- drivers/crypto/Kconfig | 11 + drivers/crypto/Makefile |1 + drivers/crypto/s5p-sss.c | 701

Re: [PATCH] crypto: convert drivers/crypto/* to use module_platform_driver()

2011-11-26 Thread Vladimir Zapolskiy
On 26.11.2011 15:26, Axel Lin wrote: > This patch converts the drivers in drivers/crypto/* to use the > module_platform_driver() macro which makes the code smaller and a bit > simpler. > > Cc: James Hsiao > Cc: Sebastian Andrzej Siewior > Cc: Vladimir Zapolskiy > Cc: Jamie

Re: [PATCH 13/14] crypto: drivers - remove cra_list initialization

2012-07-17 Thread Vladimir Zapolskiy
perform cleanup to remove all unneeded initializations of this field in 'crypto/drivers/'. Cc: Kent Yoder Cc: Benjamin Herrenschmidt Cc: linux-ge...@lists.infradead.org Cc: Michal Ludvig Cc: Dmitry Kasatkin Cc: Varun Wadekar Cc: Vladimir Zapolskiy Cc: Eric Bénard Signed-off-by: Jussi Kivilin

Re: [PATCH 2/2] crypto: s5p-sss: remove unnecessary platform_set_drvdata()

2013-05-09 Thread Vladimir Zapolskiy
ata->clk); s5p_dev = NULL; - platform_set_drvdata(pdev, NULL); return 0; } Acked-by: Vladimir Zapolskiy -- With best wishes, Vladimir -- To unsubscribe from this list: send the line "unsubscribe linux-crypto" in the body of a message to majord...@vger

Re: [PATCH 3/8 v3] crypto:s5p-sss: Add support for SSS module on Exynos

2014-01-13 Thread Vladimir Zapolskiy
) for which 1. AES register are at an offset of 0x200 and 2. hash interrupt is not available Signed-off-by: Naveen Krishna Ch CC: Herbert Xu CC: David S. Miller CC: Vladimir Zapolskiy TO: CC: --- Changes since v2: 1. Added variant struct to handle the differences in SSS modules 2. Changed the

Re: [PATCH 0/7 v8] crypto:s5p-sss: Add Device tree and Exynos support

2014-04-30 Thread Vladimir Zapolskiy
ged in. Its has got reviewed and re-based several times and got acked by a couple of seniors. Do you want me to pick these series up? Cheers, thank you for this changeset, in my opinion it is quite good. To all changes Acked-by: Vladimir Zapolskiy -- With best wishes, Vladimir -- To unsubs

[PATCH 2/2] hwrng: mxc-rnga - add driver support on boards with device tree

2018-02-26 Thread Vladimir Zapolskiy
The driver works well on i.MX31 powered boards with device description taken from board device tree, the only change to add to the driver is the missing OF device id, the affected list of included headers and platform driver struct are beautified a little. Signed-off-by: Vladimir Zapolskiy

[PATCH 0/2] hwrng: mxc-rnga - add driver support on boards with device tree

2018-02-26 Thread Vladimir Zapolskiy
The series is a trivial change to extend Freescale i.MX31 RNGA driver to work on boards with device description taken from device tree blob. The change was tested on a legacy LogicPD MX31Lite board. Vladimir Zapolskiy (2): dt-bindings: rng: Document Freescale i.MX31 RNGA compatible hwrng: mxc

[PATCH 1/2] dt-bindings: rng: Document Freescale i.MX31 RNGA compatible

2018-02-26 Thread Vladimir Zapolskiy
the documentation file has no more potential for further extensions, nevertheless generalize it by removing explicit RNGC specifics. Signed-off-by: Vladimir Zapolskiy --- .../devicetree/bindings/rng/{imx-rngc.txt => imx-rng.txt} | 10 -- 1 file changed, 4 insertions(+), 6 deleti

Re: [PATCH 2/2] hwrng: mxc-rnga - add driver support on boards with device tree

2018-02-27 Thread Vladimir Zapolskiy
On 02/27/2018 05:49 PM, Kim Phillips wrote: > On Mon, 26 Feb 2018 20:38:49 +0200 > Vladimir Zapolskiy wrote: > >> +#ifdef CONFIG_OF >> +static const struct of_device_id mxc_rnga_of_match[] = { >> +{ .compatible = "fsl,imx31-rnga", }, >> +{ /* se

Re: [PATCH 2/2] hwrng: mxc-rnga - add driver support on boards with device tree

2018-02-27 Thread Vladimir Zapolskiy
On 02/27/2018 09:39 PM, Kim Phillips wrote: > On Tue, 27 Feb 2018 18:53:08 +0200 > Vladimir Zapolskiy wrote: > >> On 02/27/2018 05:49 PM, Kim Phillips wrote: >>> On Mon, 26 Feb 2018 20:38:49 +0200 >>> Vladimir Zapolskiy wrote: >>> >>>> +#

Re: [PATCH 2/2] hwrng: mxc-rnga - add driver support on boards with device tree

2018-03-01 Thread Vladimir Zapolskiy
On 02/27/2018 10:07 PM, Vladimir Zapolskiy wrote: > On 02/27/2018 09:39 PM, Kim Phillips wrote: >> On Tue, 27 Feb 2018 18:53:08 +0200 >> Vladimir Zapolskiy wrote: >> >>> On 02/27/2018 05:49 PM, Kim Phillips wrote: >>>> On Mon, 26 Feb 2018 20:

[PATCH v2 0/2] hwrng: mxc-rnga - add driver support on boards with device tree

2018-03-05 Thread Vladimir Zapolskiy
The series is a trivial change to extend Freescale i.MX31 RNGA driver to work on boards with device description taken from device tree blob. The change was tested on a legacy LogicPD MX31Lite board. Vladimir Zapolskiy (2): dt-bindings: rng: Document Freescale i.MX21 and i.MX31 RNGA compatibles

[PATCH v2 2/2] hwrng: mxc-rnga - add driver support on boards with device tree

2018-03-05 Thread Vladimir Zapolskiy
The driver works well on i.MX31 powered boards with device description taken from board device tree, the only change to add to the driver is the missing OF device id, the affected list of included headers and indentation in platform driver struct are beautified a little. Signed-off-by: Vladimir

[PATCH v2 1/2] dt-bindings: rng: Document Freescale i.MX21 and i.MX31 RNGA compatibles

2018-03-05 Thread Vladimir Zapolskiy
, apparently the documentation file has no more potential for further extensions, nevertheless generalize it by removing explicit RNGC specifics. Signed-off-by: Vladimir Zapolskiy Reviewed-by: Rob Herring --- Changes from v1 to v2: * added i.MX21 RNGA compatible, i.MX31 RNGA is backward compatible to it

Re: [PATCH v2 2/2] hwrng: mxc-rnga - add driver support on boards with device tree

2018-03-05 Thread Vladimir Zapolskiy
Hi Fabio, On 03/06/2018 12:24 AM, Fabio Estevam wrote: > Hi Vladimir, > > On Mon, Mar 5, 2018 at 7:21 PM, Vladimir Zapolskiy wrote: >> The driver works well on i.MX31 powered boards with device description >> taken from board device tree, the only change to add to the dri

Re: [PATCH] MAINTAINERS: crypto: s5p-sss: drop Kamil Konieczny

2020-12-07 Thread Vladimir Zapolskiy
for S5P Security Subsystem crypto accelerator. Signed-off-by: Krzysztof Kozlowski Acked-by: Vladimir Zapolskiy -- Best wishes, Vladimir

Re: [PATCH v3 4/5] amba: Make the remove callback return void

2021-01-27 Thread Vladimir Zapolskiy
Acked-by: Dmitry Torokhov Acked-by: Linus Walleij Signed-off-by: Uwe Kleine-König For drivers/memory/pl172.c: Acked-by: Vladimir Zapolskiy -- Best wishes, Vladimir