Re: [PATCH 1/2] fs: Fix indentation in do_path_lookup

2007-05-06 Thread Christoph Hellwig
On Sat, May 05, 2007 at 06:59:39PM -0400, Josef 'Jeff' Sipek wrote: Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/fs/namei.c b/fs/namei.c index 0262594..600a4e7 100644 --- a/fs/namei.c +++

Re: [PATCH 2/2] fs: Use path_walk in do_path_lookup

2007-05-06 Thread Christoph Hellwig
On Sat, May 05, 2007 at 06:59:40PM -0400, Josef 'Jeff' Sipek wrote: Since, path_walk sets the total_link_count to 0, and calls link_path_walk, we can just call path_walk directly. Ok. - To unsubscribe from this list: send the line unsubscribe linux-fsdevel in the body of a message to [EMAIL

Re: [PATCH 1/4] fs: Introduce path_component_lookup

2007-05-06 Thread Christoph Hellwig
I wrote up the suggestion before my first morning tea yesterday and must admit that the name path_component_lookup is pretty stupid. We don't just look up a component but any relative path starting from the vfsmount/dentry pair. How about vfs_path_lookup instead because it mirrors various other

Re: [PATCH 4/4] fs: Remove path_walk export

2007-05-06 Thread Christoph Hellwig
On Sat, May 05, 2007 at 07:09:34PM -0400, Josef 'Jeff' Sipek wrote: Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c |1 - 1 files changed, 0 insertions(+), 1 deletions(-) it should be possible to make it static now aswell. (the uml code using it is #if0'ed and will

cifs review reminder

2007-05-06 Thread Christoph Hellwig
Steve, any chance to please send cifs uodates to -fsdevel before sending them to Linus? A lot of the cifs code really would benefit from some review. - To unsubscribe from this list: send the line unsubscribe linux-fsdevel in the body of a message to [EMAIL PROTECTED] More majordomo info at

Re: [PATCH 1/1] sunrpc: Use path_component_lookup

2007-05-06 Thread Trond Myklebust
On Sat, 2007-05-05 at 20:52 -0400, Josef 'Jeff' Sipek wrote: use path_component_lookup instead of open-coding the necessary functionality. Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- net/sunrpc/rpc_pipe.c | 16 +++- 1 files changed, 7 insertions(+), 9

[PATCH] fs: Fix indentation in do_path_lookup

2007-05-06 Thread Josef 'Jeff' Sipek
Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c |6 ++ 1 files changed, 2 insertions(+), 4 deletions(-) diff --git a/fs/namei.c b/fs/namei.c index 0262594..48078ea 100644 --- a/fs/namei.c +++ b/fs/namei.c @@ -1156,11 +1156,9 @@ static int fastcall do_path_lookup(int

Re: [PATCH] fs: Fix indentation in do_path_lookup

2007-05-06 Thread Christoph Hellwig
On Sun, May 06, 2007 at 11:30:28AM -0400, Josef 'Jeff' Sipek wrote: + if (unlikely(!retval !audit_dummy_context() nd + nd-dentry nd-dentry-d_inode)) the check for nd is not needed either as I hopefully mentioned in my last mail. - To unsubscribe from this

Re: [PATCH 1/2] fs: Fix indentation in do_path_lookup

2007-05-06 Thread Josef Sipek
On Sun, May 06, 2007 at 12:11:24PM +0100, Christoph Hellwig wrote: On Sat, May 05, 2007 at 06:59:39PM -0400, Josef 'Jeff' Sipek wrote: Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git

Re: [PATCH 1/2] fs: Fix indentation in do_path_lookup

2007-05-06 Thread Christoph Hellwig
On Sun, May 06, 2007 at 12:43:23PM -0400, Josef Sipek wrote: On Sun, May 06, 2007 at 12:11:24PM +0100, Christoph Hellwig wrote: On Sat, May 05, 2007 at 06:59:39PM -0400, Josef 'Jeff' Sipek wrote: Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c |2 +- 1 files

[PATCH 1/5] fs: Introduce vfs_path_lookup

2007-05-06 Thread Josef 'Jeff' Sipek
Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c| 32 include/linux/namei.h |2 ++ 2 files changed, 34 insertions(+), 0 deletions(-) diff --git a/fs/namei.c b/fs/namei.c index 3449e0a..090cce4 100644 --- a/fs/namei.c +++

[PATCH 5/5] fs: Remove path_walk export

2007-05-06 Thread Josef 'Jeff' Sipek
Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c|3 +-- include/linux/namei.h |1 - 2 files changed, 1 insertions(+), 3 deletions(-) diff --git a/fs/namei.c b/fs/namei.c index d9eb621..7a98676 100644 --- a/fs/namei.c +++ b/fs/namei.c @@ -1026,7 +1026,7 @@

[PATCH 2/5] sunrpc: Use vfs_path_lookup

2007-05-06 Thread Josef 'Jeff' Sipek
use vfs_path_lookup instead of open-coding the necessary functionality. Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] Acked-by: Trond Myklebust [EMAIL PROTECTED] --- net/sunrpc/rpc_pipe.c | 16 +++- 1 files changed, 7 insertions(+), 9 deletions(-) diff --git

[PATCH 0/2] [TRIVIAL] Small cleanups for do_path_lookup (V2)

2007-05-06 Thread Josef 'Jeff' Sipek
(For changes since V1, see the end of this email.) The following 2 patches are trivial cleanups to do_path_lookup in namei.c. Since these changes are trivial, they can go into 2.6.22-rc1 without any problems. Josef 'Jeff' Sipek (2): fs: Fix indentation in do_path_lookup fs: Use

[PATCH 2/2] fs: Use path_walk in do_path_lookup

2007-05-06 Thread Josef 'Jeff' Sipek
Since, path_walk sets the total_link_count to 0, and calls link_path_walk, we can just call path_walk directly. Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/fs/namei.c b/fs/namei.c index

[PATCH 1/2] fs: Fix indentation in do_path_lookup

2007-05-06 Thread Josef 'Jeff' Sipek
Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c |4 +--- 1 files changed, 1 insertions(+), 3 deletions(-) diff --git a/fs/namei.c b/fs/namei.c index 7a98676..2a5c232 100644 --- a/fs/namei.c +++ b/fs/namei.c @@ -1159,11 +1159,9 @@ static int fastcall do_path_lookup(int dfd,

Re: [PATCH 1/5] fs: Introduce vfs_path_lookup

2007-05-06 Thread Christoph Hellwig
On Sun, May 06, 2007 at 01:41:25PM -0400, Josef 'Jeff' Sipek wrote: Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c| 32 include/linux/namei.h |2 ++ 2 files changed, 34 insertions(+), 0 deletions(-) Looks good to me. -

Re: [PATCH 3/5] nfsctl: Use vfs_path_lookup

2007-05-06 Thread Christoph Hellwig
On Sun, May 06, 2007 at 01:41:27PM -0400, Josef 'Jeff' Sipek wrote: use vfs_path_lookup instead of open-coding the necessary functionality. Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/nfsctl.c | 15 +-- 1 files changed, 5 insertions(+), 10 deletions(-) diff

Re: [PATCH 4/5] fs: Mark link_path_walk static

2007-05-06 Thread Christoph Hellwig
On Sun, May 06, 2007 at 01:41:28PM -0400, Josef 'Jeff' Sipek wrote: +/* forward declaration */ +static int fastcall link_path_walk(const char *name, struct nameidata *nd); I don't think we need that comment, otherwise this looks good. - To unsubscribe from this list: send the line unsubscribe

Re: [PATCH 5/5] fs: Remove path_walk export

2007-05-06 Thread Christoph Hellwig
On Sun, May 06, 2007 at 01:41:29PM -0400, Josef 'Jeff' Sipek wrote: Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c|3 +-- include/linux/namei.h |1 - 2 files changed, 1 insertions(+), 3 deletions(-) Ok. - To unsubscribe from this list: send the line

Re: [PATCH 0/2] [TRIVIAL] Small cleanups for do_path_lookup (V2)

2007-05-06 Thread Christoph Hellwig
On Sun, May 06, 2007 at 01:47:54PM -0400, Josef 'Jeff' Sipek wrote: (For changes since V1, see the end of this email.) The following 2 patches are trivial cleanups to do_path_lookup in namei.c. Since these changes are trivial, they can go into 2.6.22-rc1 without any problems. Josef 'Jeff'

[PATCH 4/5] fs: Mark link_path_walk static

2007-05-06 Thread Josef 'Jeff' Sipek
Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/namei.c|4 +++- include/linux/namei.h |1 - 2 files changed, 3 insertions(+), 2 deletions(-) diff --git a/fs/namei.c b/fs/namei.c index 090cce4..925c62e 100644 --- a/fs/namei.c +++ b/fs/namei.c @@ -108,6 +108,8 @@ *

[PATCH 1/1] nfsctl: Use vfs_path_lookup

2007-05-06 Thread Josef 'Jeff' Sipek
use vfs_path_lookup instead of open-coding the necessary functionality. Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] --- fs/nfsctl.c | 16 ++-- 1 files changed, 6 insertions(+), 10 deletions(-) diff --git a/fs/nfsctl.c b/fs/nfsctl.c index c043136..51f1b31 100644 ---

Re: patch: VFS: fix passing of AT_PHDR value in auxv to ELF interpreter

2007-05-06 Thread Quentin Godfroy
On Fri, May 04, 2007 at 09:24:05PM -0700, Jeremy Fitzhardinge wrote: Indeed, I haven't seen that. For ET_DYN executables, it could be done a thing like load_addr+elf_ppnt-p_vaddr (in the function that creates the auxv, as ity has access to the elf header), and for ET_EXEC do what I

Re: [NFS] [PATCH 0/18] export operations rewrite

2007-05-06 Thread Neil Brown
On Friday May 4, [EMAIL PROTECTED] wrote: On Tuesday May 1, [EMAIL PROTECTED] wrote: - the calling conversion on the decode side where we first call -decode_fh to split the filehandle into two blobs only to recurse back into exportfs and then recurse back into the filesystem

Re: [NFS] [PATCH 0/18] export operations rewrite

2007-05-06 Thread Neil Brown
On Monday May 7, [EMAIL PROTECTED] wrote: Would you be able to respin that second patch series with one of those changes? Of course it is actually the first series of patches that introduces this problem. So maybe just a full respin?? Thanks, NeilBrown - To unsubscribe from this list: send

Re: ChunkFS - measuring cross-chunk references

2007-05-06 Thread Valerie Henson
On Mon, Apr 23, 2007 at 02:53:33PM -0600, Andreas Dilger wrote: Also, is it considered a cross-chunk reference if a directory entry is referencing an inode in another group? Should there be a continuation inode in the local group, or is the directory entry itself enough? (Sorry for the

Re: ChunkFS - measuring cross-chunk references

2007-05-06 Thread Valerie Henson
On Mon, Apr 23, 2007 at 02:05:47AM +0530, Karuna sagar K wrote: Hi, The attached code contains program to estimate the cross-chunk references for ChunkFS file system (idea from Valh). Below are the results: Nice work! Thank you very much for doing this! -VAL - To unsubscribe from this

Re: [PATCH 1/1] nfsctl: Use vfs_path_lookup

2007-05-06 Thread Neil Brown
On Sunday May 6, [EMAIL PROTECTED] wrote: use vfs_path_lookup instead of open-coding the necessary functionality. Signed-off-by: Josef 'Jeff' Sipek [EMAIL PROTECTED] Acked-by: NeilBrown [EMAIL PROTECTED] Thanks, NeilBrown --- fs/nfsctl.c | 16 ++-- 1 files changed, 6

Re: ChunkFS - measuring cross-chunk references

2007-05-06 Thread Valerie Henson
On Mon, Apr 23, 2007 at 08:13:06PM -0400, Theodore Tso wrote: There may also be special things we will need to do to handle scenarios such as BackupPC, where if it looks like a directory contains a huge number of hard links to a particular chunk, we'll need to make sure that directory is