Re: [PATCH v2] Input: soc_button_array: Remove kfree on data allocated with devm_zalloc

2014-07-28 Thread pramod gurav
Hi Dmitry, Thanks for the review. On Fri, Jul 25, 2014 at 9:52 PM, Dmitry Torokhov dmitry.torok...@gmail.com wrote: Hi Pramod, On Fri, Jul 25, 2014 at 05:04:34PM +0530, pramod.gurav@gmail.com wrote: From: Pramod Gurav pramod.gu...@smartplayin.com This patch does below: - Removes kfree

Re: [PATCH v2] Input: soc_button_array: Remove kfree on data allocated with devm_zalloc

2014-07-28 Thread Dmitry Torokhov
On July 27, 2014 11:50:41 PM PDT, pramod gurav pramod.gurav@gmail.com wrote: Hi Dmitry, Thanks for the review. On Fri, Jul 25, 2014 at 9:52 PM, Dmitry Torokhov dmitry.torok...@gmail.com wrote: Hi Pramod, On Fri, Jul 25, 2014 at 05:04:34PM +0530, pramod.gurav@gmail.com wrote: From:

Re: [PATCH v2] Input: soc_button_array: Remove kfree on data allocated with devm_zalloc

2014-07-28 Thread pramod gurav
On Mon, Jul 28, 2014 at 12:40 PM, Dmitry Torokhov dmitry.torok...@gmail.com wrote: On July 27, 2014 11:50:41 PM PDT, pramod gurav pramod.gurav@gmail.com wrote: Hi Dmitry, No need to resend, I picked out the good bits and applied. Thanks. :) -- Thanks and Regards Pramod -- To

Re: [PATCH] hid: uhid.c: Cleaning up missing null-terminate in conjunction with strncpy

2014-07-28 Thread David Herrmann
Hi On Sat, Jul 26, 2014 at 6:46 PM, Rickard Strandqvist rickard_strandqv...@spectrumdigital.se wrote: Replacing strncpy with strlcpy to avoid strings that lacks null terminate. And removed unnecessary magic numbers. Signed-off-by: Rickard Strandqvist rickard_strandqv...@spectrumdigital.se

[PATCH] input: ads7846: Switch to managed version of kzalloc and cleanups

2014-07-28 Thread pramod . gurav . etc
From: Pramod Gurav pramod.gu...@smartplayin.com This switches memory allocations from kzalloc to devm_kzalloc. This also changes the way return checks were done on failure cases of three allocations. The checks were clubbed together and hence must be done seperately to avoid calling kfree on

Re: [PATCH v7 0/5] Input: pixcir_i2c_ts: Add Type-B Multi-touch and DT support

2014-07-28 Thread Roger Quadros
Hi Dmitry, Gentle ping. Would be nice to get these into 3.17. Thanks :). cheers, -roger On 07/03/2014 12:34 PM, Roger Quadros wrote: Hi Dmitry, Gentle reminder to pick this series for -next. Thanks :). cheers, -roger On 06/17/2014 12:31 PM, Roger Quadros wrote: Hi Dmitry, These

[PATCH 1/7] mfd: cros_ec: Delay for 50ms when we see EC_CMD_REBOOT_EC

2014-07-28 Thread Javier Martinez Canillas
From: Doug Anderson diand...@chromium.org If someone sends a EC_CMD_REBOOT_EC to the EC, the EC will likely be unresponsive for quite a while. Add a delay to the end of the command to prevent random failures of future commands. NOTES: * This could be optimized a bit by simply delaying the next

[PATCH 3/7] mfd: cros_ec: stop calling -cmd_xfer() directly

2014-07-28 Thread Javier Martinez Canillas
From: Andrew Bresticker abres...@chromium.org Instead of having users of the ChromeOS EC call the interface-specific cmd_xfer() callback directly, introduce a central cros_ec_cmd_xfer() to use instead. This will allow us to put all the locking and retry logic in one place instead of duplicating

[PATCH 4/7] mfd: cros_ec: move locking into cros_ec_cmd_xfer

2014-07-28 Thread Javier Martinez Canillas
From: Andrew Bresticker abres...@chromium.org Now that there's a central cros_ec_cmd_xfer(), move the locking out of the SPI and LPC drivers. Signed-off-by: Andrew Bresticker abres...@chromium.org Reviewed-by: Simon Glass s...@chromium.org --- drivers/mfd/cros_ec.c | 10 +-

[PATCH 5/7] mfd: cros_ec: wait for completion of commands that return IN_PROGRESS

2014-07-28 Thread Javier Martinez Canillas
From: Andrew Bresticker abres...@chromium.org When an EC command returns EC_RES_IN_PROGRESS, we need to query the state of the EC until it indicates that it is no longer busy. Do this in cros_ec_cmd_xfer() under the EC's mutex so that other commands (e.g. keyboard, I2C passtru) aren't issued to

[PATCH 2/7] i2c: i2c-cros-ec-tunnel: Set retries to 3

2014-07-28 Thread Javier Martinez Canillas
From: Derek Basehore dbaseh...@chromium.org Since the i2c bus can get wedged on the EC sometimes, set the number of retries to 3. Since we un-wedge the bus immediately after the wedge happens, this is the correct fix since only one transfer will fail. Signed-off-by: Derek Basehore

[PATCH 0/7] Second batch of cleanups for cros_ec

2014-07-28 Thread Javier Martinez Canillas
This is a second batch of cleanups patches for the mfd cros_ec driver and its subdevices drivers. The first batch of cleanups was posted by Doug Anderson [0] and have already been merged. The patches were picked from the ChromeOS 3.8 kernel and after these no cleanups patches for cros_ec are left,

[PATCH 6/7] mfd: cros_ec: Instantiate sub-devices from device tree

2014-07-28 Thread Javier Martinez Canillas
From: Todd Broch tbr...@chromium.org If the EC device tree node has sub-nodes, try to instantiate them as MFD sub-devices. We can configure the EC features provided by the board. Signed-off-by: Todd Broch tbr...@chromium.org --- drivers/mfd/cros_ec.c | 40

[PATCH 7/7] Input: cros_ec_keyb: Optimize ghosting algorithm.

2014-07-28 Thread Javier Martinez Canillas
From: Todd Broch tbr...@chromium.org Previous algorithm was a bit conservative and complicating with respect to identifying key ghosting. This CL uses the bitops hamming weight function (hweight8) to count the number of matching rows for colM colN. If that number is 1 ghosting is present.

Re: [PATCHES v2] Add support for more Huion tablets

2014-07-28 Thread Benjamin Tissoires
On Wed, Jul 23, 2014 at 12:31 PM, Nikolai Kondrashov spbn...@gmail.com wrote: Hi everyone, This is the second version of the patch set adding support for more Huion tablets [1]. This version has the hid: huion: Invert in-range on specific product patch removed as requested by Benjamin

Re: Linux 3.16-rc6

2014-07-28 Thread Waiman Long
On 07/25/2014 12:10 PM, Peter Zijlstra wrote: On Thu, Jul 24, 2014 at 04:38:28PM -0400, Waiman Long wrote: Yes, I think I may have a solution for that. Borislav, can you apply the following patch on top of the lockdep patch to see if it can fix the problem? diff --git

Re: Linux 3.16-rc6

2014-07-28 Thread Peter Zijlstra
On Mon, Jul 28, 2014 at 12:37:14PM -0400, Waiman Long wrote: I am planning to take out the check in check_deadlock and only have the test in lock_acquire which change a 3 to 2 when in interrupt context. Now my question is whether to do it as a new patch on top of the existing one in tip or a

Re: [PATCH] input: ads7846: Switch to managed version of kzalloc and cleanups

2014-07-28 Thread Dmitry Torokhov
Hi Pramod, On Mon, Jul 28, 2014 at 02:16:55PM +0530, pramod.gurav@gmail.com wrote: From: Pramod Gurav pramod.gu...@smartplayin.com This switches memory allocations from kzalloc to devm_kzalloc. This also changes the way return checks were done on failure cases of three allocations. The

Re: [PATCH] input: ads7846: Switch to managed version of kzalloc and cleanups

2014-07-28 Thread Pramod Gurav
Thanks Dmitry for reviewing. On Mon, Jul 28, 2014 at 10:19 PM, Dmitry Torokhov dmitry.torok...@gmail.com wrote: Hi Pramod, On Mon, Jul 28, 2014 at 02:16:55PM +0530, pramod.gurav@gmail.com wrote: From: Pramod Gurav pramod.gu...@smartplayin.com This switches memory allocations from

Re: [PATCH 00/15] atmel_mxt_ts - device tree, bootloader, etc

2014-07-28 Thread Dmitry Torokhov
On Fri, Jul 25, 2014 at 02:06:40PM -0600, Stephen Warren wrote: On 07/25/2014 08:10 AM, Nick Dyer wrote: On 24/07/14 22:19, Stephen Warren wrote: ... I've uploaded 2 logs to: http://avon.wwwdotorg.org/downloads/mxt-logs/ (note there's no directory indexing, so manually add the filenames

Re: [PATCH] input: ads7846: Switch to managed version of kzalloc and cleanups

2014-07-28 Thread Dmitry Torokhov
On Mon, Jul 28, 2014 at 10:37:18PM +0530, Pramod Gurav wrote: Thanks Dmitry for reviewing. On Mon, Jul 28, 2014 at 10:19 PM, Dmitry Torokhov dmitry.torok...@gmail.com wrote: Hi Pramod, On Mon, Jul 28, 2014 at 02:16:55PM +0530, pramod.gurav@gmail.com wrote: From: Pramod Gurav

Re: [v2] input: drv260x: Add TI drv260x haptics driver

2014-07-28 Thread Dmitry Torokhov
Hi Dan, On Mon, Jul 28, 2014 at 11:53:23AM -0500, Dan Murphy wrote: Add the TI drv260x haptics/vibrator driver. This device uses the input force feedback to produce a wave form to driver an ERM or LRA actuator device. The initial driver supports the devices real time playback mode. But

Re: [PATCH v6 3/4] HID: lenovo: Don't call function in condition, show error codes

2014-07-28 Thread Dmitry Torokhov
On Sat, Jul 26, 2014 at 03:42:27PM +0100, Jamie Lentin wrote: Signed-off-by: Jamie Lentin j...@lentin.co.uk --- drivers/hid/hid-lenovo.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/hid/hid-lenovo.c b/drivers/hid/hid-lenovo.c index a56b9e7..f96bf09

Re: [PATCH 1/2] input: wacom: Support up to 2048 pressure levels with ISDv4

2014-07-28 Thread Dmitry Torokhov
On Fri, Jul 18, 2014 at 04:12:21PM -0700, Jason Gerecke wrote: On Mon, Jun 30, 2014 at 2:46 PM, Jason Gerecke killert...@gmail.com wrote: Signed-off-by: Jason Gerecke killert...@gmail.com --- drivers/input/tablet/wacom_wac.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

Re: [v2] input: drv260x: Add TI drv260x haptics driver

2014-07-28 Thread Murphy, Dan
Dmitry Thanks for the comments On 07/28/2014 12:43 PM, Dmitry Torokhov wrote: Hi Dan, On Mon, Jul 28, 2014 at 11:53:23AM -0500, Dan Murphy wrote: Add the TI drv260x haptics/vibrator driver. This device uses the input force feedback to produce a wave form to driver an ERM or LRA actuator

Re: [v2] input: drv260x: Add TI drv260x haptics driver

2014-07-28 Thread simon
The initial driver supports the devices real time playback mode. But the device has additional wave patterns in ROM. As it presented the device appears to be a memoryless device, however you present it to the rest of the system as if it can support playback of multiple effects

Re: Power-managing devices that are not of interest at some point in time

2014-07-28 Thread Patrik Fimml
(Note: Your email arrived here with lines wrapped in a hard-to-read way, not sure where the problem lies.) On Tue, Jul 22, 2014 at 01:23:14AM +0200, had...@hadess.net wrote: On 2014-07-19 01:16, Dmitry Torokhov wrote: snip I'd say no. Anyway, even though it is very tempting to declare

Re: Power-managing devices that are not of interest at some point in time

2014-07-28 Thread Patrik Fimml
On Fri, Jul 18, 2014 at 04:16:50PM -0700, Dmitry Torokhov wrote: [...] Anyway, even though it is very tempting to declare inhibit a deeper state of runtime suspend maybe you are right and inhibit should really be separate from PM and drivers would have to sort out all the possible state

Re: [PATCH 00/15] atmel_mxt_ts - device tree, bootloader, etc

2014-07-28 Thread Yufeng Shen
On Fri, Jul 25, 2014 at 4:06 PM, Stephen Warren swar...@wwwdotorg.org wrote: On 07/25/2014 08:10 AM, Nick Dyer wrote: On 24/07/14 22:19, Stephen Warren wrote: ... I've uploaded 2 logs to: http://avon.wwwdotorg.org/downloads/mxt-logs/ (note there's no directory indexing, so manually add

Re: [v2] input: drv260x: Add TI drv260x haptics driver

2014-07-28 Thread Murphy, Dan
Dmitry On 07/28/2014 12:59 PM, si...@mungewell.org wrote: The initial driver supports the devices real time playback mode. But the device has additional wave patterns in ROM. As it presented the device appears to be a memoryless device, however you present it to the rest of the system as

Re: [PATCH 00/15] atmel_mxt_ts - device tree, bootloader, etc

2014-07-28 Thread Stephen Warren
On 07/28/2014 02:20 PM, Yufeng Shen wrote: On Fri, Jul 25, 2014 at 4:06 PM, Stephen Warren swar...@wwwdotorg.org wrote: On 07/25/2014 08:10 AM, Nick Dyer wrote: On 24/07/14 22:19, Stephen Warren wrote: ... I've uploaded 2 logs to: http://avon.wwwdotorg.org/downloads/mxt-logs/ (note

Re: [PATCH 00/15] atmel_mxt_ts - device tree, bootloader, etc

2014-07-28 Thread Stephen Warren
On 07/28/2014 03:23 PM, Stephen Warren wrote: On 07/28/2014 02:20 PM, Yufeng Shen wrote: ... Where did you get the configuration file ? It is possible that we rely too much on mxt_start to turn on the T9.CTRL bit and have neglected its setting in the config file. If you can tell me where you