RE: [PATCH v13 09/12] input: cyapa: add gen5 trackpad device firmware update function support

2014-12-10 Thread Dudley Du
Jeremiah, Thank you very much for the solution. I will aplly it to my local patches immediately. Do you think it is required to re-submit the patch set right now? Thanks, Dudley -Original Message- From: linux-input-ow...@vger.kernel.org [mailto:linux-input-ow...@vger.kernel.org] On

Re: [PATCH v2 2/3] HID: wacom: Initialize MT slots for generic devices at post_parse_hid

2014-12-10 Thread Jiri Kosina
On Tue, 9 Dec 2014, Benjamin Tissoires wrote: Well, I wanted to make some cosmetic changes in 3/3 and double check that it was generic enough, but I've been sidetracked, and today I have to keep my sick daughter. Please apply my rev-by on this one only. Feel free to apply 3/3 however - if

Re: [PATCH v13 09/12] input: cyapa: add gen5 trackpad device firmware update function support

2014-12-10 Thread Jeremiah Mahler
Dudley, On Wed, Dec 10, 2014 at 09:19:19AM +, Dudley Du wrote: Jeremiah, Thank you very much for the solution. I will aplly it to my local patches immediately. Do you think it is required to re-submit the patch set right now? I think you could if you want to or you could wait to

[PATCH] Input:Optimize events_per_packet count calculation

2014-12-10 Thread anshul . g
From: Anshul Garg anshu...@samsung.com This patch avoids unnecessary operations while estimating events per packet for an input device when event type is not set. Signed-off-by: Anshul Garg anshu...@samsung.com --- drivers/input/input.c | 22 +- 1 file changed, 13

[PATCH] Input:Optimize events_per_packet count calculation

2014-12-10 Thread anshul . g
From: Anshul Garg anshu...@samsung.com This patch avoids unnecessary operations while estimating events per packet for an input device when event type is not set. Signed-off-by: Anshul Garg anshu...@samsung.com --- drivers/input/input.c | 22 +- 1 file changed, 13

[PATCH] hid: Add battery quirk for USB_DEVICE_ID_APPLE_ALU_WIRELESS_2011_ISO keyboard

2014-12-10 Thread Karl Relton
Apple bluetooth wireless keyboard (sold in UK) has always reported zero for battery strength no matter what condition the batteries are actually in. With this patch applied (applying same quirk as other Apple keyboards), the battery strength is now correctly reported. Signed-off-by: Karl Relton

Re: [systemd-devel] Supporting U2F over HID on Linux?

2014-12-10 Thread Andy Lutomirski
On Tue, Dec 9, 2014 at 12:46 PM, Andy Lutomirski l...@amacapital.net wrote: On Mon, Nov 3, 2014 at 12:41 PM, Andy Lutomirski l...@amacapital.net wrote: On Mon, Nov 3, 2014 at 12:21 PM, Jiri Kosina jkos...@suse.cz wrote: On Mon, 3 Nov 2014, David Herrmann wrote: Agreed, mostly. My only real

NULL pointer dereference in i2c-hid

2014-12-10 Thread Gabriele Mazzotta
Hi, my laptop uses a touchpad that needs hid-rmi along with i2c-hid to work. i2c-hid and hid-rmi can be loaded and unloaded independelty from each other, however since 34f439e4afcd (HID: i2c-hid: add runtime PM support) if I unload hid-rmi and after it I also unload i2c-hid, I get a NULL pointer

Re: [PATCH 2/2] Input: gpio_keys - replace timer and workqueue with delayed workqueue

2014-12-10 Thread Andy Shevchenko
On Sun, 2014-12-07 at 23:21 -0800, Dmitry Torokhov wrote: We do not need to roll our own implementation of delayed work now that we have proper implementation of mod_delayed_work. For interrupt-only driven buttons we retain the timer, but we rename it to release_timer to better reflect its

Re: [PATCH v2 3/3] HID: wacom: Report input events for each finger on generic devices

2014-12-10 Thread Benjamin Tissoires
On Fri, Dec 5, 2014 at 4:37 PM, Jason Gerecke killert...@gmail.com wrote: The existing generic touch code only reports events after reading an entire HID report, which practically means that only data about the last contact in a report will ever be provided to userspace. This patch uses a

Re: [PATCH v2] HID: rmi: Scan the report descriptor to determine if the device is suitable for the hid-rmi driver

2014-12-10 Thread Benjamin Tissoires
Hi Andrew, On Mon, Dec 8, 2014 at 7:16 PM, Andrew Duggan adug...@synaptics.com wrote: On 11/24/2014 03:37 PM, Andrew Duggan wrote: On composite HID devices there may be multiple HID devices on separate interfaces, but hid-rmi should only bind to the touchpad. The previous version simply

Re: [PATCH] HID: rmi: Add support for the touchpad in the Razer Blade 14 laptop

2014-12-10 Thread Benjamin Tissoires
On Mon, Dec 8, 2014 at 7:16 PM, Andrew Duggan adug...@synaptics.com wrote: On 11/24/2014 04:20 PM, Andrew Duggan wrote: The Razer Blade 14 has a Synaptic's TouchPad on one of the interfaces of a composite USB device. This patch allows the hid-rmi driver to bind to that interface. It also adds

[PATCH 2/2] HID: logitech-hidpp: prefix the name with Logitech

2014-12-10 Thread Benjamin Tissoires
Current names are reported as K750, M705, and it can be misleading for the users when they look at their input device list. Prefixing the names with Logitech makes things better. Signed-off-by: Benjamin Tissoires benjamin.tissoi...@redhat.com --- Hi Jiri, I'd love to see this one in 3.19

[PATCH 1/2] HID: logitech-hidpp: do not return the name length

2014-12-10 Thread Benjamin Tissoires
We do not make any use of the actual name length get through hidpp_get_device_name(). We can drop the extra code and simplify the API a bit. Signed-off-by: Benjamin Tissoires benjamin.tissoi...@redhat.com --- drivers/hid/hid-logitech-hidpp.c | 10 +++--- 1 file changed, 3 insertions(+), 7

Re: [PATCH 1/2] HID: logitech-hidpp: do not return the name length

2014-12-10 Thread Peter Wu
On Wednesday 10 December 2014 17:21:09 Benjamin Tissoires wrote: We do not make any use of the actual name length get through hidpp_get_device_name(). We can drop the extra code and simplify the API a bit. Signed-off-by: Benjamin Tissoires benjamin.tissoi...@redhat.com ---

Re: [PATCH v2 3/3] HID: wacom: Report input events for each finger on generic devices

2014-12-10 Thread Jason Gerecke
On Wed, Dec 10, 2014 at 12:25 PM, Benjamin Tissoires benjamin.tissoi...@gmail.com wrote: On Fri, Dec 5, 2014 at 4:37 PM, Jason Gerecke killert...@gmail.com wrote: The existing generic touch code only reports events after reading an entire HID report, which practically means that only data about

Re: [PATCH 2/2] HID: logitech-hidpp: prefix the name with Logitech

2014-12-10 Thread Peter Wu
On Wednesday 10 December 2014 17:21:10 Benjamin Tissoires wrote: Current names are reported as K750, M705, and it can be misleading for the users when they look at their input device list. Prefixing the names with Logitech makes things better. Doesn't this apply to all input devices? Like,

Re: [PATCH 2/2] HID: logitech-hidpp: prefix the name with Logitech

2014-12-10 Thread Benjamin Tissoires
On Dec 11 2014 or thereabouts, Peter Wu wrote: On Wednesday 10 December 2014 17:21:10 Benjamin Tissoires wrote: Current names are reported as K750, M705, and it can be misleading for the users when they look at their input device list. Prefixing the names with Logitech makes things

Re: [PATCH 1/2] HID: logitech-hidpp: do not return the name length

2014-12-10 Thread Benjamin Tissoires
On Dec 10 2014 or thereabouts, Peter Wu wrote: On Wednesday 10 December 2014 17:21:09 Benjamin Tissoires wrote: We do not make any use of the actual name length get through hidpp_get_device_name(). We can drop the extra code and simplify the API a bit. Signed-off-by: Benjamin

Re: [PATCH v2 3/3] HID: wacom: Report input events for each finger on generic devices

2014-12-10 Thread Benjamin Tissoires
On Wed, Dec 10, 2014 at 6:01 PM, Jason Gerecke killert...@gmail.com wrote: On Wed, Dec 10, 2014 at 12:25 PM, Benjamin Tissoires benjamin.tissoi...@gmail.com wrote: On Fri, Dec 5, 2014 at 4:37 PM, Jason Gerecke killert...@gmail.com wrote: The existing generic touch code only reports events

Re: [PATCH 1/2] HID: logitech-hidpp: do not return the name length

2014-12-10 Thread Peter Wu
On Wednesday 10 December 2014 18:01:52 Benjamin Tissoires wrote: On Dec 10 2014 or thereabouts, Peter Wu wrote: On Wednesday 10 December 2014 17:21:09 Benjamin Tissoires wrote: We do not make any use of the actual name length get through hidpp_get_device_name(). We can drop the

[PATCH v3 3/3] HID: wacom: Report input events for each finger on generic devices

2014-12-10 Thread Jason Gerecke
The existing generic touch code only reports events after reading an entire HID report, which practically means that only data about the last contact in a report will ever be provided to userspace. This patch uses a trick from hid-multitouch.c to discover what type of field is at the end of each

Re: [PATCH] HID: rmi: Add support for the touchpad in the Razer Blade 14 laptop

2014-12-10 Thread Andrew Duggan
Hi Benjamin, Thanks for reviewing my patch. Comments and questions below. On 12/10/2014 12:51 PM, Benjamin Tissoires wrote: On Mon, Dec 8, 2014 at 7:16 PM, Andrew Duggan adug...@synaptics.com wrote: On 11/24/2014 04:20 PM, Andrew Duggan wrote: The Razer Blade 14 has a Synaptic's TouchPad on

Re: [PATCH] HID: rmi: Add support for the touchpad in the Razer Blade 14 laptop

2014-12-10 Thread Benjamin Tissoires
On Wed, Dec 10, 2014 at 8:00 PM, Andrew Duggan adug...@synaptics.com wrote: Hi Benjamin, Thanks for reviewing my patch. Comments and questions below. On 12/10/2014 12:51 PM, Benjamin Tissoires wrote: On Mon, Dec 8, 2014 at 7:16 PM, Andrew Duggan adug...@synaptics.com wrote: On 11/24/2014

Re: [PATCH 1/2] HID: logitech-hidpp: do not return the name length

2014-12-10 Thread Benjamin Tissoires
On Dec 11 2014 or thereabouts, Peter Wu wrote: On Wednesday 10 December 2014 18:01:52 Benjamin Tissoires wrote: On Dec 10 2014 or thereabouts, Peter Wu wrote: On Wednesday 10 December 2014 17:21:09 Benjamin Tissoires wrote: We do not make any use of the actual name length get through