Re: [PATCH 4/4] HID: usbhid: use to_usb_device

2015-12-28 Thread Jiri Kosina
On Wed, 23 Dec 2015, Geliang Tang wrote:

> Use to_usb_device() instead of open-coding it.
> 
> Signed-off-by: Geliang Tang 
> ---
>  drivers/hid/usbhid/usbhid.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/hid/usbhid/usbhid.h b/drivers/hid/usbhid/usbhid.h
> index 807922b..fa47d66 100644
> --- a/drivers/hid/usbhid/usbhid.h
> +++ b/drivers/hid/usbhid/usbhid.h
> @@ -96,7 +96,7 @@ struct usbhid_device {
>  };
>  
>  #define  hid_to_usb_dev(hid_dev) \
> - container_of(hid_dev->dev.parent->parent, struct usb_device, dev)
> + to_usb_device(hid_dev->dev.parent->parent)

Applied to hid.git#for-4.5/upstream.

-- 
Jiri Kosina
SUSE Labs

--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 4/4] HID: usbhid: use to_usb_device

2015-12-23 Thread Geliang Tang
Use to_usb_device() instead of open-coding it.

Signed-off-by: Geliang Tang 
---
 drivers/hid/usbhid/usbhid.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/hid/usbhid/usbhid.h b/drivers/hid/usbhid/usbhid.h
index 807922b..fa47d66 100644
--- a/drivers/hid/usbhid/usbhid.h
+++ b/drivers/hid/usbhid/usbhid.h
@@ -96,7 +96,7 @@ struct usbhid_device {
 };
 
 #definehid_to_usb_dev(hid_dev) \
-   container_of(hid_dev->dev.parent->parent, struct usb_device, dev)
+   to_usb_device(hid_dev->dev.parent->parent)
 
 #endif
 
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html