[rcu:dev.2017.05.06a 80/80] make[2]: *** No rule to make target 'kernel/header-test.o', needed by 'kernel/built-in.o'.

2017-05-07 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/paulmck/linux-rcu.git dev.2017.05.06a head: e6184d80f67541ddceb62fb4262e793c13035045 commit: e6184d80f67541ddceb62fb4262e793c13035045 [80/80] rcu: Remove seqlock.h include from rcupdate.h config: x86_64-kexec (attached as .config)

[rcu:dev.2017.05.06a 80/80] make[2]: *** No rule to make target 'kernel/header-test.o', needed by 'kernel/built-in.o'.

2017-05-07 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/paulmck/linux-rcu.git dev.2017.05.06a head: e6184d80f67541ddceb62fb4262e793c13035045 commit: e6184d80f67541ddceb62fb4262e793c13035045 [80/80] rcu: Remove seqlock.h include from rcupdate.h config: x86_64-kexec (attached as .config)

[PATCH 4/4] s390/sysinfo: Combine two function calls into one

2017-05-07 Thread SF Markus Elfring
From: Markus Elfring Date: Sun, 7 May 2017 18:48:39 +0200 A bit of data was put into a sequence by two separate function calls at four places. Print the same data by single function calls instead. Signed-off-by: Markus Elfring ---

[PATCH v2] drm/rockchip: analogix_dp: add supports for regulators in edp IP

2017-05-07 Thread Randy Li
I found if eDP_AVDD_1V0 and eDP_AVDD_1V8 are not been power at RK3288, once trying to enable the pclk clock, the kernel would dead. This patch would try to enable them first. The eDP_AVDD_1V8 is used for eDP phy, and the eDP_AVDD_1V0 are used both for eDP phy and controller. Change-Id:

[PATCH 4/4] s390/sysinfo: Combine two function calls into one

2017-05-07 Thread SF Markus Elfring
From: Markus Elfring Date: Sun, 7 May 2017 18:48:39 +0200 A bit of data was put into a sequence by two separate function calls at four places. Print the same data by single function calls instead. Signed-off-by: Markus Elfring --- arch/s390/kernel/sysinfo.c | 13 + 1 file changed,

[PATCH v2] drm/rockchip: analogix_dp: add supports for regulators in edp IP

2017-05-07 Thread Randy Li
I found if eDP_AVDD_1V0 and eDP_AVDD_1V8 are not been power at RK3288, once trying to enable the pclk clock, the kernel would dead. This patch would try to enable them first. The eDP_AVDD_1V8 is used for eDP phy, and the eDP_AVDD_1V0 are used both for eDP phy and controller. Change-Id:

[PATCH 1/2] drivers: staging: media: atomisp: fixed coding style errors

2017-05-07 Thread Avraham Shukron
Fix for error (not warnings) reported by checkpatch.pl Specifically: - missing whitespace around "=" and after "," - indentation with spaces instead of tabs - lines starting with a whitespace This patch does not affect the compiled code in any way. Signed-off-by: Avraham Shukron

[PATCH 1/2] drivers: staging: media: atomisp: fixed coding style errors

2017-05-07 Thread Avraham Shukron
Fix for error (not warnings) reported by checkpatch.pl Specifically: - missing whitespace around "=" and after "," - indentation with spaces instead of tabs - lines starting with a whitespace This patch does not affect the compiled code in any way. Signed-off-by: Avraham Shukron ---

Re: [PATCH] char: random: casting prevents missing calculations

2017-05-07 Thread Arnd Bergmann
On Sun, May 7, 2017 at 9:58 PM, Karim Eshapa wrote: > On Sun, 7 May 2017 20:36:55 +0200, Arnd Bergmann wrote: >>On Sun, May 7, 2017 at 2:47 PM, Karim Eshapa wrote: >>> Cast (long)jiffies and (long)state->last_time beacause >>> they tends to

Re: [PATCH] char: random: casting prevents missing calculations

2017-05-07 Thread Arnd Bergmann
On Sun, May 7, 2017 at 9:58 PM, Karim Eshapa wrote: > On Sun, 7 May 2017 20:36:55 +0200, Arnd Bergmann wrote: >>On Sun, May 7, 2017 at 2:47 PM, Karim Eshapa wrote: >>> Cast (long)jiffies and (long)state->last_time beacause >>> they tends to unsigned long. may cause a problem specially >>> when

Re: [PATCH 7/7] DWARF: add the config option

2017-05-07 Thread Josh Poimboeuf
On Fri, May 05, 2017 at 12:57:11PM -0700, Linus Torvalds wrote: > On Fri, May 5, 2017 at 5:22 AM, Jiri Slaby wrote: > > The DWARF unwinder is in place and ready. So introduce the config option > > to allow users to enable it. It is by default off due to missing > > assembly

Re: [PATCH 7/7] DWARF: add the config option

2017-05-07 Thread Josh Poimboeuf
On Fri, May 05, 2017 at 12:57:11PM -0700, Linus Torvalds wrote: > On Fri, May 5, 2017 at 5:22 AM, Jiri Slaby wrote: > > The DWARF unwinder is in place and ready. So introduce the config option > > to allow users to enable it. It is by default off due to missing > > assembly annotations. > > Who

[PATCH] leds/trigger: system can't enter suspend.

2017-05-07 Thread sanshan zhang
From: zhang sanshan system can't enter suspend when enable led heartbeat. pm will call heartbeat_pm_notifier when suspend. system will prepare led states, and led_trigger_unregister will use led_trigger_set to set trigger. kobject_uevent_env will send event,it will call

[PATCH] leds/trigger: system can't enter suspend.

2017-05-07 Thread sanshan zhang
From: zhang sanshan system can't enter suspend when enable led heartbeat. pm will call heartbeat_pm_notifier when suspend. system will prepare led states, and led_trigger_unregister will use led_trigger_set to set trigger. kobject_uevent_env will send event,it will call ep_poll_callback to hold

[PATCH 3/4] s390/sysinfo: Replace six seq_printf() calls by seq_puts()

2017-05-07 Thread SF Markus Elfring
From: Markus Elfring Date: Sun, 7 May 2017 18:18:45 +0200 Six strings which did not contain data format specifications should be put into a sequence. Thus use the corresponding function "seq_puts". This issue was detected by using the Coccinelle software.

[PATCH 3/4] s390/sysinfo: Replace six seq_printf() calls by seq_puts()

2017-05-07 Thread SF Markus Elfring
From: Markus Elfring Date: Sun, 7 May 2017 18:18:45 +0200 Six strings which did not contain data format specifications should be put into a sequence. Thus use the corresponding function "seq_puts". This issue was detected by using the Coccinelle software. Signed-off-by: Markus Elfring ---

RE: [PATCH v9 5/5] virtio-balloon: VIRTIO_BALLOON_F_MISC_VQ

2017-05-07 Thread Wang, Wei W
On 05/06/2017 06:21 AM, Michael S. Tsirkin wrote: > On Thu, Apr 27, 2017 at 02:33:44PM +0800, Wei Wang wrote: > > On 04/14/2017 01:08 AM, Michael S. Tsirkin wrote: > > > On Thu, Apr 13, 2017 at 05:35:08PM +0800, Wei Wang wrote: > > > > Add a new vq, miscq, to handle miscellaneous requests between

[PATCH v3] staging: rtl8723bs: remove re-positioned call to kfree in os_dep/ioctl_cfg80211.c

2017-05-07 Thread Ian W MORRISON
A kernel cloned from git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git and built with the latest RTL8723BS driver included (CONFIG_RTL8723BS=m) fails when booting on an Intel Atom device with the RTL8723BS wifi chipset due to an error in

RE: [PATCH v9 5/5] virtio-balloon: VIRTIO_BALLOON_F_MISC_VQ

2017-05-07 Thread Wang, Wei W
On 05/06/2017 06:21 AM, Michael S. Tsirkin wrote: > On Thu, Apr 27, 2017 at 02:33:44PM +0800, Wei Wang wrote: > > On 04/14/2017 01:08 AM, Michael S. Tsirkin wrote: > > > On Thu, Apr 13, 2017 at 05:35:08PM +0800, Wei Wang wrote: > > > > Add a new vq, miscq, to handle miscellaneous requests between

[PATCH v3] staging: rtl8723bs: remove re-positioned call to kfree in os_dep/ioctl_cfg80211.c

2017-05-07 Thread Ian W MORRISON
A kernel cloned from git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git and built with the latest RTL8723BS driver included (CONFIG_RTL8723BS=m) fails when booting on an Intel Atom device with the RTL8723BS wifi chipset due to an error in

[PATCH] PM / Domains: Use seq_putc() in pm_genpd_summary_one()

2017-05-07 Thread SF Markus Elfring
From: Markus Elfring Date: Sun, 7 May 2017 22:26:19 +0200 A single character (line break) should be put into a sequence. Thus use the corresponding function "seq_putc". This issue was detected by using the Coccinelle software. Signed-off-by: Markus Elfring

Re: [PATCH v5 01/10] pinctrl: generic: Add bi-directional and output-enable

2017-05-07 Thread Linus Walleij
On Fri, Apr 28, 2017 at 12:09 PM, Geert Uytterhoeven wrote: >> You can certainly call it whatever the datasheet calls it >> in your driver #defines but for the DT bindings we would >> ideally have the physical world things. > > FWIW, you have already applied v4. Yeah I

[PATCH] PM / Domains: Use seq_putc() in pm_genpd_summary_one()

2017-05-07 Thread SF Markus Elfring
From: Markus Elfring Date: Sun, 7 May 2017 22:26:19 +0200 A single character (line break) should be put into a sequence. Thus use the corresponding function "seq_putc". This issue was detected by using the Coccinelle software. Signed-off-by: Markus Elfring --- drivers/base/power/domain.c | 2

Re: [PATCH v5 01/10] pinctrl: generic: Add bi-directional and output-enable

2017-05-07 Thread Linus Walleij
On Fri, Apr 28, 2017 at 12:09 PM, Geert Uytterhoeven wrote: >> You can certainly call it whatever the datasheet calls it >> in your driver #defines but for the DT bindings we would >> ideally have the physical world things. > > FWIW, you have already applied v4. Yeah I noticed when sending pull

RE: [PATCH v10 3/6] virtio-balloon: VIRTIO_BALLOON_F_PAGE_CHUNKS

2017-05-07 Thread Wang, Wei W
On 05/06/2017 06:29 AM, Michael S. Tsirkin wrote: > On Thu, May 04, 2017 at 04:50:12PM +0800, Wei Wang wrote: > > Add a new feature, VIRTIO_BALLOON_F_PAGE_CHUNKS, which enables the > > transfer of the ballooned (i.e. inflated/deflated) pages in chunks to > > the host. > > > > The implementation of

RE: [PATCH v10 3/6] virtio-balloon: VIRTIO_BALLOON_F_PAGE_CHUNKS

2017-05-07 Thread Wang, Wei W
On 05/06/2017 06:29 AM, Michael S. Tsirkin wrote: > On Thu, May 04, 2017 at 04:50:12PM +0800, Wei Wang wrote: > > Add a new feature, VIRTIO_BALLOON_F_PAGE_CHUNKS, which enables the > > transfer of the ballooned (i.e. inflated/deflated) pages in chunks to > > the host. > > > > The implementation of

Re: [PATCH] char: random: casting prevents missing calculations

2017-05-07 Thread Arnd Bergmann
On Sun, May 7, 2017 at 2:47 PM, Karim Eshapa wrote: > Cast (long)jiffies and (long)state->last_time beacause > they tends to unsigned long. may cause a problem specially > when comparison happens (< 0). > > Signed-off-by: Karim Eshapa I don't

Re: [PATCH] char: random: casting prevents missing calculations

2017-05-07 Thread Arnd Bergmann
On Sun, May 7, 2017 at 2:47 PM, Karim Eshapa wrote: > Cast (long)jiffies and (long)state->last_time beacause > they tends to unsigned long. may cause a problem specially > when comparison happens (< 0). > > Signed-off-by: Karim Eshapa I don't understand what you are saying above, and the patch

RE: [virtio-dev] Re: [PATCH v9 2/5] virtio-balloon: VIRTIO_BALLOON_F_BALLOON_CHUNKS

2017-05-07 Thread Wang, Wei W
On 05/06/2017 06:26 AM, Michael S. Tsirkin wrote: > On Thu, Apr 27, 2017 at 02:31:49PM +0800, Wei Wang wrote: > > On 04/27/2017 07:20 AM, Michael S. Tsirkin wrote: > > > On Wed, Apr 26, 2017 at 11:03:34AM +, Wang, Wei W wrote: > > > > Hi Michael, could you please give some feedback? > > > I'm

Re: [PATCH 1/3] ARM: dts: rockchip: Move cros-ec-sbs to rk3288-veyron-chromebook-sbs

2017-05-07 Thread Paul Kocialkowski
Hi, Le lundi 01 mai 2017 à 08:49 -0700, Doug Anderson a écrit : > On Mon, May 1, 2017 at 7:07 AM, Heiko Stuebner wrote: > > Am Sonntag, 30. April 2017, 22:56:52 CEST schrieb Paul Kocialkowski: > > > Le dimanche 30 avril 2017 à 22:37 +0200, Heiko Stuebner a écrit : > > > > Hi

[PATCH 2/2] i2c: mux: reg: rename label to indicate what it does

2017-05-07 Thread Peter Rosin
That maintains sanity if it is ever called from some other spot, and also makes the label names coherent. Signed-off-by: Peter Rosin --- drivers/i2c/muxes/i2c-mux-reg.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/i2c/muxes/i2c-mux-reg.c

RE: [virtio-dev] Re: [PATCH v9 2/5] virtio-balloon: VIRTIO_BALLOON_F_BALLOON_CHUNKS

2017-05-07 Thread Wang, Wei W
On 05/06/2017 06:26 AM, Michael S. Tsirkin wrote: > On Thu, Apr 27, 2017 at 02:31:49PM +0800, Wei Wang wrote: > > On 04/27/2017 07:20 AM, Michael S. Tsirkin wrote: > > > On Wed, Apr 26, 2017 at 11:03:34AM +, Wang, Wei W wrote: > > > > Hi Michael, could you please give some feedback? > > > I'm

Re: [PATCH 1/3] ARM: dts: rockchip: Move cros-ec-sbs to rk3288-veyron-chromebook-sbs

2017-05-07 Thread Paul Kocialkowski
Hi, Le lundi 01 mai 2017 à 08:49 -0700, Doug Anderson a écrit : > On Mon, May 1, 2017 at 7:07 AM, Heiko Stuebner wrote: > > Am Sonntag, 30. April 2017, 22:56:52 CEST schrieb Paul Kocialkowski: > > > Le dimanche 30 avril 2017 à 22:37 +0200, Heiko Stuebner a écrit : > > > > Hi Paul, > > > > > > >

[PATCH 2/2] i2c: mux: reg: rename label to indicate what it does

2017-05-07 Thread Peter Rosin
That maintains sanity if it is ever called from some other spot, and also makes the label names coherent. Signed-off-by: Peter Rosin --- drivers/i2c/muxes/i2c-mux-reg.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/i2c/muxes/i2c-mux-reg.c

[PATCH] ARM: dts: rockchip: add missing grf phandle for rk3288

2017-05-07 Thread Randy Li
The PWM devices need to access the grf to switch the PWM IP. And tsadc uses it to shutdown the system. Signed-off-by: Randy Li --- arch/arm/boot/dts/rk3288.dtsi | 5 + 1 file changed, 5 insertions(+) diff --git a/arch/arm/boot/dts/rk3288.dtsi

[PATCH 1/2] i2c: mux: reg: put away the parent i2c adapter on probe failure

2017-05-07 Thread Peter Rosin
It is only prudent to let go of resources that are not used. Fixes: b3fdd32799d8 ("i2c: mux: Add register-based mux i2c-mux-reg") Signed-off-by: Peter Rosin --- drivers/i2c/muxes/i2c-mux-reg.c | 17 - 1 file changed, 12 insertions(+), 5 deletions(-) diff --git

[PATCH] ARM: dts: rockchip: add missing grf phandle for rk3288

2017-05-07 Thread Randy Li
The PWM devices need to access the grf to switch the PWM IP. And tsadc uses it to shutdown the system. Signed-off-by: Randy Li --- arch/arm/boot/dts/rk3288.dtsi | 5 + 1 file changed, 5 insertions(+) diff --git a/arch/arm/boot/dts/rk3288.dtsi b/arch/arm/boot/dts/rk3288.dtsi index

[PATCH 1/2] i2c: mux: reg: put away the parent i2c adapter on probe failure

2017-05-07 Thread Peter Rosin
It is only prudent to let go of resources that are not used. Fixes: b3fdd32799d8 ("i2c: mux: Add register-based mux i2c-mux-reg") Signed-off-by: Peter Rosin --- drivers/i2c/muxes/i2c-mux-reg.c | 17 - 1 file changed, 12 insertions(+), 5 deletions(-) diff --git

Re: [PATCH 7/7] DWARF: add the config option

2017-05-07 Thread Ingo Molnar
* Josh Poimboeuf wrote: > One instance of the structure would exist for each time the stack > pointer changes, e.g. for every function entry, push/pop, and rsp > add/subtract. The data could be assembled and sorted offline, possibly > derived from DWARF, or more likely,

Re: [PATCH 7/7] DWARF: add the config option

2017-05-07 Thread Ingo Molnar
* Josh Poimboeuf wrote: > One instance of the structure would exist for each time the stack > pointer changes, e.g. for every function entry, push/pop, and rsp > add/subtract. The data could be assembled and sorted offline, possibly > derived from DWARF, or more likely, generated by objtool.

[PATCH 2/2] Staging: rtl8712: ieee80211: fixed camelcase coding style issue

2017-05-07 Thread Jaya Durga
Fixed coding style issue Signed-off-by: Jaya Durga --- drivers/staging/rtl8712/ieee80211.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/rtl8712/ieee80211.c b/drivers/staging/rtl8712/ieee80211.c index 512bf16..66d9daf 100644

[PATCH 2/2] Staging: rtl8712: ieee80211: fixed camelcase coding style issue

2017-05-07 Thread Jaya Durga
Fixed coding style issue Signed-off-by: Jaya Durga --- drivers/staging/rtl8712/ieee80211.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/rtl8712/ieee80211.c b/drivers/staging/rtl8712/ieee80211.c index 512bf16..66d9daf 100644 ---

Re: [PATCH v3 1/2] thermal: core: Allow orderly_poweroff to be called only once

2017-05-07 Thread Pavel Machek
> thermal_zone_device_check --> thermal_zone_device_update --> > handle_thermal_trip --> handle_critical_trips --> orderly_poweroff > > The above sequence happens every 250/500 mS based on the configuration. > The orderly_poweroff function is getting called every 250/500 mS. > With a full fledged

Re: [PATCH] platform/x86: toshiba_acpi: use memdup_user_nul

2017-05-07 Thread Andy Shevchenko
On Sat, May 6, 2017 at 6:40 PM, Geliang Tang wrote: > Use memdup_user_nul() helper instead of open-coding to simplify the > code. > Pushed to testing, thanks. > Signed-off-by: Geliang Tang > --- > drivers/platform/x86/toshiba_acpi.c | 11

Re: [PATCH v3 1/2] thermal: core: Allow orderly_poweroff to be called only once

2017-05-07 Thread Pavel Machek
> thermal_zone_device_check --> thermal_zone_device_update --> > handle_thermal_trip --> handle_critical_trips --> orderly_poweroff > > The above sequence happens every 250/500 mS based on the configuration. > The orderly_poweroff function is getting called every 250/500 mS. > With a full fledged

Re: [PATCH] platform/x86: toshiba_acpi: use memdup_user_nul

2017-05-07 Thread Andy Shevchenko
On Sat, May 6, 2017 at 6:40 PM, Geliang Tang wrote: > Use memdup_user_nul() helper instead of open-coding to simplify the > code. > Pushed to testing, thanks. > Signed-off-by: Geliang Tang > --- > drivers/platform/x86/toshiba_acpi.c | 11 +++ > 1 file changed, 3 insertions(+), 8

Re: [PATCHv3 1/2] Input: pwm-vibra: new driver

2017-05-07 Thread Dmitry Torokhov
Hi Sebastian, On Fri, May 05, 2017 at 11:28:22AM +0200, Sebastian Reichel wrote: > Provide a simple driver for PWM controllable vibrators. It > will be used by Motorola Droid 4. > > Tested-by: Tony Lindgren > Signed-off-by: Sebastian Reichel

Re: [PATCHv3 1/2] Input: pwm-vibra: new driver

2017-05-07 Thread Dmitry Torokhov
Hi Sebastian, On Fri, May 05, 2017 at 11:28:22AM +0200, Sebastian Reichel wrote: > Provide a simple driver for PWM controllable vibrators. It > will be used by Motorola Droid 4. > > Tested-by: Tony Lindgren > Signed-off-by: Sebastian Reichel > --- > Changes since PATCHv1: > - move driver

<    1   2   3   4   5